summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRémi Verschelde <rverschelde@gmail.com>2023-12-01 10:45:02 +0100
committerRémi Verschelde <rverschelde@gmail.com>2023-12-01 10:45:07 +0100
commit41517eacb1115e5020af8c305492f6c77ffa89bc (patch)
tree72bc61e312bb1429a9015f18d3dca6bb1f7b920b /CMakeLists.txt
parent17137b2e2ecdeb5638a885d28498164d35a2130d (diff)
downloadredot-cpp-41517eacb1115e5020af8c305492f6c77ffa89bc.tar.gz
CMake: Remove hardcoded warnings list and forcing -Werror on library builds
The CMake buildsystem should be completely reviewed to properly match what is done by SCons, instead of making its own arbitrary decisions on how godot-cpp should be compiled. Currently the SCons setup doesn't include warning options, so CMake shouldn't either. Options similar to upstream Godot's SCons setup could be added, and then replicated for CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75ff500..e715102 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,11 +47,6 @@ option(GODOT_CPP_WARNING_AS_ERROR "Treat warnings as errors" OFF)
# Add path to modules
list( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/" )
-# Check if we are building ourself or being included
-if(${PROJECT_NAME} STREQUAL ${CMAKE_PROJECT_NAME})
- set(GODOT_CPP_BUILDING_SELF ON)
-endif()
-
# Set some helper variables for readability
set( compiler_is_clang "$<OR:$<CXX_COMPILER_ID:AppleClang>,$<CXX_COMPILER_ID:Clang>>" )
set( compiler_is_gnu "$<CXX_COMPILER_ID:GNU>" )
@@ -158,12 +153,6 @@ add_library(godot::cpp ALIAS ${PROJECT_NAME})
include(GodotCompilerWarnings)
-# Treat warnings as errors if we are building ourself
-if(GODOT_CPP_BUILDING_SELF)
- unset( GODOT_CPP_WARNING_AS_ERROR CACHE )
- set_warning_as_error()
-endif()
-
target_compile_features(${PROJECT_NAME}
PRIVATE
cxx_std_17