summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThaddeus Crews <repiteo@outlook.com>2024-06-24 12:20:55 -0500
committerThaddeus Crews <repiteo@outlook.com>2024-06-24 15:43:55 -0500
commite0d363aad8e2204fe8ca4b6937ef2ad74a7b293b (patch)
treec8300e4864984e9157ba8502ee019c4cd7226128 /pyproject.toml
parentc414c2b37d0563456a2fe194b16f8c4aa442e865 (diff)
downloadredot-cpp-e0d363aad8e2204fe8ca4b6937ef2ad74a7b293b.tar.gz
Integrate `.pre-commit-config.yaml`
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..0e9c4b4
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,58 @@
+[tool.mypy]
+disallow_any_generics = true
+explicit_package_bases = true
+ignore_missing_imports = true
+namespace_packages = true
+no_implicit_optional = true
+pretty = true
+scripts_are_modules = true
+show_column_numbers = true
+warn_redundant_casts = true
+warn_return_any = true
+warn_unreachable = true
+
+[tool.ruff]
+extend-include = ["SConstruct"]
+line-length = 120
+target-version = "py37"
+
+[tool.ruff.lint]
+extend-select = [
+ "I", # isort
+]
+
+[tool.ruff.lint.per-file-ignores]
+"SConstruct" = [
+ "F821", # Undefined name
+]
+
+[tool.codespell]
+enable-colors = ""
+write-changes = ""
+check-hidden = ""
+quiet-level = 3
+builtin = "clear,rare,en-GB_to_en-US"
+ignore-words-list = """\
+ breaked,
+ cancelled,
+ checkin,
+ curvelinear,
+ doubleclick,
+ expct,
+ findn,
+ gird,
+ hel,
+ inout,
+ labelin,
+ lod,
+ mis,
+ nd,
+ numer,
+ ot,
+ outin,
+ requestor,
+ te,
+ textin,
+ thirdparty,
+ vai
+"""