Commit message (Collapse) | Author | Age | Files | Lines | ||
---|---|---|---|---|---|---|
... | ||||||
* | Improve Directory content navigation | Tomasz Chabora | 2021-12-10 | 1 | -7/+54 | |
| | ||||||
* | Replace String comparisons with "", String() to is_empty() | Nathan Franke | 2021-12-09 | 1 | -4/+4 | |
| | | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings | |||||
* | Add an `OS.crash()` method for testing system crash handler | Hugo Locurcio | 2021-12-03 | 1 | -0/+5 | |
| | | | | | This makes it possible to test the system's crash handler without having to modify engine code or exploit an engine bug. | |||||
* | Expose Thread::get_main_id in core bindings | Brian Semrau | 2021-11-12 | 1 | -0/+5 | |
| | ||||||
* | Use "enum class" for input enums | Aaron Franke | 2021-11-12 | 1 | -4/+4 | |
| | ||||||
* | [macOS] Add `create_instance` function to spawn editor copies. | bruvzg | 2021-11-01 | 1 | -0/+14 | |
| | | | | [macOS] Modify `create_project` function to detect and run app bundles using NSWorkspace to ensure app window is registered and activated correctly. | |||||
* | Use OpenGL 3.3 core profile instead of compatibility profile | Clay John | 2021-10-31 | 1 | -1/+1 | |
| | | | | | | | | | | - Rename OpenGL to GLES3 in the source code per community feedback. - The renderer is still exposed as "OpenGL 3" to the user. - Hide renderer selection dropdown until OpenGL support is more mature. - The renderer can still be changed in the Project Settings or using the `--rendering-driver opengl` command line argument. - Remove commented out exporter code. - Remove some OpenGL/DisplayServer-related debugging prints. | |||||
* | Rename GLES2 driver to OpenGL to prepare for the upgrade to GLES3 | Hugo Locurcio | 2021-10-30 | 1 | -1/+1 | |
| | | | | | - Use lowercase driver names for the `--rendering-driver` command line argument. | |||||
* | Added better descriptive error messages for file operations in core_bind.cpp | unknown | 2021-10-18 | 1 | -33/+33 | |
| | ||||||
* | [core_bind] Add `is_alive` to Thread. Replace `is_active` with `is_started`. | Brian Semrau | 2021-10-06 | 1 | -7/+15 | |
| | | | | Replacing `is_active` resolves an API discrepancy between core_bind Thread and core/os Thread. | |||||
* | Merge pull request #53059 from timothyqiu/thread-obj | Rémi Verschelde | 2021-10-02 | 1 | -4/+12 | |
|\ | | | | | Fix crash when creating thread | |||||
| * | Fix crash when creating thread | Haoyu Qiu | 2021-09-29 | 1 | -4/+12 | |
| | | ||||||
* | | Use range iterators for `Map` | Lightning_A | 2021-09-30 | 1 | -4/+4 | |
|/ | ||||||
* | Merge pull request #53053 from LATRio/callable_in_thread_start | Rémi Verschelde | 2021-09-28 | 1 | -32/+11 | |
|\ | ||||||
| * | Use Callable in Thread::start | LATRio | 2021-09-25 | 1 | -32/+11 | |
| | | ||||||
* | | Fix inversed check inside register_singleton | Hennadii Chernyshchyk | 2021-09-28 | 1 | -1/+1 | |
| | | ||||||
* | | Remove `Engine.editor_hint` in favor of `Engine.is_editor_hint()` | Hugo Locurcio | 2021-09-20 | 1 | -2/+0 | |
|/ | | | | | | The `Engine.set_editor_hint()` setter method is no longer exposed to scripting, which makes the property effectively read-only from an user perspective. | |||||
* | Implement `OS::get_locale_language()` helper method | Rémi Verschelde | 2021-09-16 | 1 | -0/+5 | |
| | | | | | | | | | This method extracts the 2 or 3-letter language code from `OS::get_locale()`, making it easier for users to identify the "main" language code for users that might have different OS locales due to different OS or region, but should be matched to the same translation (e.g. "generic" Spanish). Fixes #40703. | |||||
* | Expose enum related methods in ClassDB | Haoyu Qiu | 2021-09-11 | 1 | -0/+41 | |
| | ||||||
* | Rename String::is_rel_path to String::is_relative_path | Wilson E. Alvarez | 2021-08-29 | 1 | -6/+6 | |
| | ||||||
* | Add ability to register singletons from engine API | reduz | 2021-08-25 | 1 | -2/+33 | |
| | | | | | * Exposed functions in Engine to register and unregister singletons. * Added the concept of user singletons, which can be removed (the system ones can't). | |||||
* | Merge pull request #51627 from mhilbrunner/todo-for-neikeq | Rémi Verschelde | 2021-08-18 | 1 | -707/+715 | |
|\ | ||||||
| * | Namespaces instead of underscore prefix for binds | Max Hilbrunner | 2021-08-17 | 1 | -707/+715 | |
| | | | | | | | | | | | | Thanks to neikeq for the initial work. Co-authored-by: Ignacio Roldán Etcheverry <neikeq@users.noreply.github.com> | |||||
* | | Merge pull request #51793 from KoBeWi/direnam | Rémi Verschelde | 2021-08-17 | 1 | -2/+4 | |
|\ \ | |/ |/| | Fix renaming directories | |||||
| * | Fix renaming directories | kobewi | 2021-08-17 | 1 | -2/+4 | |
| | | ||||||
* | | Add partial support for Android scoped storage. | ne0fhyk | 2021-08-16 | 1 | -8/+3 | |
|/ | | | | | This is done by providing API access to app specific directories which don't have any limitations and allows us to bump the target sdk version to 30. In addition, we're also bumping the min sdk version to 19 as version 18 is no longer supported by Google Play Services and only account of 0.3% of Android devices. | |||||
* | Rename `iterations_per_second` to `physics_ticks_per_second` | Hugo Locurcio | 2021-08-11 | 1 | -7/+7 | |
| | | | | | | | | This makes it clearer that this property is only about physics FPS, not rendering FPS. The `physics_fps` project setting was also renamed to `physics_ticks_per_second` for consistency. | |||||
* | Use doubles for time in many other places | Aaron Franke | 2021-08-09 | 1 | -7/+7 | |
| | ||||||
* | [Core] Expose ResourceLoader.get_resource_uid. | Fabio Alessandrelli | 2021-08-09 | 1 | -0/+5 | |
| | ||||||
* | Fix logic to allow default null thread argument | Pedro J. Estébanez | 2021-08-08 | 1 | -1/+1 | |
| | ||||||
* | OS: Fix used resource debug prints | Rémi Verschelde | 2021-08-06 | 1 | -4/+32 | |
| | | | | | | These methods were broken by 22419082d9bedbc9dc060ea5784bb0871f8710a3 5 years ago and nobody complained, so maybe they're not so useful... But at least this should restore them to a working state. | |||||
* | Fix thread start with no user data when target has no default argument | Pedro J. Estébanez | 2021-07-31 | 1 | -1/+30 | |
| | ||||||
* | Use Ref<T> references as iterators where relevant | Rémi Verschelde | 2021-07-26 | 1 | -7/+7 | |
| | | | | And const when possible. | |||||
* | Use const references where possible for List range iterators | Rémi Verschelde | 2021-07-25 | 1 | -10/+10 | |
| | ||||||
* | Use C++ iterators for Lists in many situations | Aaron Franke | 2021-07-23 | 1 | -32/+30 | |
| | ||||||
* | Move `alert` function from `DisplayServer` to `OS`. | bruvzg | 2021-07-22 | 1 | -0/+6 | |
| | ||||||
* | Let thread func have optional parameter | Faymoon | 2021-07-13 | 1 | -1/+2 | |
| | | | | Fixes #38042. | |||||
* | Merge pull request #48359 from Calinou/add-engine-print-error-property | Rémi Verschelde | 2021-06-20 | 1 | -0/+12 | |
|\ | ||||||
| * | Add `Engine.print_error_messages` property to disable printing errors | Hugo Locurcio | 2021-05-01 | 1 | -0/+12 | |
| | | | | | | | | | | | | | | | | This can be used during unit test suite runs to hide error and warning messages. Care should be taken when using this feature, as it can hide important information if used wrongly. | |||||
* | | Rename `instance()`->`instantiate()` when it's a verb | Lightning_A | 2021-06-19 | 1 | -6/+6 | |
| | | ||||||
* | | Merge pull request #44806 from madmiraal/consolidate_json | Rémi Verschelde | 2021-06-19 | 1 | -75/+0 | |
|\ \ | | | | | | | Consolidate JSON, JSONParseResults and JSONParser into JSON | |||||
| * | | Consolidate JSON, JSONParseResults and JSONParser into JSON | Marcel Admiraal | 2021-06-19 | 1 | -75/+0 | |
| | | | | | | | | | | | | | | | Renames JSON.parse_string() to parse() Renames JSON.decode_data() to stringify() | |||||
* | | | Expose OS data directory getter methods | Hugo Locurcio | 2021-06-19 | 1 | -0/+18 | |
|/ / | | | | | | | | | | | This can be used by editor plugins and non-game applications to store data in the correct directories according to the XDG Base Directory specification. | |||||
* | | Merge pull request #49123 from aaronfranke/it-is-time | Rémi Verschelde | 2021-06-12 | 1 | -231/+0 | |
|\ \ | | | | | | | Add a Time singleton | |||||
| * | | Add Time singleton | Aaron Franke | 2021-06-11 | 1 | -231/+0 | |
| | | | ||||||
* | | | Rename Reference to RefCounted | Pedro J. Estébanez | 2021-06-11 | 1 | -1/+1 | |
| | | | ||||||
* | | | Merge pull request #34566 from Heikki00/34541_to_json_precision | Rémi Verschelde | 2021-06-11 | 1 | -3/+3 | |
|\ \ \ | |/ / |/| | | Increased String::num default decimal precision | |||||
| * | | Increase String::num default decimal precision | Heikki Simojoki | 2021-05-29 | 1 | -3/+3 | |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Fixes #34541 Renamed MAX_DIGITS to MAX_DECIMALS, since it only changes the amount of digits after the decimal point. Increased MAX_DECIMALS to 32, and made String::num use MAX_DECIMALS consistently. If -1 is passed as decimal precision to String::num, it now gets changed to the correct precision based on the number's magnitude, instead of using printf default(which is 6) String::num_real also calculates the correct precision now. Also made the types used in floating-point math more consistent in a few places. | |||||
* | | | Add OS.get_external_data_dir() to get Android external directory | Marcel Admiraal | 2021-06-10 | 1 | -0/+5 | |
| | | | ||||||
* | | | Merge pull request #48889 from Calinou/file-rename-endian-swap | Rémi Verschelde | 2021-06-03 | 1 | -9/+9 | |
|\ \ \ | | | | | | | | | Rename File's `endian_swap` to `big_endian` |