Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rebranding: Doc/ | Dubhghlas McLaughlin | 2024-10-17 | 1 | -2/+2 |
| | |||||
* | fix: change "Godot" to "Redot" | Muhannad Elbolaky | 2024-10-15 | 1 | -2/+2 |
| | | | | Trying to change "Godot" to "Redot" in the doc context while acknowledging the reference to previous Godot versions like Godot 3.X. | ||||
* | Add further details on properties returning `Packed*Array` | A Thousand Ships | 2024-04-08 | 1 | -0/+1 |
| | |||||
* | Overhaul some "uncommon" wording in class reference | Micky | 2024-03-01 | 1 | -6/+6 |
| | |||||
* | Clarify `PackedByteArray.decompress*` limitations with external data | A Thousand Ships | 2024-01-07 | 1 | -0/+2 |
| | |||||
* | Add performance note to Array.resize() | MewPurPur | 2023-11-10 | 1 | -1/+1 |
| | |||||
* | Validate `code` tags for class and member references | Yuri Sizov | 2023-10-03 | 1 | -2/+2 |
| | | | | | | | | This commit also adds means to manually disable warnings in `code` tags where it's a false positive with the new `skip-lint` attribute. Warnings are now enabled on CI to prevent future errors. | ||||
* | Doc: Reference String <-> PackedByteArray conversions from each other | Aaron Franke | 2023-09-12 | 1 | -5/+5 |
| | |||||
* | Fix many typos in documentation | Septian | 2023-07-19 | 1 | -1/+1 |
| | |||||
* | Doctool: Remove version attribute from XML header | Rémi Verschelde | 2023-07-06 | 1 | -1/+1 |
| | | | | | | We don't use that info for anything, and it generates unnecessary diffs every time we bump the minor version (and CI failures if we forget to sync some files from opt-in modules (mono, text_server_fb). | ||||
* | Bump version to 4.2-dev | Rémi Verschelde | 2023-07-05 | 1 | -1/+1 |
| | | | | Keep on waitin' | ||||
* | Make documentation sorting use natural order | Ninni Pipping | 2023-05-09 | 1 | -25/+25 |
| | |||||
* | Expose brotli decompression to the scripting API. | bruvzg | 2023-03-29 | 1 | -1/+1 |
| | |||||
* | Add GDScript `to_wchar_buffer` and `get_string_from_wchar` functions. | bruvzg | 2023-03-21 | 1 | -0/+6 |
| | |||||
* | Bump version to 4.1-dev | Rémi Verschelde | 2023-03-01 | 1 | -1/+1 |
| | | | | Can't stop, won't stop, they said, huh? | ||||
* | Various classref typo fixes | Haoyu Qiu | 2023-02-20 | 1 | -2/+2 |
| | |||||
* | Replace File/Directory with FileAccess/DirAccess | kobewi | 2022-09-19 | 1 | -3/+3 |
| | |||||
* | Complete documentation of packed arrays | kobewi | 2022-08-19 | 1 | -0/+32 |
| | |||||
* | [doc] Use "param" instead of "code" to refer to parameters (4) | Andy Maloney | 2022-08-11 | 1 | -7/+7 |
| | |||||
* | Expose clear method for packed arrays | Haoyu Qiu | 2022-08-10 | 1 | -0/+6 |
| | |||||
* | Rename the argument tag to param in XML documentation | Yuri Sizov | 2022-08-08 | 1 | -73/+73 |
| | |||||
* | Prevent out-of-bounds write in array conversion; avoid logspam on empty arrays. | Lyuma | 2022-06-30 | 1 | -5/+5 |
| | |||||
* | Add search methods for packed arrays | Haoyu Qiu | 2022-05-07 | 1 | -0/+23 |
| | | | | | | * count() * find() * rfind() | ||||
* | Remove Array link in description of PackedArrays | Haoyu Qiu | 2022-04-23 | 1 | -2/+2 |
| | |||||
* | Remove generating of null comparison operators from documentation | Yuri Roubinsky | 2022-03-14 | 1 | -10/+0 |
| | |||||
* | Add an XML schema for documentation | Hugo Locurcio | 2022-02-15 | 1 | -1/+1 |
| | | | | | | | | This makes it easier to spot syntax errors when editing the class reference. The schema is referenced locally so validation can still work offline. Each class XML's schema conformance is also checked on GitHub Actions. | ||||
* | `Array`: Relax `slice` bound checks to properly handle negative indices | Rémi Verschelde | 2022-01-10 | 1 | -2/+3 |
| | | | | | | | | | | | | | | The same is done for `Vector` (and thus `Packed*Array`). `begin` and `end` can now take any value and will be clamped to `[-size(), size()]`. Negative values are a shorthand for indexing the array from the last element upward. `end` is given a default `INT_MAX` value (which will be clamped to `size()`) so that the `end` parameter can be omitted to go from `begin` to the max size of the array. This makes `slice` works similarly to numpy's and JavaScript's. | ||||
* | Unify similar method descriptions | Haoyu Qiu | 2022-01-06 | 1 | -1/+1 |
| | | | | | | | | | | Notably: * `Packed*Array.size()` and `Array.size()`. * Shared methods of `Transform2D` and `Transform3D`. * Shared methods of `Vector2`, `Vector3`, and `Vector2i`. This reduces the Deja Vu when translating the class reference :) | ||||
* | PackedByteArray, Array slice end exclusive, rename subarray to slice | Nathan Franke | 2021-11-26 | 1 | -8/+9 |
| | |||||
* | Rename `remove()` to `remove_at()` when removing by index | Lightning_A | 2021-11-23 | 1 | -1/+1 |
| | |||||
* | Move the docs for constructors and operators out of methods section | Aaron Franke | 2021-10-29 | 1 | -41/+45 |
| | |||||
* | Merge pull request #52850 from mashumafi/vector-bsearch | Rémi Verschelde | 2021-10-01 | 1 | -0/+9 |
|\ | |||||
| * | Implement bsearch for Vector and Packed*Array | mashumafi | 2021-09-30 | 1 | -0/+9 |
| | | |||||
* | | Don't generate empty doc sections and reduce code duplication | Aaron Franke | 2021-09-20 | 1 | -2/+0 |
|/ | |||||
* | Allow comparing equality between builtin types and null | George Marques | 2021-09-17 | 1 | -0/+10 |
| | |||||
* | Replace stb_vorbis with libogg+libvorbis | Ellen Poe | 2021-09-09 | 1 | -1/+1 |
| | |||||
* | doc: Use self-closing tags for `return` and `argument` | Rémi Verschelde | 2021-07-30 | 1 | -252/+126 |
| | | | | | | | | For the time being we don't support writing a description for those, preferring having all details in the method's description. Using self-closing tags saves half the lines, and prevents contributors from thinking that they should write the argument or return documentation there. | ||||
* | New to_***_array method to decode PackedByteArray to Packed***Array | ChristopheClaustre | 2021-07-24 | 1 | -0/+36 |
| | | | | | Documentation for new PackedByteArray::to_***_array methods Documentation for to_byte_array method for PackedInt32/Int64/Float32/Float64Array | ||||
* | Add fill method to Arrays and PackedArrays | Matheus Lima Cunha | 2021-04-21 | 1 | -0/+9 |
| | |||||
* | doc: Sync classref with current source | Rémi Verschelde | 2021-04-19 | 1 | -0/+240 |
| | |||||
* | Fix misformatted documentation from #47435, #42827, #46991 | Yuri Sizov | 2021-04-04 | 1 | -7/+7 |
| | |||||
* | Rename Array.invert() to Array.reverse() | Marcel Admiraal | 2021-03-21 | 1 | -1/+1 |
| | | | | | Does the same internally for List and Vector<>, which includes all PackedArray types. | ||||
* | class reference proofreading | Paul Joannon | 2021-03-19 | 1 | -1/+1 |
| | |||||
* | doc: Sync classref with current source | Rémi Verschelde | 2021-03-18 | 1 | -11/+11 |
| | | | | And move GLTF docs to its module folder. | ||||
* | doc: Sync classref with current source | Rémi Verschelde | 2021-01-04 | 1 | -7/+7 |
| | |||||
* | Rename empty() to is_empty() | Marcel Admiraal | 2020-12-28 | 1 | -1/+1 |
| | |||||
* | packed*arrays are pass by ref now. support duplicate and update documentation | Jordan Schidlowsky | 2020-12-17 | 1 | -1/+7 |
| | |||||
* | Merge pull request #43246 from HaSa1002/docs-lang-5 | Rémi Verschelde | 2020-11-16 | 1 | -2/+8 |
|\ | | | | | Docs: Port code examples to C# (M, N, O, P, Q, R) | ||||
| * | Docs: Port Code Examples to C# (M, N, O, P, R) | HaSa1002 | 2020-11-09 | 1 | -2/+8 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Includes: * MarginContainer * NavigationPolygon * Node * NodePath * OS * PackedByteArray * PackedScene * PacketPeerUDP * PCKPacker * Performance * PhysicsShapeQueryParameters2D * PhysicsShapeQueryParameters3D * PrimitiveMesh * ProjectSettings Co-authored-by: Aaron Franke <arnfranke@yahoo.com> | ||||
* | | doc: Sync classref to add operators after #43419 | Rémi Verschelde | 2020-11-10 | 1 | -3/+35 |
| | |