summaryrefslogtreecommitdiffstats
path: root/editor/create_dialog.cpp
Commit message (Collapse)AuthorAgeFilesLines
...
* | Merge pull request #68709 from MewPurPur/instance-begone-part3Rémi Verschelde2022-11-161-2/+2
|\ \ | | | | | | | | | Remove more instances of 'instance' being used as a verb
| * | Remove more instances of 'instance' being used as a verbVolTer2022-11-161-2/+2
| | |
* | | Merge pull request #67798 from KoBeWi/code_resurrectionRémi Verschelde2022-11-151-2/+1
|\ \ \ | |/ / |/| | | | | Uncomment drag forwarding in CreateDialog
| * | Uncomment drag forwarding in CreateDialogkobewi2022-10-231-2/+1
| |/
* | Don't allow instancing virtual node types in the Create New Node dialogAaron Franke2022-11-051-4/+4
| |
* | Unify usage of GLOBAL/EDITOR_GETkobewi2022-10-181-1/+1
|/
* SCons: Re-enable treating `#warning` as error with `werror`Rémi Verschelde2022-10-101-3/+1
| | | | | | | | Replace all TODO uses of `#warning` by proper TODO comments, and will open matching bug reports to keep track of them. We don't have a great track record fixing TODOs, but I'd wager we're even worse for fixing these "TODO #warning" so we should prohibit this usage.
* Fix MSVC warnings, rename shadowed variables, fix uninitialized values, ↵bruvzg2022-10-071-10/+10
| | | | change warnings=all to use /W4.
* Fix creating Nodes from Recent listMarkus Sauermann2022-09-301-9/+10
| | | | | - give shorter search matches more weight - allow matching against "Node"
* Add ability to flag classes as experimental or deprecated.SaracenOne2022-09-111-0/+9
|
* simplify title of create/change node dialogNathan Franke2022-09-071-7/+3
| | | | The create dialog in replace mode now always has the title `Change type of "%s"`, where `%s` is either "MyNodeName" or "MyVisualScript.vs".
* Improve handling of custom typeskobewi2022-09-051-2/+2
|
* Merge pull request #65039 from Mickeon/rename-treeitem-tooltipRémi Verschelde2022-08-301-1/+1
|\
| * Rename TreeItem's `set_tooltip` to `set_tooltip_text`Micky2022-08-301-1/+1
| | | | | | | | | | | | | | | | | | `set_tooltip` -> `set_tooltip_text` `get_tooltip` -> `get_tooltip_text` For consistency: `get_button_tooltip` -> `get_button_tooltip_text` And the `tooltip` parameter in `add_button` was renamed to `tooltip_text`
* | Rename String `plus_file` to `path_join`Aaron Franke2022-08-291-4/+4
|/
* Revert "Remove NOTIFICATION_ENTER_TREE when paired with ↵Rémi Verschelde2022-08-291-2/+7
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | NOTIFICATION_THEME_CHANGED" This reverts commit 4b817a565cab8af648c88cfc7ab6481e86ee3625. Fixes #64988. Fixes #64997. This caused several regressions (#64988, #64997, https://github.com/godotengine/godot/issues/64997#issuecomment-1229970605) which point at a flaw in the current logic: - `Control::NOTIFICATION_ENTER_TREE` triggers a *deferred* notification with `NOTIFCATION_THEME_CHANGED` as introduced in #62845. - Some classes use their `THEME_CHANGED` to cache theme items in member variables (e.g. `style_normal`, etc.), and use those member variables in `ENTER_TREE`, `READY`, `DRAW`, etc. Since the `THEME_CHANGE` notification is now deferred, they end up accessing invalid state and this can lead to not applying theme properly (e.g. for EditorHelp) or crashing (e.g. for EditorLog or CodeEdit). So we need to go back to the drawing board and see if `THEME_CHANGED` can be called earlier so that the previous logic still works? Or can we refactor all engine code to make sure that: - `ENTER_TREE` and similar do not depend on theme properties cached in member variables. - Or `THEME_CHANGE` does trigger a general UI update to make sure that any bad theme handling in `ENTER_TREE` and co. gets fixed when `THEME_CHANGE` does arrive for the first time. But that means having a temporary invalid (and possibly still crashing) state, and doing some computations twice which might be heavy (e.g. `EditorHelp::_update_doc()`).
* Merge pull request #64885 from Mickeon/rename-tooltip-hintRémi Verschelde2022-08-281-1/+1
|\ | | | | Rename `hint_tooltip` to `tooltip_text` & setter getter
| * Rename `hint_tooltip` to `tooltip_text` & setgetMicky2022-08-271-1/+1
| | | | | | | | | | | | | | | | `hint_tooltip` -> `tooltip_text` `set_tooltip` -> `set_tooltip_text` `_get_tooltip` -> `get_tooltip_text` Updates documentation, too.
* | Remove NOTIFICATION_ENTER_TREE when paired with NOTIFICATION_THEME_CHANGEDAaron Record2022-08-271-7/+2
|/
* Changed the title of change node type dialogUmang Kalra2022-08-201-2/+6
|
* Move editor paths into the EditorPaths classAaron Franke2022-07-291-3/+4
|
* Add ok_button_text to AcceptDialog and cancel_button_text to ConfirmationDialogFireForge2022-07-091-2/+2
|
* Rework scene creation dialogkobewi2022-06-211-0/+7
|
* Use range iterators for RBSet in most casesAaron Record2022-05-191-2/+2
|
* Replace most uses of Map by HashMapreduz2022-05-161-1/+1
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Merge pull request #59498 from ↵Rémi Verschelde2022-05-121-1/+1
|\ | | | | | | | | adamscott/add-custom-type-check-before-hiding-type [Fix #58248] Add custom type check before hiding type
| * [Fix #58248] Add custom type check before hiding typeAdam Scott2022-03-241-1/+1
| |
* | Narrow FileAccess scope to prevent deadlocks.bruvzg2022-04-121-22/+26
| |
* | Make FileAccess and DirAccess classes reference counted.bruvzg2022-04-111-14/+7
|/
* Discern between virtual and abstract class bindingsreduz2022-03-101-2/+2
| | | | | | | | | | | | | | * Previous "virtual" classes (which can't be instantiated) are not corretly named "abstract". * Added a new "virtual" category for classes, they can't be instantiated from the editor, but can be inherited from script and extensions. * Converted a large amount of classes from "abstract" to "virtual" where it makes sense. Most classes that make sense have been converted. Missing: * Physics servers * VideoStream * Script* classes. which will go in a separate PR due to the complexity involved.
* Fix crash in Create New Node dialog with certain user-created scriptsHaoyu Qiu2022-02-191-11/+11
|
* Port existing _notification code to use switch statements (part 1/3)jmb4622022-02-161-0/+3
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-4/+4
|
* Merge pull request #40140 from hinlopen/tree-scroll-centerRémi Verschelde2022-02-081-3/+3
|\
| * Center when scrolling to tree item.Stijn Hinlopen2022-02-051-3/+3
| |
* | Revert "Add missing SNAME macro optimization to all theme methods call"Rémi Verschelde2022-02-081-2/+2
| | | | | | | | | | | | | | | | This reverts commit a988fad9a092053434545c32afae91ccbdfbe792. As discussed in #57725 and clarified in #57788, `SNAME` is not meant to be used everywhere but only in critical code paths. For theme methods specifically, it was by design that only getters use `SNAME` and not setters.
* | Merge pull request #43015 from Xrayez/refactor-auto-instapropRémi Verschelde2022-02-081-11/+1
|\ \ | | | | | | Refactor auto-instantiation of `Object` properties in editor
| * | Refactor auto-instantiation of `Object` properties in editorAndrii Doroshenko (Xrayez)2021-12-281-11/+1
| | | | | | | | | | | | | | | | | | | | | | | | Auto-instantiation is used by the create dialog, but should also be used by the editor inspector. This refactors object properties auto-instantiation into a dedicated method to be reused throughout editor (and possibly scripting).
* | | Add missing SNAME macro optimization to all theme methods calljmb4622022-02-061-2/+2
| |/ |/|
* | Vectors: Use clear() and has().Anilforextra2022-02-021-5/+5
| | | | | | | | | | | | Use clear() instead of resize(0). Use has() instead of "find(p_val) != -1".
* | Rename String::is_subsequence_ofi to String::is_subsequence_ofnWilson E. Alvarez2022-01-261-1/+1
| |
* | Merge pull request #55509 from V-Sekai/create_node_and_doc_fixRémi Verschelde2022-01-171-13/+64
|\ \ | | | | | | Fix crashes when global named scripts extends an unnamed script
| * | Properly handle named class types inheriting from scripts without names.SaracenOne2021-12-011-13/+64
| | |
* | | Fix theming update in several editor classesYuri Roubinsky2022-01-161-3/+10
| | |
* | | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| |/ |/| | | | | Happy new year to the wonderful Godot community!
* | Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-4/+4
| | | | | | | | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* | Fix error emitting when called new shader dialog from resource dialogYuri Roubinsky2021-12-071-1/+3
|/
* Rename `remove()` to `remove_at()` when removing by indexLightning_A2021-11-231-1/+1
|
* Use "enum class" for input enumsAaron Franke2021-11-121-4/+4
|
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-1/+1
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.