summaryrefslogtreecommitdiffstats
path: root/editor/debugger/editor_profiler.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
|
* Rebrand preambles to RedotSpartan3222024-10-131-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | (cherry picked from commit e8542b06acca3c1bdeee4b528411771f0819f084) Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Scene] Add `SceneStringNames::text/value_changed`A Thousand Ships2024-06-191-1/+1
|
* [Scene] Add `SceneStringNames::item_selected`A Thousand Ships2024-06-191-2/+2
|
* [Scene] Add `SceneStringNames::font(_size/_color)`A Thousand Ships2024-06-181-1/+1
|
* Fix profiler seek line color in light modes, update on theme changeChristian Kaiser2024-05-261-2/+12
|
* [Scene] Add SceneStringNames::pressedA Thousand Ships2024-05-141-3/+3
|
* Use Core/Scene stringnames consistentlykobewi2024-05-131-3/+3
|
* Merge pull request #86143 from YeldhamDev/ttr_here,_rtr_thereRémi Verschelde2024-03-261-3/+3
|\ | | | | | | Stop using `RTR()` inside the "editor" folder
| * Stop using `RTR()` inside the "editor" folderMichael Alexsander2024-02-271-3/+3
| |
* | Fix unexpected auto translation of Tree contentHaoyu Qiu2024-03-181-0/+1
| |
* | Merge pull request #86398 from reach-satori/prof-visibility-fixRémi Verschelde2024-03-011-0/+1
|\ \ | |/ |/| | | Fix internal profiling button being visible when disabled in settings
| * Fix internal profiling button being visible when disabledMateus Reis2023-12-211-0/+1
| |
* | Fix editor profiler script function sort orderbaptr2024-01-271-1/+1
| | | | | | | | | | | | | | | | | | | | | | The engine internally limits the number of functions reported back (to 16 by default). To this point, it's been sort the profiling info in *ascending* order of time spent, then trimming the list. This meant we may only see the best (fastest) functions, instead of the worst that you probably want when profiling. Now the servers_debugger sort more closely matches the local_debugger one, which worked fine.
* | Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
|/ | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Fix missing time for some script functions in profilermsreis2023-12-191-0/+16
| | | | | | | | | Fixes the issue by adding a mechanism by which the functions that were previously disappearing can be profiled too. This is optional with an editor setting, since collecting more information naturally slows the engine further while profiling. Fixes #23715, #40251, #29049
* Add EditorStringNames singletonkobewi2023-09-031-7/+8
|
* Extract and reorganize texture resource classesHendrik Brucker2023-07-141-0/+1
|
* Merge pull request #75200 from ↵Rémi Verschelde2023-06-191-2/+0
|\ | | | | | | | | | | Calinou/debugger-editor-settings-add-property-hints Add property hints for debugger/profiler editor settings
| * Add property hints for debugger/profiler editor settingsHugo Locurcio2023-03-221-2/+0
| | | | | | | | This also adds descriptions for those settings.
* | Fix profilers' GUI treesVolTer2023-06-031-3/+3
|/
* Improvements and fixes based on Weblate commentsHaoyu Qiu2023-02-131-0/+2
| | | | | | | | | | | | | | | | | | | * Description of `ui_text_submit` action should be "Submit Text" instead of "Text Submitted". * Spell out "Animation" instead of using "Anim.". * Treat "Max" as regular word instead of writing "Max.". * Use generic "Set %s" for action name instead of a dedicated "Set target_position". * Add translator comment for: * "Inclusive" and "Self" in the profiler. * Places where it needs the context about being an editor progress label. * "Duplicated Animation Name" since it's refering to the new name of a duplicated animation. * Disambiguation of "View Plane Transform", "Paste Selects" and "Display Normal". * Fix wrong undo action name for renaming an input action. * Fix missing end quote in a shader error message. * In class reference: * Fix duplicated "if" in the description of `signf()`. * Fix mismatched example output in `String.operator %()`. * Fix typo in the description of `Decal.texture_emission`. * Unify description of `String.match()` and `StringName.match()`.
* Add expand modes to TextureRectkobewi2023-01-121-1/+1
|
* Use BitField<> in core type masksJuan Linietsky2023-01-081-1/+1
| | | | | | | | * All core types masks are now correctly marked as bitfields. * The enum hacks in MouseButtonMask and many other types are gone. This ensures that binders to other languages non C++ can actually implement type safe bitmasks. * Most bitmask operations replaced by functions in BitField<> * Key is still a problem because its enum and mask at the same time. While it kind of works in C++, this most likely can't be implemented safely in other languages and will have to be changed at some point. Mostly left as-is. * Documentation and API dump updated to reflect bitfields in core types.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Fix: Profiler and Visual Profiler start/stop state inconsistencystmSi2022-12-231-4/+9
|
* Unify usage of GLOBAL/EDITOR_GETkobewi2022-10-181-1/+1
|
* Make some Image methods statickobewi2022-10-141-3/+1
|
* Fix profiler being disabled at wrong timeshalgriffiths2022-09-131-3/+19
| | | | Co-authored by: Will Whitty <tavurth@gmail.com>
* Merge pull request #64377 from Mickeon/rename-canvas-redrawRémi Verschelde2022-08-301-5/+5
|\ | | | | Rename `CanvasItem.update()` to `queue_redraw()`
| * Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-5/+5
| | | | | | | | | | | | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* | Rename TreeItem's `set_tooltip` to `set_tooltip_text`Micky2022-08-301-1/+1
|/ | | | | | | | | `set_tooltip` -> `set_tooltip_text` `get_tooltip` -> `get_tooltip_text` For consistency: `get_button_tooltip` -> `get_button_tooltip_text` And the `tooltip` parameter in `add_button` was renamed to `tooltip_text`
* Revert "Remove NOTIFICATION_ENTER_TREE when paired with ↵Rémi Verschelde2022-08-291-2/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | NOTIFICATION_THEME_CHANGED" This reverts commit 4b817a565cab8af648c88cfc7ab6481e86ee3625. Fixes #64988. Fixes #64997. This caused several regressions (#64988, #64997, https://github.com/godotengine/godot/issues/64997#issuecomment-1229970605) which point at a flaw in the current logic: - `Control::NOTIFICATION_ENTER_TREE` triggers a *deferred* notification with `NOTIFCATION_THEME_CHANGED` as introduced in #62845. - Some classes use their `THEME_CHANGED` to cache theme items in member variables (e.g. `style_normal`, etc.), and use those member variables in `ENTER_TREE`, `READY`, `DRAW`, etc. Since the `THEME_CHANGE` notification is now deferred, they end up accessing invalid state and this can lead to not applying theme properly (e.g. for EditorHelp) or crashing (e.g. for EditorLog or CodeEdit). So we need to go back to the drawing board and see if `THEME_CHANGED` can be called earlier so that the previous logic still works? Or can we refactor all engine code to make sure that: - `ENTER_TREE` and similar do not depend on theme properties cached in member variables. - Or `THEME_CHANGE` does trigger a general UI update to make sure that any bad theme handling in `ENTER_TREE` and co. gets fixed when `THEME_CHANGE` does arrive for the first time. But that means having a temporary invalid (and possibly still crashing) state, and doing some computations twice which might be heavy (e.g. `EditorHelp::_update_doc()`).
* Merge pull request #64885 from Mickeon/rename-tooltip-hintRémi Verschelde2022-08-281-1/+1
|\ | | | | Rename `hint_tooltip` to `tooltip_text` & setter getter
| * Rename `hint_tooltip` to `tooltip_text` & setgetMicky2022-08-271-1/+1
| | | | | | | | | | | | | | | | `hint_tooltip` -> `tooltip_text` `set_tooltip` -> `set_tooltip_text` `_get_tooltip` -> `get_tooltip_text` Updates documentation, too.
* | Remove NOTIFICATION_ENTER_TREE when paired with NOTIFICATION_THEME_CHANGEDAaron Record2022-08-271-3/+2
|/
* Add static methods for creating Image and ImageTexturekobewi2022-07-081-1/+1
|
* Increase the editor profiler frame history default and maximum limitHugo Locurcio2022-05-281-2/+2
| | | | | | | | | | | | The new default value (1800) allows storing 30 seconds of profiling at 60 FPS. The new maximum value (10000) allows storing about 3 minutes of profiling at 60 FPS. The profiler graph will scale accordingly to the chosen setting, so the default value is kept relatively low to prevent the graph from looking too squished on narrow displays.
* Add a new HashSet templatereduz2022-05-201-1/+1
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Use range iterators for RBSet in most casesAaron Record2022-05-191-12/+12
|
* Replace most uses of Map by HashMapreduz2022-05-161-19/+19
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Style: Partially apply clang-tidy's `cppcoreguidelines-pro-type-member-init`Rémi Verschelde2022-05-021-6/+0
| | | | | | | | | | | Didn't commit all the changes where it wants to initialize a struct with `{}`. Should be reviewed in a separate PR. Option `IgnoreArrays` enabled for now to be conservative, can be disabled to see if it proposes more useful changes. Also fixed manually a handful of other missing initializations / moved some from constructors.
* More icon updates on theme changeHaoyu Qiu2022-03-151-0/+1
|
* Remove duplicate editor settings definitionskobewi2022-03-061-1/+1
|
* Port existing _notification code to use switch statements (part 1/3)jmb4622022-02-161-3/+7
|
* Revert "Add missing SNAME macro optimization to all theme methods call"Rémi Verschelde2022-02-081-1/+1
| | | | | | | | This reverts commit a988fad9a092053434545c32afae91ccbdfbe792. As discussed in #57725 and clarified in #57788, `SNAME` is not meant to be used everywhere but only in critical code paths. For theme methods specifically, it was by design that only getters use `SNAME` and not setters.
* Add missing SNAME macro optimization to all theme methods calljmb4622022-02-061-1/+1
|
* simplify formatting scripts, add a clang-tidy script, and run clang-tidyNathan Franke2022-01-291-1/+2
|
* Rename TextureRect.expand to ignore_texture_sizekobewi2022-01-071-1/+1
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!