summaryrefslogtreecommitdiffstats
path: root/editor/rename_dialog.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
|
* Rebrand preambles to RedotSpartan3222024-10-131-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | (cherry picked from commit e8542b06acca3c1bdeee4b528411771f0819f084) Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Scene] Add `SceneStringNames::text/value_changed`A Thousand Ships2024-06-191-7/+7
|
* [Scene] Add `SceneStringNames::item_selected`A Thousand Ships2024-06-191-2/+2
|
* [Scene] Add `SceneStringNames::font(_size/_color)`A Thousand Ships2024-06-181-3/+3
|
* Don't traslate preview in node batch rename dialogHaoyu Qiu2024-05-211-0/+1
|
* [Scene] Add SceneStringNames::pressedA Thousand Ships2024-05-141-10/+10
|
* Use Core/Scene stringnames consistentlykobewi2024-05-131-8/+8
|
* Replace `find` with `contains/has` where applicableA Thousand Ships2024-05-081-1/+1
| | | | | | | * Replaces `find(...) != -1` with `contains` for `String` * Replaces `find(...) == -1` with `!contains` for `String` * Replaces `find(...) != -1` with `has` for containers * Replaces `find(...) == -1` with `!has` for containers
* Reduce and prevent unnecessary random-access to `List`A Thousand Ships2024-05-041-4/+4
| | | | | | | | | Random-access access to `List` when iterating is `O(n^2)` (`O(n)` when accessing a single element) * Removed subscript operator, in favor of a more explicit `get` * Added conversion from `Iterator` to `ConstIterator` * Remade existing operations into other solutions when applicable
* Allow to easily rename multiple nodeskobewi2024-03-031-2/+1
| | | | Co-authored-by: ajreckof <tbonhoure@ymail.Com>
* Add const lvalue ref to editor/* container parametersMuller-Castro2024-02-261-2/+2
|
* Replace error checks against `size` with `is_empty`A Thousand Ships2024-02-091-1/+1
|
* Reorganize code related to editor themingYuri Sizov2024-01-161-2/+1
| | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Fix accessing editor theme items throughout the UIYuri Sizov2023-09-151-4/+4
| | | | This also exposes `EditorInterface::get_editor_theme`.
* Extract ScriptInstance to simplify includesYuri Sizov2023-09-061-1/+1
| | | | | | | | | This allows to include script_instance.h directly in the generated gdvirtual.gen.inc, and remove excessive includes from the codebase. This should also allow Resource to use GDVIRTUAL macros, which wasn't possible previously due to a circular dependency.
* Add EditorStringNames singletonkobewi2023-09-031-3/+4
|
* Avoid unnecessary inspector updates when loading or switching scenesYuri Sizov2023-08-121-2/+2
| | | | | | This should result in some noticeable performance improvements, aside from fixing bugs due to conflicts in logic. This also simplifies some related code identified while debugging.
* properly update nodepath with batch renameajreckof2023-06-141-4/+2
|
* Improve includes of EditorNode (and everything else)Yuri Sizov2023-04-071-0/+4
| | | | | | Also start organizing editor-specific GUI components into a dedicated folder, `editor/gui`. Also move `editor_file_server` next to the rest of debugger classes.
* Add EditorUndoRedoManager singletonkobewi2023-01-161-1/+1
|
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Fix substitute buttons were never enabledMarius Hanl2022-12-301-2/+2
| | | | This happened because the viewport of the scene_tree_editor was queried for the focus owner instead of the current viewport
* Use forward-declarations in big editor classestrollodel2022-11-291-0/+1
|
* Cleanup remaining EditorUndoRedoManager usageskobewi2022-11-241-3/+3
|
* Fix MSVC warnings, rename shadowed variables, fix uninitialized values, ↵bruvzg2022-10-071-3/+3
| | | | change warnings=all to use /W4.
* Add `String.to_{camel,pascal,snake}_case` methodsDanil Alexeev2022-08-301-2/+2
|
* Rename `hint_tooltip` to `tooltip_text` & setgetMicky2022-08-271-13/+13
| | | | | | | | `hint_tooltip` -> `tooltip_text` `set_tooltip` -> `set_tooltip_text` `_get_tooltip` -> `get_tooltip_text` Updates documentation, too.
* Add per-scene UndoRedokobewi2022-08-221-2/+3
|
* Extract EditorResourceConversionPlugin into its own source files and clean ↵Yuri Sizov2022-07-311-0/+1
| | | | up editor includes
* Remove Signal connect bindsJuan Linietsky2022-07-291-9/+9
| | | | | Remove the optional argument p_binds from `Object::connect` since it was deprecated by Callable.bind(). Changed all uses of it to Callable.bind()
* Add ok_button_text to AcceptDialog and cancel_button_text to ConfirmationDialogFireForge2022-07-091-1/+1
|
* Move duplicate AutoWrap, Overrun and VisibleChar behavior enums to the ↵bruvzg2022-06-161-1/+1
| | | | TextServer.
* popup deferred hide suppressed if reopenedderammo2022-05-131-0/+2
| | | | | | | | | popup no longer tries to close itself a second time popup no longer closes after having been reopened fixed bug in RenameDialog not calling base (by inspection) fixes #59181 fixes #60921 reverts #59287
* Make `TabBar/Container` default their alignments to the left instead of centerMichael Alexsander2022-03-171-1/+0
|
* Make `TabContainer` use `TabBar` internallyMichael Alexsander2022-03-031-1/+1
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-4/+4
|
* Revert "Add missing SNAME macro optimization to all theme methods call"Rémi Verschelde2022-02-081-3/+3
| | | | | | | | This reverts commit a988fad9a092053434545c32afae91ccbdfbe792. As discussed in #57725 and clarified in #57788, `SNAME` is not meant to be used everywhere but only in critical code paths. For theme methods specifically, it was by design that only getters use `SNAME` and not setters.
* Add missing SNAME macro optimization to all theme methods calljmb4622022-02-061-3/+3
|
* Remove get_focus_owner() from Control, replaced by ↵Gilles Roudière2022-02-031-2/+2
| | | | get_viewport()->gui_get_focus_owner()
* Merge pull request #57205 from TechnoPorg/variant-template-castRémi Verschelde2022-01-271-1/+1
|\ | | | | Allow method binds to take Object subclasses as arguments
| * Allow method binds to take Object subclasses as argumentsTechnoPorg2022-01-251-1/+1
| | | | | | | | | | | | This commit adds a condition to VariantCaster that casts Variants of type OBJECT to any type T, if T is derived from Object. This change enables a fair bit of code cleanup. First, the Variant implicit cast operators for Node and Control can be removed, which allows for some invalid includes to be removed. Second, helper methods in Tree whose sole purpose was to cast arguments to TreeItem * are no longer necessary. A few small changes also had to be made to other files, due to the changes cascading down all the includes.
* | Merge pull request #52690 from nsrCodes/batch-rename-preview-wrapRémi Verschelde2022-01-201-0/+1
|\ \
| * | Added the smart word wrap property to preview labelNavdeep Singh Rathore2021-09-151-0/+1
| | |
* | | Fix various typosluz paz2022-01-131-1/+1
| |/ |/| | | Found via `codespell -q 3 -S ./thirdparty,*.po,./DONORS.md -L ackward,ang,ans,ba,beng,cas,childs,childrens,dof,doubleclick,expct,fave,findn,gird,hist,inh,inout,leapyear,lod,nd,numer,ois,ony,paket,ro,seeked,sinc,switchs,te,uint,varn,vew`
* | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | | | | | Happy new year to the wonderful Godot community!
* | align to horizontal_alignment, valign to vertical_alignment, relatedNathan Franke2021-12-091-1/+1
| |
* | Modules: Make sure to include modules_enabled.gen.h where neededRémi Verschelde2021-11-121-0/+1
| |
* | Fix incorrect encoding (Latin-1 instead of UTF-8) used in `_error_handler` ↵bruvzg2021-11-081-3/+3
| | | | | | | | functions.
* | clang-format: Disable alignment of operands, too unreliableRémi Verschelde2021-10-281-1/+1
| | | | | | | | | | | | | | | | | | Sets `AlignOperands` to `DontAlign`. `clang-format` developers seem to mostly care about space-based indentation and every other version of clang-format breaks the bad mismatch of tabs and spaces that it seems to use for operand alignment. So it's better without, so that it respects our two-tabs `ContinuationIndentWidth`.