summaryrefslogtreecommitdiffstats
path: root/platform/windows/godot.natvis
Commit message (Collapse)AuthorAgeFilesLines
* Style: Trim trailing whitespace and ensure newline at EOFRémi Verschelde2024-05-081-1/+1
| | | | Found by apply the file_format checks again via #91597.
* Add PackedVector4Array Variant typeK. S. Ernest (iFire) Lee2024-05-031-3/+5
| | | | | Co-authored-by: A Thousand Ships <96648715+AThousandShips@users.noreply.github.com> Co-authored-by: Rémi Verschelde <rverschelde@gmail.com>
* Fix natvis after CowData 64-bit changesnikitalita2024-02-011-9/+9
|
* revamp godot.natvisnikitalita2024-01-101-25/+116
|
* added more data structures to Natvis for msdevderammo2022-09-041-17/+67
| | | | | can now debug signal_map and connections in Objects can now view more Variant types, such as packed arrays
* Visual Studio Natvis file works for Variant againderammo2022-07-311-2/+2
|
* Implement Vector4, Vector4i, Projectionreduz2022-07-231-0/+2
| | | | | | | | | | | | | Implement built-in classes Vector4, Vector4i and Projection. * Two versions of Vector4 (float and integer). * A Projection class, which is a 4x4 matrix specialized in projection types. These types have been requested for a long time, but given they were very corner case they were not added before. Because in Godot 4, reimplementing parts of the rendering engine is now possible, access to these types (heavily used by the rendering code) becomes a necessity. **Q**: Why Projection and not Matrix4? **A**: Godot does not use Matrix2, Matrix3, Matrix4x3, etc. naming convention because, within the engine, these types always have a *purpose*. As such, Godot names them: Transform2D, Transform3D or Basis. In this case, this 4x4 matrix is _always_ used as a _Projection_, hence the naming.
* Rename Quat to QuaternionMarcel Admiraal2021-06-041-4/+4
|
* Rename Variant TRANSFORM to TRANSFORM3DAaron Franke2021-06-031-2/+2
| | | Also _transform to _transform3d
* Added LocalVector to Visual Studio debugger visualizationPouleyKetchoupp2021-02-241-0/+10
|
* Incorrect format specifiers used to display some String/StringName dataandrew-softdev2020-12-281-33/+27
|
* Variant: Rename Type::_RID to Type::RIDRémi Verschelde2020-11-091-2/+2
| | | | | | | | The underscore prefix was used to avoid the conflict between the `RID` class name and the matching enum value in `Variant::Type`. This can be fixed differently by prefixing uses of the `RID` class in `Variant` with the scope resolution operator, as done already for `AABB`.
* Style: Fix code format scripts compat with non-GNU UnicesRémi Verschelde2020-07-271-3/+3
| | | | | | | It's too hard to get compatibility between GNU and BSD sed, so let's just use perl oneliners. And improve it to also remove trailing tabs, not just spaces.
* Update natvis file to display Node class correctly in Visual Studio debuggerPouleyKetchoupp2019-10-291-0/+8
|
* Fixed & improved Visual Studio custom debugger visualizationPouleyKetchoupp2019-03-121-65/+82
|
* Initial version of VS natvis fileelasota2018-09-171-0/+129