summaryrefslogtreecommitdiffstats
path: root/scene/2d/navigation_agent_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
...
* Merge pull request #62214 from smix8/navigation_layer_bitmask_helpers_4.xRémi Verschelde2022-06-201-0/+21
|\
| * Add navigation layer bitmask helper functionssmix82022-06-191-0/+21
| | | | | | | | Adds helper functions to work with the navigation layer bitmask.
* | Add NavigationAgent desired path distancesmix82022-06-181-1/+9
|/ | | | Add NavigationAgent desired path distance
* Streamline Navigation layer function names.smix82022-06-151-11/+11
| | | | Streamline Navigation layer function names.
* Add NavigationAgent set_navigation_map() functionsmix82022-06-141-2/+28
| | | | Add NavigationAgent set_navigation_map() and get_navigation_map() function.
* Fix NavigationAgent reparent issuessmix82022-06-011-8/+41
| | | | Fix NavigationAgent reparent issues
* Process NavigationAgent2D/3D avoidance on demand onlysmix82022-05-201-2/+19
| | | | | Changes NavigationAgent avoidance callback to a toggle that is disabled by default. Also fixes a few missing descriptions / wrong warnings.
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-6/+6
|
* Make Navigation Agents and Obstacles respect parent process modesmix82022-05-171-0/+20
| | | | Temporarily removes agent from navigation map when parent node cannot process due to SceneTree pause and process_mode property. Normal process_mode does not work as other agents would still avoid the paused agents because they were still active on the navigation map and the rvo world. Also fixes potential crash when region_get_map or agent_get_map is called while no map is set.
* Merge pull request #59331 from bartekd97/navigation-agent-layersRémi Verschelde2022-04-011-5/+16
|\
| * Expose navigable layers for NavigationAgent2D/3DBARTEK-PC\Bartek2022-03-201-5/+16
| |
* | String: Remove TTR and DTR defines in non-tools buildRémi Verschelde2022-03-281-1/+1
|/ | | | | This ensures we don't use TTR in runtime code, as it's specifically meant to source translations for the editor.
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-0/+2
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-0/+1
|
* i18n: Sync template with current 3.x codebaseRémi Verschelde2022-01-071-1/+1
| | | | | | Weblate will now track the state of `3.x` to prepare for the 3.5 release. (cherry picked from commit 02d9ac107158c8c5d95f1ecc48078d66e00c1a57)
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Improved readability for failing error conditionsDuroxxigar2021-10-081-2/+2
|
* Use get_global_* functions instead of using transforms.Anilforextra2021-08-141-4/+4
|
* Fix some unnecessary includesAaron Franke2021-08-131-1/+0
|
* Optimize StringName usagereduz2021-07-181-4/+4
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Merge pull request #47960 from smix8/issue_47334_navagent2d_target_reachedRémi Verschelde2021-04-271-6/+11
|\
| * put distance check to target into functionsmix82021-04-271-12/+11
| | | | | | | | put distance check to target into function
| * Fix NavigationAgent2D not emitting "target_reached" Signal reliablysmix82021-04-161-0/+6
| | | | | | | | Fix NavigationAgent2D not emitting "target_reached" Signal reliably
* | Fix broken NavigationAgent2D collision avoidance callbackssmix82021-04-201-3/+7
|/ | | | Fix broken NavigationAgent2D collision avoidance callbacks
* Use Array for node configuration warningsNathan Franke2021-04-111-7/+4
| | | | Previously, the warnings were passed as a string and delimitation of which were hard coded at each implementation.
* Implement Navigation layersGilles Roudière2021-03-101-1/+10
|
* Remove Navigation2D/3D nodes, and move the navigation map to the world resourceGilles Roudière2021-03-101-42/+2
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Rename empty() to is_empty()Marcel Admiraal2020-12-281-1/+1
|
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-1/+1
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* Merge pull request #38743 from arrowinaknee/node-config-warningsRémi Verschelde2020-10-011-2/+7
|\ | | | | Update all get_configuration_warning() to retrieve warnings from the parent
| * Update all get_configuration_warning to retrieve warnings from the parentArrowInAKnee2020-05-161-2/+7
| |
* | Split `Geometry` singleton into `Geometry2D` and `Geometry3D`Andrii Doroshenko (Xrayez)2020-05-271-1/+2
|/ | | | Extra `_2d` suffixes are removed from 2D methods accoringly.
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-7/+13
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-4/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Port member initialization from constructor to declaration (C++11)Rémi Verschelde2020-05-141-9/+1
| | | | | | | | | | Using `clang-tidy`'s `modernize-use-default-member-init` check and manual review of the changes, and some extra manual changes that `clang-tidy` failed to do. Also went manually through all of `core` to find occurrences that `clang-tidy` couldn't handle, especially all initializations done in a constructor without using initializer lists.
* Style: clang-format: Disable AllowShortIfStatementsOnASingleLineRémi Verschelde2020-05-101-3/+6
| | | | | | | Part of #33027, also discussed in #29848. Enforcing the use of brackets even on single line statements would be preferred, but `clang-format` doesn't have this functionality yet.
* Replace NULL with nullptrlupoDharkael2020-04-021-14/+14
|
* Renaming of servers for coherency.Juan Linietsky2020-03-271-15/+15
| | | | | | | | | | VisualServer -> RenderingServer PhysicsServer -> PhysicsServer3D Physics2DServer -> PhysicsServer2D NavigationServer -> NavigationServer3D Navigation2DServer -> NavigationServer2D Also renamed corresponding files.
* Fixes navigation path resetAndrea Catania2020-03-191-0/+1
|
* Variant: Added 64-bit packed arrays, renamed Variant::REAL to FLOAT.Juan Linietsky2020-02-251-6/+6
| | | | | | | | | | | | | | | | | | | | | - Renames PackedIntArray to PackedInt32Array. - Renames PackedFloatArray to PackedFloat32Array. - Adds PackedInt64Array and PackedFloat64Array. - Renames Variant::REAL to Variant::FLOAT for consistency. Packed arrays are for storing large amount of data and creating stuff like meshes, buffers. textures, etc. Forcing them to be 64 is a huge waste of memory. That said, many users requested the ability to have 64 bits packed arrays for their games, so this is just an optional added type. For Variant, the float datatype is always 64 bits, and exposed as `float`. We still have `real_t` which is the datatype that can change from 32 to 64 bits depending on a compile flag (not entirely working right now, but that's the idea). It affects math related datatypes and code only. Neither Variant nor PackedArray make use of real_t, which is only intended for math precision, so the term is removed from there to keep only float.
* Vulkan: Move thirdparty code out of drivers, style fixesRémi Verschelde2020-02-111-1/+1
| | | | | | | - `vk_enum_string_helper.h` is a generated file taken from the SDK (Vulkan-ValidationLayers). - `vk_mem_alloc.h` is a library from GPUOpen: https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator
* - Integrated NavigationServer and Navigation2DServer.Andrea Catania2020-02-101-0/+341
- Added Navigation Agents and Obstacles. - Integrated Collision Avoidance. This work has been kindly sponsored by IMVU.