summaryrefslogtreecommitdiffstats
path: root/scene/3d/lightmap_gi.cpp
Commit message (Collapse)AuthorAgeFilesLines
...
| * Validate physical light units in GI classes.clayjohn2022-09-141-3/+12
| | | | | | | | Add checks for physical light units in a few more places to ensure they aren't used when disabled.
* | Tweak LightmapGI defaults to be closer to the CPU lightmapperHugo Locurcio2022-09-161-2/+3
|/ | | | | | | | | | | | | | - Use 3 bounces by default. - Enable environment lighting from the scene by default. - This is not done in `3.x` for compatibility with existing projects, but it makes sense to do this by default since pretty much all outdoor scenes benefit from this. - Set the custom environment color to white (like ReflectionProbe). - Its default energy is still 0, so it's invisible by default. - Enable the generation of dynamic object probes by default. - Tweak the `max_texture_size` property hint for better usability. - Improve error messages when passing invalid sizes to `LightmapGI.set_max_texture_size()`.
* Fix crash when executing `LightmapGIData._set_light_textures_data`Haoyu Qiu2022-09-041-0/+1
|
* Merge pull request #65170 from KoBeWi/your_argument_is_TypedArrayRémi Verschelde2022-09-021-2/+2
|\
| * Change Array arguments to TypedArraykobewi2022-09-011-2/+2
| |
* | Implement Physical Light Units as an optional setting.clayjohn2022-08-311-7/+42
|/ | | | | | This allows light sources to be specified in physical light units in addition to the regular energy multiplier. In order to avoid loss of precision at high values, brightness values are premultiplied by an exposure normalization value. In support of Physical Light Units this PR also renames CameraEffects to CameraAttributes.
* Make `_validate_property` a multilevel methodYuri Sizov2022-08-221-8/+7
|
* Swap arguments of ResourceSaver.save()kobewi2022-07-291-1/+1
|
* Use integer types in Image and ImageTexture methodsFireForge2022-07-181-1/+1
| | | | | | | | | | | - Image.blit_rect() - Image.blit_rect_mask() - Image.blend_rect() - Image.blend_rect_mask() - Image.fill_rect() - Image.get_used_rect() - Image.get_rect() - ImageTexture.set_size_override()
* Remove unused hintskobewi2022-07-121-1/+1
|
* Merge pull request #62124 from holgac/bugfix-62096JFonS2022-06-261-1/+1
|\ | | | | Fixes #62096: LightmapGIData::_get_light_textures_data crash on empty image
| * Fixes #62096: LightmapGIData::_get_light_textures_data crash on empty imageholgac2022-06-171-1/+1
| | | | | | | | | | | | The program crashes when trying to determine slice width/height if the light texture is empty. This fix just returns an empty array, as if the light texture does not exist.
* | add support for soft shadows to the lightmapperPriyansh Rathi2022-06-241-3/+3
| |
* | Clean up Hash Functionsreduz2022-06-201-2/+2
|/ | | | | | | Clean up and do fixes to hash functions and newly introduced murmur3 hashes in #61934 * Clean up usage of murmur3 * Fixed usages of binary murmur3 on floats (this is invalid) * Changed DJB2 to use xor (which seems to be better)
* save lightmap as multi-image atlasPriyansh Rathi2022-06-141-50/+107
|
* Fix warnings found by Emscripten 3.1.10Rémi Verschelde2022-05-101-3/+2
| | | | | Fix `-Wunused-but-set-variable`, `-Wunqualified-std-cast-call`, and `-Wliteral-range` warnings.
* Rename Basis get_axis to get_column, remove redundant methodsAaron Franke2022-05-031-2/+2
|
* Color: Rename `to_srgb`/`to_linear` to include base color spaceRémi Verschelde2022-04-131-1/+1
| | | | | This helps reduce confusion around sRGB <> Linear conversions by making both input and output color spaces explicit.
* Make FileAccess and DirAccess classes reference counted.bruvzg2022-04-111-3/+2
|
* String: Remove TTR and DTR defines in non-tools buildRémi Verschelde2022-03-281-8/+8
| | | | | This ensures we don't use TTR in runtime code, as it's specifically meant to source translations for the editor.
* Discern between virtual and abstract class bindingsreduz2022-03-101-4/+0
| | | | | | | | | | | | | | * Previous "virtual" classes (which can't be instantiated) are not corretly named "abstract". * Added a new "virtual" category for classes, they can't be instantiated from the editor, but can be inherited from script and extensions. * Converted a large amount of classes from "abstract" to "virtual" where it makes sense. Most classes that make sense have been converted. Missing: * Physics servers * VideoStream * Script* classes. which will go in a separate PR due to the complexity involved.
* Rename StreamTexture* to CompressedTexture*reduz2022-03-051-1/+1
| | | | | | * Its not and will not be used for streaming. * Streaming will be implemented in 4.1 and it will work different. * It makes more sense to be called CompressedTexture since it imports and compresses texture files.
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-9/+11
|
* Merge pull request #55360 from Calinou/rename-bake-mode-propertiesRémi Verschelde2022-01-201-1/+1
|\
| * Rename and reorder bake mode properties for consistencyHugo Locurcio2021-12-141-1/+1
| | | | | | | | | | | | | | | | The order now goes from least to most computationally expensive: - Disabled - Static - Dynamic
* | Use fill() to fill an entire image instead of setting pixels individually.Anilforextra2022-01-081-5/+1
| |
* | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | | | | | Happy new year to the wonderful Godot community!
* | GPULightMapper: convert colors of lights to linearWilliam Deurwaarder2021-12-111-3/+4
| | | | | | | | | | | | To make baked colors of lights equal to dynamic colors of lights they have to be converted to linear as the colors of dynamic lights are converted to linear by RendererSceneRenderRD.
* | Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-1/+1
|/ | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* Rename `PROPERTY_USAGE_NOEDITOR` to `PROPERTY_USAGE_NO_EDITOR`Hugo Locurcio2021-11-031-3/+3
| | | | | This is consistent with other constants that include `NO`, such as `PROPERTY_HINT_COLOR_NO_ALPHA`.
* Refactored Node3D rotation modesreduz2021-10-251-0/+1
| | | | | | | | | * Made the Basis euler orders indexed via enum. * Node3D has a new rotation_order property to choose Euler rotation order. * Node3D has also a rotation_mode property to choose between Euler, Quaternion and Basis Exposing these modes as well as the order makes Godot a lot friendlier for animators, which can choose the best way to interpolate rotations. The new *Basis* mode makes the (exposed) transform property obsolete, so it was removed (can still be accessed by code of course).
* Add Get Center Method for Rect2/Rect2i and AABB.Anilforextra2021-09-211-2/+2
|
* Fix some unnecessary includesAaron Franke2021-08-131-6/+1
|
* Node3D gizmo improvementsjfons2021-07-231-1/+1
| | | | | | | | * Clean-up of node_3d_editor_plugin.{h,cpp}: removed unused code, fixed some bugs. * Moved node_3d_editor_gizmos.{h,cpp} to editor/plugins. * Added support for multiple gizmos per node. This means custom gizmos will no longer override the built-in ones and that multiple gizmos can be used in more complex nodes. * Added support for handle IDs. When adding handles to a gizmo, an ID can be specified for each one, making it easier to work with gizmos that have a variable number of handles. * Added support for subgizmos, selectable elements that can be transformed without needing a node of their own. By overriding _subgizmo_intersect_frustum() and/or _subgizmo_intersect_ray() gizmos can define which subgizmos should be selected on a region or click selection. Subgizmo transformations are applied using get/set/commit virtual methods, similar to how handles work.
* Use is_equal_approx in more placesAaron Franke2021-07-211-1/+1
|
* Use PROPERTY_USAGE_NONE instead of 0 for no property usageAaron Franke2021-07-011-3/+3
| | | | Also use const more often.
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-5/+5
|
* Core: Move DirAccess and FileAccess to `core/io`Rémi Verschelde2021-06-111-2/+2
| | | | | File handling APIs are typically considered part of I/O, and we did have most `FileAccess` implementations in `core/io` already.
* Rename GI Classesreduz2021-06-051-0/+1466
* GIProbe is now VoxelGI * BakedLightmap is now LightmapGI As godot adds more ways to provide GI (as an example, SDFGI in 4.0), the different techniques (which have different pros/cons) need to be properly named to avoid confusion.