summaryrefslogtreecommitdiffstats
path: root/servers/audio/effects
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-2740-80/+80
|
* Rebrand preambles to RedotSpartan3222024-10-1340-0/+80
| | | | | | | | | | | | | | | | | | | | | | | | (cherry picked from commit e8542b06acca3c1bdeee4b528411771f0819f084) Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Rebrand Godot 4.3 to RedotTrashguy2024-10-132-3/+3
|
* Add AudioEffectHardLimiter as a rework of audio limiter effectlandervr2024-03-252-0/+250
|
* AudioEffectPitchShift: Actually fix -Wstringop-overflow warningRémi Verschelde2024-02-222-46/+21
| | | | Previous commit didn't help, so its changes are reverted.
* AudioEffectPitchShift: Prevent negative size memset (GCC warning)Rémi Verschelde2024-02-191-3/+5
|
* Fix member names of `AudioFrame` to match extensionA Thousand Ships2024-02-1313-46/+46
|
* Replace error checks against `size` with `is_empty`A Thousand Ships2024-02-091-1/+1
|
* bugfix for audio stream generators getting killed accidentally by audio serverFabian Keller2023-09-101-4/+7
|
* Fix AudioEffectRecord circular referenceWilson E. Alvarez2023-06-192-26/+20
|
* Fix wait for thread not startedSamuele Panzeri2023-04-271-1/+3
|
* Merge pull request #70515 from stmSi/fix-hanging-audio-pitch-scaleRémi Verschelde2023-02-171-1/+1
|\ | | | | | | Fix hanging if audiostream's pitch_scale is NaN
| * Fix Editor hanging if audiostream's pitch_scale is NaNstmSi2022-12-241-1/+1
| |
* | One Copyright Update to rule them allRémi Verschelde2023-01-0538-1102/+1102
|/ | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* AudioEffectDistorion docs & inspector editsM-O-Marmalade2022-11-221-2/+2
| | | | | | | | Fixing a few typos in the AudioEffectDistortion docs, making a few things clearer, etc Also adding the decibel (dB) suffix to the pre/post gain properties in the inspector.
* Style: Misc docs and comment style and language fixesRémi Verschelde2022-11-023-6/+6
| | | | | | | | | | - Removed empty paragraphs in XML. - Consistently use bold style for "Example:", on a new line. - Fix usage of `[code]` when hyperlinks could be used (`[member]`, `[constant]`). - Fix invalid usage of backticks for inline code in BBCode. - Fix some American/British English spelling inconsistencies. - Other minor fixes spotted along the way, including typo fixes with codespell. - Don't specify `@GlobalScope` for `enum` and `constant`.
* Fix MSVC warnings, rename shadowed variables, fix uninitialized values, ↵bruvzg2022-10-071-3/+3
| | | | change warnings=all to use /W4.
* Remove NO_THREADS fallback code, Godot 4 requires thread supportRémi Verschelde2022-10-031-8/+0
| | | | | This also removes `OS::can_use_threads` from the public API since it's always true.
* Use `constexpr` in the conditions with template parameters and `sizeof`s to ↵bruvzg2022-09-292-7/+7
| | | | suppress C4127 warnings.
* Change time parameters and variables to double typeDave Palais2022-09-262-8/+8
| | | | Addresses #65313
* Rename `str2var` to `str_to_var` and similarMicky2022-08-267-20/+20
| | | | | | | | | | | | | | | | | | Affects the Math class, a good chunk of the audio code, and a lot of other miscellaneous classes, too. - `var2str` -> `var_to_str` - `str2var` -> `str_to_var` - `bytes2var` -> `bytes_to_var` - `bytes2var_with_objects` -> `bytes_to_var_with_objects` - `var2bytes` -> `var_to_bytes` - `var2bytes_with_objects` -> `var_to_bytes_with_objects` - `linear2db` -> `linear_to_db` - `db2linear` -> `db_to_linear` - `deg2rad` -> `deg_to_rad` - `rad2deg` -> `rad_to_deg` - `dict2inst` -> `dict_to_inst` - `inst2dict` -> `inst_to_dict`
* Rename properties unnecessarily using slash (`/`) in their namesRémi Verschelde2022-08-232-47/+33
| | | | | | | | | This is a legacy of Godot 2 days before the inspector had support for groups. "Properties" with a slash in their name can't be accessed from script unless using `set()`/`get()` so they were not actual properties as far as script languages are concerned. Part of #17558.
* Make `_validate_property` a multilevel methodYuri Sizov2022-08-225-18/+18
|
* Merge pull request #60957 from DeeJayLSP/sample_pcmRémi Verschelde2022-07-282-15/+15
|\
| * Rename AudioStreamSample to a more discoverable nameDeeJayLSP2022-07-282-15/+15
| |
* | Code quality: Fix header guards consistencyRémi Verschelde2022-07-2516-42/+44
|/ | | | | Adds `header_guards.sh` bash script, used in CI to validate future changes. Can be run locally to fix invalid header guards.
* Implement BPM supportreduz2022-07-232-2/+8
| | | | | | | | | | | Based on #62896, only implements the BPM support part. * Implements BPM support in the AudioStreamOGG/MP3 importers. * Can select BPM/Bar Size and total beats in a song file, as well as edit looping points. * Looping is now BPM aware * Added a special importer UI for configuring this. * Added a special preview showing the audio waveform as well as the playback position in the resource picker. * Renamed `AudioStream::instance` to `instantiate` for correctness.
* Cleanup AudioEffectRecord thread_active variableMarcel Admiraal2022-06-172-5/+0
|
* Add suffixes to all nodes and resourcesFireForge2022-06-1112-42/+42
|
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-1/+1
|
* Replace most uses of Map by HashMapreduz2022-05-162-5/+5
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Style: Partially apply clang-tidy's `cppcoreguidelines-pro-type-member-init`Rémi Verschelde2022-05-024-19/+16
| | | | | | | | | | | Didn't commit all the changes where it wants to initialize a struct with `{}`. Should be reviewed in a separate PR. Option `IgnoreArrays` enabled for now to be conservative, can be disabled to see if it proposes more useful changes. Also fixed manually a handful of other missing initializations / moved some from constructors.
* Fix some issues found by cppcheck.bruvzg2022-04-061-1/+1
|
* Zero initialize all pointer class and struct membersRémi Verschelde2022-04-043-3/+3
| | | | | This prevents the pitfall of UB when checking if they have been assigned something valid by comparing to nullptr.
* Remove last editor code dependencies in template buildRémi Verschelde2022-03-282-1/+9
| | | | | | SConstruct change also makes it possible to outright delete the `editor` folder in a `tools=no` build, which we use in CI to ensure no invalid cross-dependencies are added.
* Discern between virtual and abstract class bindingsreduz2022-03-101-1/+1
| | | | | | | | | | | | | | * Previous "virtual" classes (which can't be instantiated) are not corretly named "abstract". * Added a new "virtual" category for classes, they can't be instantiated from the editor, but can be inherited from script and extensions. * Converted a large amount of classes from "abstract" to "virtual" where it makes sense. Most classes that make sense have been converted. Missing: * Physics servers * VideoStream * Script* classes. which will go in a separate PR due to the complexity involved.
* Revert "PitchShift effect quality and performance tweaks for different pitch ↵Rémi Verschelde2022-03-022-81/+56
| | | | scale values"
* Style: Cleanup single-line blocks, semicolons, dead codeRémi Verschelde2022-02-162-4/+0
| | | | | Remove currently unused implementation of TextureBasisU, could be re-added later on if needed and ported.
* Audio quality improvements in PitchShiftBartłomiej T. Listwon2022-02-112-56/+73
|
* Pass audio samples untouched for pitch_scale around 1.0fBartłomiej T. Listwon2022-02-111-0/+8
|
* Vectors: Use clear() and has().Anilforextra2022-02-021-1/+1
| | | | | | Use clear() instead of resize(0). Use has() instead of "find(p_val) != -1".
* Style: Remove inconsistently used `@author` docstringsRémi Verschelde2022-01-042-10/+2
| | | | | | | | | | Each file in Godot has had multiple contributors who co-authored it over the years, and the information of who was the original person to create that file is not very relevant, especially when used so inconsistently. `git blame` is a much better way to know who initially authored or later modified a given chunk of code, and most IDEs now have good integration to show this information.
* Update copyright statements to 2022Rémi Verschelde2022-01-0338-76/+76
| | | | Happy new year to the wonderful Godot community!
* Remove unimplemented methodsMarcel Admiraal2021-10-213-5/+0
|
* Merge pull request #52237 from ellenhp/polyphonyJuan Linietsky2021-09-072-0/+5
|\ | | | | Add optional polyphonic playback to built-in audio player nodes
| * Add polyphony to Audio Stream Player nodesEllen Poe2021-09-072-0/+5
| |
* | [Net] Move multiplayer to core subdir, split RPCManager.Fabio Alessandrelli2021-09-071-0/+1
|/ | | | | | | | | | | Move multiplayer classes to "core/multiplayer" subdir. Move the RPCConfig and enums (TransferMode, RPCMode) to a separate file (multiplayer.h), and bind them to the global namespace. Move the RPC handling code to its own class (RPCManager). Renames "get_rpc_sender_id" to "get_remote_sender_id".
* Require AudioStream::mix to return the number of frames successfully mixedEllen Poe2021-08-272-2/+3
|
* Replace HTTP links with HTTPS for sites with HTTPS versionsAaron Franke2021-08-221-1/+1
|
* Use PROPERTY_USAGE_NONE instead of 0 for no property usageAaron Franke2021-07-012-4/+4
| | | | Also use const more often.