summaryrefslogtreecommitdiffstats
path: root/servers/physics_server_2d.h
Commit message (Collapse)AuthorAgeFilesLines
...
* Merge pull request #52271 from nekomatata/query-layer-default-maskCamille Mohr-Daurat2021-09-061-13/+11
|\ | | | | Harmonize default value for collision mask in ray/shape queries
| * Harmonize default value for collision mask in ray/shape queriesPouleyKetchoupp2021-08-301-13/+11
| | | | | | | | | | | | | | | | The default mask for queries was 0, 0x7FFFFFFF or 0xFFFFFFFF depending on the cases. Now always using 0xFFFFFFFF (in the form of UINT32_MAX to make it clear) in order to use all layers by default.
* | Merge pull request #49471 from nekomatata/body-state-sync-callbackJuan Linietsky2021-08-311-0/+4
|\ \ | |/ |/| Clean physics direct body state usage in 2D and 3D physics
| * Clean physics direct body state usage in 2D and 3D physicsPouleyKetchoupp2021-08-251-0/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Use a C++ callback instead of Callable for synchronizing physics nodes' state with physics servers. Remove usage of PhysicsDirectBodyState in physics nodes when not necessary. Store PhysicsDirectBodyState for bodies individually instead of a singleton to avoid issues when accessing direct body state for multiple bodies. PhysicsDirectBodyState is initialized only when needed, so it doesn't have to be created when using the physics server directly. Move PhysicsDirectBodyState2D and PhysicsDirectBodyState3D to separate cpp files.
* | Rename RayShape to SeparationRayShapePouleyKetchoupp2021-08-241-2/+2
| | | | | | | | | | Makes it clearer that it's used for special cases when picking a collision shape.
* | Fix CharacterBody motion with RayShapePouleyKetchoupp2021-08-241-2/+2
| | | | | | | | | | | | | | | | | | | | Make separation ray shapes work properly in move_and_slide, wihtout the specific code in CharacterBody like before. Now most of the logic is handled inside the physics server. The only thing that's needed is to use ray shapes only for recovery and ignore them when performing the motion itself (unless we're snapping or slips on slope is on).
* | Restore RayShape as a regular shape typePouleyKetchoupp2021-08-241-0/+2
|/ | | | | Partial revert from previously removing ray shapes completely, added back as a shape type but without the specific character controller code.
* API improvement on physics, mainly CharacterBodyfabriceci2021-08-151-3/+7
| | | | | | | | | | | | Changes: - Rename few methods/property and group them in the editor when it's possible - Make MotionResult API consistency with KinematicCollision - Return a boolean in move_and_slide if there was a collision - New methods: - get_floor_angle on CharacterBody to get the floor angle. - get_angle on KinematicCollision to get the collision angle. - get_last_slide_collision to quickly get the latest collision of move_and_slide.
* Rename LineShape2D to WorldMarginShape2DHugo Locurcio2021-08-141-2/+2
| | | | | The new name makes it more obvious that it acts as an infinite plane, and is consistent with its 3D counterpart (WorldMarginShape3D).
* Remove infinite inertia and ray shapes from CharacterBodyPouleyKetchoupp2021-08-101-6/+2
| | | | | | | | | | | Infinite inertia: Not needed anymore, since it's now possible to set one-directional collision layers in order for characters to ignore rigid bodies, while rigid bodies still collide with characters. Ray shapes: They were introduced as a work around to allow constant speed on slopes, which is now possible with the new property in CharacterBody instead.
* Fix applied rotation from moving platforms in move_and_slidePouleyKetchoupp2021-08-091-0/+2
| | | | | | | | | When synchronizing CharacterBody motion with moving the platform using direct body state, only the linear velocity was taken into account. This change exposes velocity at local point in direct body state and uses it in move_and_slide to get the proper velocity that includes rotations.
* Fixing 2D moving platform logicfabriceci2021-07-151-2/+2
| | | | | | Fixing by applying the movement in two steps, first the platform movement, and then the body movement. Plus, add the platform movement when we are on_wall.
* Add a method to set the number of physics solver iterations in 3DHugo Locurcio2021-07-101-1/+1
| | | | | This is only for GodotPhysics, and adds a 3D counterpart to the 2D method that was recently added.
* Remove unused PhysicsShapeQueryResult3D & PhysicsShapeQueryResult2DPouleyKetchoupp2021-07-051-22/+0
|
* Expose body_test_motion in 3D physics serverPouleyKetchoupp2021-07-021-2/+2
| | | | | | | Results are exposed through PhysicsTestMotionResult3D, the same way it's done for 2D. Also cleaned a few things in the 2D version.
* Fix move_and_collide causing sliding on slopesPouleyKetchoupp2021-06-281-0/+6
| | | | | | | | | | | Make sure the direction of the motion is preserved, unless the depth is higher than the margin, which means the body needs depenetration in any direction. Also changed move_and_slide to avoid sliding on the first motion, in order to avoid issues with unstable position on ground when jumping. Co-authored-by: fabriceci <fabricecipolla@gmail.com>
* Rename Reference to RefCountedPedro J. Estébanez2021-06-111-7/+7
|
* Fix uninitialized members in physics query resultsPouleyKetchoupp2021-06-071-5/+5
|
* More explanatory names for RigidBody modesPouleyKetchoupp2021-06-041-2/+2
| | | | | | | | | MODE_DYNAMIC instead of MODE_RIGID MODE_DYNAMIC_LOCKED instead of MODE_CHARACTER No more special case for sleeping behavior for MODE_DYNAMIC_LOCKED (MODE_CHARACTER was forcing the body not to sleep, which is redundant with can_sleep and wasn't done in Bullet).
* KinematicBody split between new CharacterBody and PhysicsBodyPouleyKetchoupp2021-06-041-12/+2
| | | | | | | | | | | PhysicsBody now has methods move_and_collide/test_move and needed properties for these methods: safe margin, locked axes (3D only). Moved collision_exceptions from StaticBody to PhysicsBody for 3D (same as 2D, and conforms to documentation). RigidBody doesn't have test_motion method anymore, it's now redundant with PhysicsBody.test_move.
* Enable setting of collision iterations in PhysicsServer2DRhathe2021-05-191-0/+2
| | | | | This allows fine-tuning of collision iterations for more accurate collision physics with a performance cost.
* Prevent setting too big or too small Collision Mask and LayerRafał Mikrut2021-04-301-2/+2
|
* Unexpose _direct_state_changed in PhysicsBodyrafallus2021-04-221-1/+1
| | | | | | | Removed _direct_state_changed bindings Affects 2D and 3D nodes Callbacks now use Callable Tests were changed accordingly
* Make Servers truly Thread Safereduz2021-02-101-6/+11
| | | | | | | | | -Rendering server now uses a split RID allocate/initialize internally, this allows generating RIDs immediately but initialization to happen later on the proper thread (as rendering APIs generally requiere to call on the right thread). -RenderingServerWrapMT is no more, multithreading is done in RenderingServerDefault. -Some functions like texture or mesh creation, when renderer supports it, can register and return immediately (so no waiting for server API to flush, and saving staging and command buffer memory). -3D physics server changed to be made multithread friendly. -Added PhysicsServer3DWrapMT to use 3D physics server from multiple threads. -Disablet Bullet (too much effort to make multithread friendly, this needs to be fixed eventually).
* Use real_t in physics codeAaron Franke2021-01-281-24/+24
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Remove empty lines around braces with the formatting scriptAaron Franke2020-11-161-3/+0
|
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-3/+3
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* Refactor MethodBind to use variadic templatesreduz2020-10-181-1/+1
| | | | Removed make_binders and the old style generated binders.
* Ensure assignment operators return by reference to avoid unnecessary copies.Marcel Admiraal2020-09-041-1/+1
|
* Merge pull request #37350 from aaronfranke/force-impulseRémi Verschelde2020-07-021-4/+4
|\ | | | | Refactor physics force and impulse code to use (force, position) order
| * Refactor physics force and impulse codeAaron Franke2020-06-021-4/+4
| |
* | Expose shape property for shape query parameters classesAndrii Doroshenko (Xrayez)2020-06-261-1/+4
| | | | | | | | Co-authored-by: PouleyKetchoupp <pouleyketchoup@gmail.com>
* | Correct misspellings of damped spring.Marcel Admiraal2020-06-041-7/+7
|/
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-11/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Port member initialization from constructor to declaration (C++11)Rémi Verschelde2020-05-141-4/+2
| | | | | | | | | | Using `clang-tidy`'s `modernize-use-default-member-init` check and manual review of the changes, and some extra manual changes that `clang-tidy` failed to do. Also went manually through all of `core` to find occurrences that `clang-tidy` couldn't handle, especially all initializations done in a constructor without using initializer lists.
* Replace NULL with nullptrlupoDharkael2020-04-021-2/+2
|
* More server renames for consistency after #37361Rémi Verschelde2020-03-281-6/+6
|
* Renaming of servers for coherency.Juan Linietsky2020-03-271-0/+699
VisualServer -> RenderingServer PhysicsServer -> PhysicsServer3D Physics2DServer -> PhysicsServer2D NavigationServer -> NavigationServer3D Navigation2DServer -> NavigationServer2D Also renamed corresponding files.