summaryrefslogtreecommitdiffstats
path: root/dev-games/redot-bin/redot-bin-4.3_beta.ebuild
diff options
context:
space:
mode:
authorDubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com>2024-10-23 22:17:41 -0500
committerDubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com>2024-10-23 22:17:41 -0500
commit46a404e64ce3ed1d8cccc407ff9671305613118b (patch)
tree6271aeed461affcc026c998f3db618a5a4da5c7a /dev-games/redot-bin/redot-bin-4.3_beta.ebuild
parentbddeac6e6a25341933690dc125e826e64307f030 (diff)
downloadmcdubh-overlay-46a404e64ce3ed1d8cccc407ff9671305613118b.tar.gz
Adding Redot 4.3
Diffstat (limited to 'dev-games/redot-bin/redot-bin-4.3_beta.ebuild')
-rw-r--r--dev-games/redot-bin/redot-bin-4.3_beta.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-games/redot-bin/redot-bin-4.3_beta.ebuild b/dev-games/redot-bin/redot-bin-4.3_beta.ebuild
new file mode 100644
index 0000000..cab9f84
--- /dev/null
+++ b/dev-games/redot-bin/redot-bin-4.3_beta.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Open-source game engine for everyone. No strings attached."
+HOMEPAGE="https://www.redotengine.org/"
+SRC_URI="https://github.com/Redot-Engine/redot-engine/releases/download/redot-4.3-beta.1/Redot_v4.3-beta.1_linux.x86_64.zip -> ${P}.zip"
+
+LICENSE="
+ MIT
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="
+ alsa +dbus debug deprecated +fontconfig +gui pulseaudio raycast
+ speech test +theora +tools +udev +upnp +vulkan wayland +webp
+"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/brotli:=
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli,harfbuzz]
+ media-libs/harfbuzz:=[icu]
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libvorbis
+ <net-libs/mbedtls-3:=
+ net-libs/wslay
+ sys-libs/zlib:=
+ media-libs/alsa-lib
+ sys-apps/dbus
+ media-libs/fontconfig
+ media-libs/libglvnd
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libxkbcommon
+ media-libs/embree:4
+ media-libs/vulkan-loader[X,wayland?]
+ media-libs/libpulse
+ media-libs/libtheora
+ app-misc/ca-certificates
+ virtual/udev
+ media-libs/libwebp:=
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+ dev-util/wayland-scanner
+"
+
+src_unpack() {
+ unpack ${P}.zip
+ mv redot-linux-dev ${P}
+ mv ${P}/redot.linuxbsd.editor.x86_64 ${P}/${P}
+}
+
+src_install() {
+ newbin redot* redot-bin
+}
+
+