summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThaddeus Crews <repiteo@outlook.com>2024-06-03 10:19:58 -0500
committerThaddeus Crews <repiteo@outlook.com>2024-06-03 10:19:58 -0500
commit26859357c5b3702c72706cce0fcd39d7c15bbc8b (patch)
tree0dcfb8c7fbe18a8d1196c2ab6c52be4876814d2d /pyproject.toml
parent5f1184e93fe1021c86520460dc0a6619bff3c1fb (diff)
downloadredot-engine-26859357c5b3702c72706cce0fcd39d7c15bbc8b.tar.gz
CI: Migrate codespell logic to `pyproject.toml`
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 34ae075f2b..59b6d09a03 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -27,3 +27,51 @@ extend-select = [
"E402", # Module level import not at top of file
"F821", # Undefined name
]
+
+[tool.codespell]
+enable-colors = ""
+write-changes = ""
+check-hidden = ""
+quiet-level = 3
+builtin = "clear,rare,en-GB_to_en-US"
+skip = """\
+ .mailmap,
+ *.desktop,
+ *.gitignore,
+ *.po,
+ *.pot,
+ *.rc,
+ AUTHORS.md,
+ COPYRIGHT.txt,
+ core/input/gamecontrollerdb.txt,
+ core/string/locales.h,
+ DONORS.md,
+ editor/project_converter_3_to_4.cpp,
+ platform/android/java/lib/src/com/*,
+ platform/web/package-lock.json
+"""
+ignore-words-list = """\
+ breaked,
+ cancelled,
+ checkin,
+ colour,
+ curvelinear,
+ doubleclick,
+ expct,
+ findn,
+ gird,
+ hel,
+ inout,
+ labelin,
+ lod,
+ mis,
+ nd,
+ numer,
+ ot,
+ outin,
+ requestor,
+ te,
+ textin,
+ thirdparty,
+ vai
+"""