summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThaddeus Crews <repiteo@outlook.com>2024-11-14 11:15:41 -0600
committerThaddeus Crews <repiteo@outlook.com>2024-11-14 13:05:21 -0600
commit70d41e7cecf491dc1cdbf0ac4b61bd36e0364b8a (patch)
tree8ed9a4969db93141fc66795a0672f87064e269ea /pyproject.toml
parent76fa7b291455a8ba24c50005072ebdb58f8a5984 (diff)
downloadredot-engine-70d41e7cecf491dc1cdbf0ac4b61bd36e0364b8a.tar.gz
Style: Update `pyproject.toml` syntax
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml98
1 files changed, 49 insertions, 49 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c4fbe4a459..403d9fd675 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,14 +1,14 @@
[tool.mypy]
-ignore_missing_imports = true
disallow_any_generics = true
+explicit_package_bases = true
+ignore_missing_imports = true
+namespace_packages = true
no_implicit_optional = true
pretty = true
show_column_numbers = true
warn_redundant_casts = true
warn_return_any = true
warn_unreachable = true
-namespace_packages = true
-explicit_package_bases = true
exclude = ["thirdparty/"]
python_version = "3.8"
@@ -42,50 +42,50 @@ section-order = [
]
[tool.codespell]
-enable-colors = ""
-write-changes = ""
-check-hidden = ""
+enable-colors = true
+write-changes = true
+check-hidden = true
quiet-level = 3
-builtin = "clear,rare,en-GB_to_en-US"
-skip = """\
- .mailmap,
- *.desktop,
- *.gitignore,
- *.po,
- *.pot,
- *.rc,
- AUTHORS.md,
- COPYRIGHT.txt,
- core/input/gamecontrollerdb.txt,
- core/string/locales.h,
- DONORS.md,
- editor/project_converter_3_to_4.cpp,
- platform/android/java/lib/src/com/*,
- platform/web/package-lock.json
-"""
-ignore-words-list = """\
- breaked,
- cancelled,
- checkin,
- colour,
- curvelinear,
- doubleclick,
- expct,
- findn,
- gird,
- hel,
- inout,
- labelin,
- lod,
- mis,
- nd,
- numer,
- ot,
- outin,
- parm,
- requestor,
- te,
- textin,
- thirdparty,
- vai
-"""
+builtin = ["clear", "rare", "en-GB_to_en-US"]
+skip = [
+ ".mailmap",
+ "*.desktop",
+ "*.gitignore",
+ "*.po",
+ "*.pot",
+ "*.rc",
+ "AUTHORS.md",
+ "COPYRIGHT.txt",
+ "core/input/gamecontrollerdb.txt",
+ "core/string/locales.h",
+ "DONORS.md",
+ "editor/project_converter_3_to_4.cpp",
+ "platform/android/java/lib/src/com/*",
+ "platform/web/package-lock.json",
+]
+ignore-words-list = [
+ "breaked",
+ "cancelled",
+ "checkin",
+ "colour",
+ "curvelinear",
+ "doubleclick",
+ "expct",
+ "findn",
+ "gird",
+ "hel",
+ "inout",
+ "labelin",
+ "lod",
+ "mis",
+ "nd",
+ "numer",
+ "ot",
+ "outin",
+ "parm",
+ "requestor",
+ "te",
+ "textin",
+ "thirdparty",
+ "vai",
+]