summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThaddeus Crews <repiteo@outlook.com>2024-06-11 15:19:07 -0500
committerThaddeus Crews <repiteo@outlook.com>2024-09-25 09:34:35 -0500
commit9f9ee0c813443333a49c797083ff456629c009fb (patch)
tree36dbb6cd89f1b81eaf7940a2d097dc77e55a7f61 /pyproject.toml
parent0a9d8f04c10870c0f9f7bbd2e0505edc8494e299 (diff)
downloadredot-engine-9f9ee0c813443333a49c797083ff456629c009fb.tar.gz
SCons: Add unobtrusive type hints in SCons files
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 13 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 78c8d8c20e..a4bfd27816 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -26,7 +26,19 @@ extend-select = [
[tool.ruff.lint.per-file-ignores]
"{SConstruct,SCsub}" = [
"E402", # Module level import not at top of file
- "F821", # Undefined name
+ "F403", # Undefined local with import star
+ "F405", # Undefined local with import star usage
+]
+
+[tool.ruff.lint.isort]
+sections = { metadata = ["misc.utility.scons_hints"] }
+section-order = [
+ "future",
+ "metadata",
+ "standard-library",
+ "third-party",
+ "first-party",
+ "local-folder",
]
[tool.codespell]