summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJakub Marcowski <chubercikbattle@gmail.com>2024-05-21 15:14:59 +0200
committerThaddeus Crews <repiteo@outlook.com>2024-05-21 18:02:29 -0500
commitd9f8ef68df1df8cf88d484fc22995f55a9c3f9aa (patch)
tree69f67b54e7fbb15be77877d5de8d3906fc41b882 /pyproject.toml
parentaaa4560729bf0161deb71789b47eba5623893845 (diff)
downloadredot-engine-d9f8ef68df1df8cf88d484fc22995f55a9c3f9aa.tar.gz
Update pre-commit hooks configuration to use `ruff` instead of `black`
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 15 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f1ea10fbae..34ae075f2b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,6 +11,19 @@ namespace_packages = true
explicit_package_bases = true
exclude = ["thirdparty/"]
-[tool.black]
+[tool.ruff]
+extend-exclude = ["thirdparty"]
+extend-include = ["SConstruct", "SCsub"]
line-length = 120
-extend-exclude = ".*thirdparty/.*"
+target-version = "py37"
+
+[tool.ruff.lint]
+extend-select = [
+ "I", # isort
+]
+
+[tool.ruff.lint.per-file-ignores]
+"{SConstruct,SCsub}" = [
+ "E402", # Module level import not at top of file
+ "F821", # Undefined name
+]