summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThaddeus Crews <repiteo@outlook.com>2024-05-14 11:04:46 -0500
committerThaddeus Crews <repiteo@outlook.com>2024-05-14 12:01:48 -0500
commitf4e58691c2e189a2fb9543737dda2cc874f3e1b4 (patch)
treed7d2b29c9b6657056620a812482e4bc00e2b18f8 /pyproject.toml
parent78cce1954ddb6fefb90b33742215f304ec7b0b94 (diff)
downloadredot-engine-f4e58691c2e189a2fb9543737dda2cc874f3e1b4.tar.gz
SCons: Consolidate pysettings via `pyproject.toml`
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000000..f1ea10fbae
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,16 @@
+[tool.mypy]
+ignore_missing_imports = true
+disallow_any_generics = true
+no_implicit_optional = true
+pretty = true
+show_column_numbers = true
+warn_redundant_casts = true
+warn_return_any = true
+warn_unreachable = true
+namespace_packages = true
+explicit_package_bases = true
+exclude = ["thirdparty/"]
+
+[tool.black]
+line-length = 120
+extend-exclude = ".*thirdparty/.*"