summaryrefslogtreecommitdiffstats
path: root/doc/classes/PackedVector2Array.xml
Commit message (Collapse)AuthorAgeFilesLines
* fix typo on PackedVector2Array docsKenton M2024-10-041-1/+1
|
* Bind Array get and set functionsAaron Franke2024-09-261-0/+7
|
* Add further details on properties returning `Packed*Array`A Thousand Ships2024-04-081-0/+1
|
* Merge pull request #90310 from mhilbrunner/OutdatedDemosRémi Verschelde2024-04-081-1/+1
|\ | | | | | | Update links to outdated asset library demos
| * Update links to outdated asset library demosskyace652024-04-071-1/+1
| | | | | | | | | | | | Update links to outdated asset library demos Co-authored-by: Max Hilbrunner <m.hilbrunner@gmail.com>
* | Merge pull request #78257 from Calinou/doc-packed-arrays-vs-typed-arraysRémi Verschelde2024-04-081-0/+1
|\ \ | |/ |/| | | Document the upsides and downsides of packed arrays versus typed arrays
| * Document the upsides and downsides of packed arrays versus typed arraysHugo Locurcio2023-11-151-0/+1
| |
* | Add performance note to Array.resize()MewPurPur2023-11-101-1/+1
|/
* Clarify docs for operators performing `xform_inv`kleonc2023-10-161-1/+3
|
* Doctool: Remove version attribute from XML headerRémi Verschelde2023-07-061-1/+1
| | | | | | We don't use that info for anything, and it generates unnecessary diffs every time we bump the minor version (and CI failures if we forget to sync some files from opt-in modules (mono, text_server_fb).
* Bump version to 4.2-devRémi Verschelde2023-07-051-1/+1
| | | | Keep on waitin'
* Document initializing PackedVectorArray/PackedColorArray correctlyHugo Locurcio2023-06-151-0/+4
|
* Add more info on the nature of NANNinni Pipping2023-05-301-0/+6
|
* Bump version to 4.1-devRémi Verschelde2023-03-011-1/+1
| | | | Can't stop, won't stop, they said, huh?
* Complete documentation of packed arrayskobewi2022-08-191-0/+6
|
* [doc] Use "param" instead of "code" to refer to parameters (4)Andy Maloney2022-08-111-5/+5
|
* Expose clear method for packed arraysHaoyu Qiu2022-08-101-0/+6
|
* Rename the argument tag to param in XML documentationYuri Sizov2022-08-081-27/+27
|
* Add search methods for packed arraysHaoyu Qiu2022-05-071-0/+23
| | | | | | * count() * find() * rfind()
* Remove Array link in description of PackedArraysHaoyu Qiu2022-04-231-2/+2
|
* Remove generating of null comparison operators from documentationYuri Roubinsky2022-03-141-10/+0
|
* Add an XML schema for documentationHugo Locurcio2022-02-151-1/+1
| | | | | | | | This makes it easier to spot syntax errors when editing the class reference. The schema is referenced locally so validation can still work offline. Each class XML's schema conformance is also checked on GitHub Actions.
* `Array`: Relax `slice` bound checks to properly handle negative indicesRémi Verschelde2022-01-101-1/+4
| | | | | | | | | | | | | | The same is done for `Vector` (and thus `Packed*Array`). `begin` and `end` can now take any value and will be clamped to `[-size(), size()]`. Negative values are a shorthand for indexing the array from the last element upward. `end` is given a default `INT_MAX` value (which will be clamped to `size()`) so that the `end` parameter can be omitted to go from `begin` to the max size of the array. This makes `slice` works similarly to numpy's and JavaScript's.
* Unify similar method descriptionsHaoyu Qiu2022-01-061-1/+1
| | | | | | | | | | Notably: * `Packed*Array.size()` and `Array.size()`. * Shared methods of `Transform2D` and `Transform3D`. * Shared methods of `Vector2`, `Vector3`, and `Vector2i`. This reduces the Deja Vu when translating the class reference :)
* PackedByteArray, Array slice end exclusive, rename subarray to sliceNathan Franke2021-11-261-7/+7
|
* Rename `remove()` to `remove_at()` when removing by indexLightning_A2021-11-231-1/+1
|
* Move the docs for constructors and operators out of methods sectionAaron Franke2021-10-291-47/+51
|
* Merge pull request #52850 from mashumafi/vector-bsearchRémi Verschelde2021-10-011-0/+9
|\
| * Implement bsearch for Vector and Packed*Arraymashumafi2021-09-301-0/+9
| |
* | Don't generate empty doc sections and reduce code duplicationAaron Franke2021-09-201-2/+0
|/
* Allow comparing equality between builtin types and nullGeorge Marques2021-09-171-0/+10
|
* Replace stb_vorbis with libogg+libvorbisEllen Poe2021-09-091-1/+1
|
* doc: Use self-closing tags for `return` and `argument`Rémi Verschelde2021-07-301-88/+44
| | | | | | | | For the time being we don't support writing a description for those, preferring having all details in the method's description. Using self-closing tags saves half the lines, and prevents contributors from thinking that they should write the argument or return documentation there.
* Add fill method to Arrays and PackedArraysMatheus Lima Cunha2021-04-211-0/+9
|
* Fix misformatted documentation from #47435, #42827, #46991Yuri Sizov2021-04-041-7/+7
|
* Rename Array.invert() to Array.reverse()Marcel Admiraal2021-03-211-1/+1
| | | | | Does the same internally for List and Vector<>, which includes all PackedArray types.
* doc: Sync classref with current sourceRémi Verschelde2021-03-181-4/+4
| | | | And move GLTF docs to its module folder.
* doc: Sync classref with current sourceRémi Verschelde2021-01-041-7/+7
|
* Rename empty() to is_empty()Marcel Admiraal2020-12-281-1/+1
|
* packed*arrays are pass by ref now. support duplicate and update documentationJordan Schidlowsky2020-12-171-1/+7
|
* doc: Sync classref to add operators after #43419Rémi Verschelde2020-11-101-3/+43
|
* Variant: Sync docs with new constructors, fixups after #43403Rémi Verschelde2020-11-091-0/+16
| | | | | Change DocData comparators for MethodDoc and ArgumentDoc to get a better ordering of constructors.
* doc: Sync classref with current source + fixup some bindingsRémi Verschelde2020-11-041-11/+27
| | | | Includes various changes triggered by the refactoring of method bindings.
* Link to demos from within the class referenceAaron Franke2020-10-011-0/+1
|
* Add sort and has methods to PackedArraysAaron Franke2020-07-061-0/+16
|
* doc: Sync classref with apparent Variant return type changesRémi Verschelde2020-02-221-0/+14
| | | | | Part of those seem bogus, methods like Array.back()/front() should return a Variant and not void.
* doc: Sync classref with current sourceRémi Verschelde2020-02-181-0/+99
Handle removal of Pool*Array types and other recent changes.