summaryrefslogtreecommitdiffstats
path: root/doc/classes/Resource.xml
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@cb411fa960f0b7fdbd97dcdb4c90f9346360ee0eSpartan3222024-11-121-1/+1
|\
| * Merge pull request #99020 from Mickeon/documentation-example-pruning-2Thaddeus Crews2024-11-121-1/+1
| |\ | | | | | | | | | Clean up more `[b]Example:[/b]` lines from the class reference
| | * Clean up more `[b]Example:[/b]` lines from the class referenceMicky2024-11-111-1/+1
| | |
* | | fix: replace "Godot" to "Redot"Muhannad Elbolaky2024-10-151-1/+1
|/ / | | | | | | Trying to change "Godot" to "Redot" in the doc while acknowledging the reference to previous Godot versions like Godot 3.X.
* / Expose several resource/resource-saver functionsChris Cranford2024-09-221-0/+49
|/
* Fix some legacy codekobewi2024-08-011-1/+1
|
* Clarify that Resource.duplicate(true) doesn't duplicate subresources inside ↵Adriaan de Jongh2024-07-141-2/+5
| | | | Array or Dictionary properties
* Expose scene unique id functionality in ResourceRyan2024-03-071-0/+12
|
* Overhaul some "uncommon" wording in class referenceMicky2024-03-011-1/+1
|
* Update many Deprecated/Experimental descriptions for consistencyMicky2024-02-171-1/+1
|
* Documentation: Add support for deprecated/experimental messagesDanil Alexeev2024-02-151-5/+3
|
* Clarify some descriptions regarding resource cachekobewi2023-12-101-1/+2
|
* Document that `resource_name` is not always supportedBoris The Brave2023-11-011-0/+1
| | | | | | Closes #82333. Co-authored-by: Yuri Sizov <11782833+YuriSizov@users.noreply.github.com>
* Reimplement Resource.`_local_to_scene_setup` & remove workaroundMicky2023-09-091-4/+20
| | | | | | Reimplements the virtual method _setup_local_to_scene, lost in #51970 Also deprecates the redundant `setup_local_to_scene_requested` signal.
* Unexpose Resource.`setup_local_to_scene`Micky2023-09-061-14/+2
| | | | | | Good riddance. Also modifies a note in ViewportTexture
* Clarify when the changed signal is emitted for Resource and ShaderMaterialJose Falanga2023-07-241-1/+1
|
* Doctool: Remove version attribute from XML headerRémi Verschelde2023-07-061-1/+1
| | | | | | We don't use that info for anything, and it generates unnecessary diffs every time we bump the minor version (and CI failures if we forget to sync some files from opt-in modules (mono, text_server_fb).
* Bump version to 4.2-devRémi Verschelde2023-07-051-1/+1
| | | | Keep on waitin'
* Merge pull request #76526 from MewPurPur/improve-docs-top-sections-COREYuri Sizov2023-05-291-1/+1
|\ | | | | Overhaul the top sections of the class reference (Core classes)
| * Overhaul the top sections of the class reference (Core classes)VolTer2023-05-191-1/+1
| |
* | Minor grammar fixes to documentationNinni Pipping2023-05-281-1/+1
|/
* Bump version to 4.1-devRémi Verschelde2023-03-011-1/+1
| | | | Can't stop, won't stop, they said, huh?
* Add PROPERTY_USAGE_NEVER_DUPLICATE flag and use for scriptAaron Franke2023-01-241-1/+2
| | | | Co-authored-by: Yakov Borevich <j.borevich@gmail.com>
* PropertyUsage: Rename "DO_NOT_SHARE_ON_DUPLICATE" to "ALWAYS_DUPLICATE"Aaron Franke2023-01-241-1/+1
|
* Style: Misc docs and comment style and language fixesRémi Verschelde2022-11-021-2/+2
| | | | | | | | | | - Removed empty paragraphs in XML. - Consistently use bold style for "Example:", on a new line. - Fix usage of `[code]` when hyperlinks could be used (`[member]`, `[constant]`). - Fix invalid usage of backticks for inline code in BBCode. - Fix some American/British English spelling inconsistencies. - Other minor fixes spotted along the way, including typo fixes with codespell. - Don't specify `@GlobalScope` for `enum` and `constant`.
* Rewrite most of Resource's documentationMicky2022-10-181-20/+38
|
* [doc] Use "param" instead of "code" to refer to parameters #3Andy Maloney2022-08-091-2/+2
|
* Rename the argument tag to param in XML documentationYuri Sizov2022-08-081-2/+2
|
* Discern between virtual and abstract class bindingsreduz2022-03-101-0/+5
| | | | | | | | | | | | | | * Previous "virtual" classes (which can't be instantiated) are not corretly named "abstract". * Added a new "virtual" category for classes, they can't be instantiated from the editor, but can be inherited from script and extensions. * Converted a large amount of classes from "abstract" to "virtual" where it makes sense. Most classes that make sense have been converted. Missing: * Physics servers * VideoStream * Script* classes. which will go in a separate PR due to the complexity involved.
* Add an XML schema for documentationHugo Locurcio2022-02-151-1/+1
| | | | | | | | This makes it easier to spot syntax errors when editing the class reference. The schema is referenced locally so validation can still work offline. Each class XML's schema conformance is also checked on GitHub Actions.
* Replace Godot docs URL with `$DOCS_URL` in XML class referenceRémi Verschelde2021-11-151-2/+2
|
* doc: Update links to latest documentation after content reorganizationRémi Verschelde2021-10-061-2/+2
|
* Don't generate empty doc sections and reduce code duplicationAaron Franke2021-09-201-2/+0
|
* Merge pull request #44885 from Jummit/duplicate-docsRémi Verschelde2021-09-161-1/+2
|\ | | | | Clarify that duplicate only copies exported members and fails with a constructor
| * clarify what duplicate does and its limitationsJummit2021-09-121-1/+2
| |
* | Replace BIND_VMETHOD by new GDVIRTUAL syntaxreduz2021-08-221-7/+5
| | | | | | | | | | | | | | | | | | | | | | * New syntax is type safe. * New syntax allows for type safe virtuals in native extensions. * New syntax permits extremely fast calling. Note: Everything was replaced where possible except for `_gui_input` `_input` and `_unhandled_input`. These will require API rework on a separate PR as they work different than the rest of the functions. Added a new method flag METHOD_FLAG_OBJECT_CORE, used internally. Allows to not dump the core virtuals like `_notification` to the json API, since each language will implement those as it is best fits.
* | doc: Use self-closing tags for `return` and `argument`Rémi Verschelde2021-07-301-18/+9
| | | | | | | | | | | | | | | | For the time being we don't support writing a description for those, preferring having all details in the method's description. Using self-closing tags saves half the lines, and prevents contributors from thinking that they should write the argument or return documentation there.
* | Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-1/+1
| |
* | Rename Reference to RefCountedPedro J. Estébanez2021-06-111-2/+2
| |
* | Document `Resource.duplicate()` only copying exported variables' valuesHugo Locurcio2021-05-311-0/+1
| |
* | Document a built-in use of `Resource.resource_name`Hugo Locurcio2021-01-231-1/+1
| |
* | Expose `Resource.emit_changed()` to scriptAndrii Doroshenko (Xrayez)2021-01-131-0/+13
| | | | | | | | Also known as `emit_signal("changed")`.
* | Remove the implication that references and resources are not objected from ↵skyace652021-01-111-1/+1
| | | | | | | | their description
* | Mention that 'changed' signal needs manual emitTomasz Chabora2020-12-031-0/+1
|/
* Document C# garbage collection caveats in Reference and ResourceHugo Locurcio2020-11-231-0/+1
|
* Improve the Object, Reference and Resource class documentationsHugo Locurcio2020-07-271-2/+3
|
* Update Resource.xml to explain behavior of duplicate when subresources is ↵Bob Gardner2020-07-081-1/+2
| | | | | true and a subresource contains further nested resources. Updated documentation for duplicate() on Resource to better explain the behavior. As per #30385.
* doc: Sync classref with current sourceRémi Verschelde2020-02-121-1/+1
| | | | | | | | Lots of internal API changes and some docstrings were lost in the conversion. I manually salvaged many of them but for all the rendering-related ones, an additional pass is needed. Added missing enum bindings in BaseMaterial3D and VisualServer.
* Update docs to version 4.0clayjohn2020-01-311-1/+1
|
* doc: Drop unused 'category' property from headerRémi Verschelde2020-01-261-1/+1
| | | | | | | | | | We already removed it from the online docs with #35132. Currently it can only be "Built-In Types" (Variant types) or "Core" (everything else), which is of limited use. We might also want to consider dropping it from `ClassDB` altogether in Godot 4.0.