summaryrefslogtreecommitdiffstats
path: root/editor/editor_feature_profile.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@f128f383e892865379cb8b14e7bcc9858efe2973Spartan3222024-11-271-0/+1
|\
| * Add theme type variations for secondary Trees and ItemListspassivestar2024-11-191-0/+1
| |
* | Merge commit godotengine/godot@0f5f3bc9546b46b2029fc8896dc859697f1eab97Spartan3222024-11-111-3/+3
|\|
| * [Editor] Fix order of editor featuresA Thousand Ships2024-11-091-3/+3
| | | | | | | | Order was broken after adding `Game View`
* | Merge commit godotengine/godot@c6c464cf9ae56e8b68620af65125dd980d0e8122Spartan3222024-11-021-0/+4
|\|
| * Add "Game" editor for better runtime debuggingMichael Alexsander2024-10-301-0/+4
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* StringName Dictionary keysrune-scape2024-08-291-6/+6
| | | | | also added 'is_string()' method to Variant and refactored many String type comparisons to use it instead
* [Scene] Add `SceneStringNames::confirmed`A Thousand Ships2024-06-191-2/+2
|
* [Scene] Add `SceneStringNames::item_selected`A Thousand Ships2024-06-191-1/+1
|
* Use `CoreStringNames::normal` in more placesA Thousand Ships2024-05-301-1/+1
|
* Editor Feature Profile: Only rebuild selected TreeItem and all children when ↵Marius Hanl2024-05-201-5/+15
| | | | a property is edited
* [Scene] Add SceneStringNames::pressedA Thousand Ships2024-05-141-6/+6
|
* Editor: Display deprecated/experimental messages in tooltipsDanil Alexeev2024-04-181-15/+8
|
* Add context support for editor property name i18nHaoyu Qiu2024-03-311-2/+2
|
* Fix unexpected auto translation of Tree contentHaoyu Qiu2024-03-181-0/+1
|
* Make auto translation inheritableMichael Alexsander2024-02-151-1/+1
|
* Split theme generation logic into several subroutinesYuri Sizov2024-01-161-1/+1
| | | | | | | | | | | | | | | | | | | | This change introduces a new theme configuration struct to be passed to the aforementioned routines to better control reuse of styles and definitions in the generator. Everything not passed and not explicitly shared is scoped so it is not automatically accessible throughout the routine. This should ensure that the decision to share styles is a conscious one. In the future we will try to reduce the number of unique definitions and share most of it. This PR is a stepping stone on this path. This also puts the effort into separating redefinitions of default theme items vs custom types introduced only by the editor. In a few cases where editor-specific definitions need to reference default definitions we simply fetch them from the theme. It's not ideal and hides the dependency a bit, but hopefully these cases will be abstracted properly in due time.
* Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
| | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Revamp how documentation tooltips workMichael Alexsander2023-10-031-12/+13
|
* Add EditorStringNames singletonkobewi2023-09-031-1/+2
|
* Use the gray color for all abstract classesMewPurPur2023-08-311-3/+3
|
* Allow changing feature profile via EditorInterfaceRedMser2023-07-241-16/+38
|
* Improve includes of EditorNode (and everything else)Yuri Sizov2023-04-071-1/+1
| | | | | | Also start organizing editor-specific GUI components into a dedicated folder, `editor/gui`. Also move `editor_file_server` next to the rest of debugger classes.
* Turn off auto translate for some editor controlsHaoyu Qiu2023-03-281-0/+1
| | | | | | | | | | | | * Scene tab * Animation name list in Animation panel * Feature profile name list in Editor Feature Profile dialog * Layout names in editor layout menu * Subresource list in Inspector dock * Resource type shown in EditorResourcePicker * Enum dropdowns in inspectors: We'll eventually allow auto translating these after implementing a way to opt-out auto translation on a property-by-property basis and a way to extract enumerators.
* Clean-up, harmonize, and improve StyleBox APIYuri Sizov2023-01-191-1/+1
| | | | | | - Make all margin properties follow the same naming convention (their getter and setter too). - Remove a virtual counterpart of `get_style_margin` from API. - Allow to override `get_minimum_size` from scripting and remove `get_center_size`.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Fix some stuff with the editor featuresMichael Alexsander2022-11-121-1/+7
|
* Allow to disable History Dock via feature profilekobewi2022-11-071-0/+4
|
* Fix various -Wmaybe-uninitialized warnings from GCC 12.2.1Rémi Verschelde2022-09-221-1/+1
| | | | | | Not sure why I didn't get those before, it may be due to upstream changes (12.2.1 is a moving target, it's basically 12.3-dev), or simply rebuilding Godot from scratch with different options.
* Merge pull request #65039 from Mickeon/rename-treeitem-tooltipRémi Verschelde2022-08-301-1/+1
|\
| * Rename TreeItem's `set_tooltip` to `set_tooltip_text`Micky2022-08-301-1/+1
| | | | | | | | | | | | | | | | | | `set_tooltip` -> `set_tooltip_text` `get_tooltip` -> `get_tooltip_text` For consistency: `get_button_tooltip` -> `get_button_tooltip_text` And the `tooltip` parameter in `add_button` was renamed to `tooltip_text`
* | Rename String `plus_file` to `path_join`Aaron Franke2022-08-291-8/+8
|/
* Rebuild the trees in the EditorFeatureProfile dialog when the editor theme ↵Yuri Sizov2022-08-051-0/+5
| | | | changes
* Merge pull request #63603 from aaronfranke/editor-pathsRémi Verschelde2022-07-291-12/+13
|\ | | | | Move editor paths into the EditorPaths class
| * Move editor paths into the EditorPaths classAaron Franke2022-07-291-12/+13
| |
* | Remove Signal connect bindsJuan Linietsky2022-07-291-8/+8
|/ | | | | Remove the optional argument p_binds from `Object::connect` since it was deprecated by Callable.bind(). Changed all uses of it to Callable.bind()
* Merge pull request #62827 from fire-forge/ok-cancelRémi Verschelde2022-07-131-1/+1
|\ | | | | Add `ok_button_text` to AcceptDialog and `cancel_button_text` to ConfirmationDialog
| * Add ok_button_text to AcceptDialog and cancel_button_text to ConfirmationDialogFireForge2022-07-091-1/+1
| |
* | Seperate filter and description in FileDialog.add_filter()FireForge2022-07-091-2/+2
|/
* Add a new HashSet templatereduz2022-05-201-2/+2
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Use range iterators for RBSet in most casesAaron Record2022-05-191-6/+6
|
* Replace most uses of Map by HashMapreduz2022-05-161-7/+7
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Make FileAccess and DirAccess classes reference counted.bruvzg2022-04-111-7/+6
|
* Add property name style toggle to InspectorHaoyu Qiu2022-03-281-2/+8
|
* Initialize bools in the headers in editorAaron Franke2022-03-121-2/+0
|
* i18n: Make property paths and categories translatableHaoyu Qiu2022-03-031-1/+3
|
* Port existing _notification code to use switch statements (part 1/3)jmb4622022-02-161-11/+13
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-2/+3
|