summaryrefslogtreecommitdiffstats
path: root/editor/editor_layouts_dialog.cpp
Commit message (Expand)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
* Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
* [Scene] Add `SceneStringNames::text/value_changed`A Thousand Ships2024-06-191-1/+1
* Use Core/Scene stringnames consistentlykobewi2024-05-131-2/+2
* Strip edges of editor layout namesHaoyu Qiu2024-03-311-5/+3
* Fix PopupMenu doesn't respect it's ScrollContainer's marginsMounir Tohami2024-02-231-0/+1
* Make auto translation inheritableMichael Alexsander2024-02-151-1/+1
* Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
* Implement automatic translation for ItemListDennisManaa2023-10-231-0/+1
* Use ui_text_submit to confirm and close text promptsjsjtxietian2023-09-011-1/+1
* Use defined key mapping for closing popups and dialogsArman Elgudzhyan2023-05-201-18/+8
* Fix layout list not resizing in editor layout dialogHaoyu Qiu2023-04-231-5/+2
* More i18n improvementsHaoyu Qiu2023-03-271-1/+1
* Improve editor layout dialogMarius Hanl2023-02-021-6/+21
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
* Do not add child twice and set initial focusMarius Hanl2022-12-211-1/+5
* Improve Editor Layout dialog (clarity, editor sizing changes)souplamp2022-11-211-0/+6
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
* Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-1/+1
* Use "enum class" for input enumsAaron Franke2021-11-121-3/+3
* Use Key enum instead of plain integersAaron Franke2021-08-101-0/+2
* Use const references where possible for List range iteratorsRémi Verschelde2021-07-251-1/+1
* Use C++ iterators for Lists in many situationsAaron Franke2021-07-231-2/+2
* Optimize StringName usagereduz2021-07-181-2/+2
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-1/+1
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
* Merge pull request #44569 from madmiraal/rename-unselect-deselectRémi Verschelde2020-12-281-1/+1
|\
| * Rename unselect to deselectMarcel Admiraal2020-12-211-1/+1
* | Rename Control margin to offsetMarcel Admiraal2020-12-231-8/+8
|/
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-1/+1
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-2/+4
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-13/+0
* Working multiple window support, including editorJuan Linietsky2020-03-261-8/+8
* Merge pull request #18020 from bruvzg/input_fix_non_latin_and_add_hw_scancodesRémi Verschelde2020-03-011-1/+1
|\
| * Rename `scancode` to `keycode`.bruvzg2020-02-251-1/+1
* | Signals: Manually port most of remaining connect_compat usesRémi Verschelde2020-02-281-1/+2
* | Signals: Port connect calls to use callable_mpRémi Verschelde2020-02-281-2/+1
|/
* Reworked signal connection system, added support for Callable and Signal obje...Juan Linietsky2020-02-201-2/+2
* Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
* Fix scoped enum value reference, breaks GCC 5Rémi Verschelde2019-06-241-1/+1
* editor save/delete layout dialog with layout listhilfazer2019-06-211-0/+138