summaryrefslogtreecommitdiffstats
path: root/editor/plugins/control_editor_plugin.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@8004c7524fb9f43425c4d6f614410a76678e0f7cSpartan3222024-10-301-29/+29
|\
| * Merge pull request #98039 from aaronfranke/button-iconThaddeus Crews2024-10-291-27/+27
| |\ | | | | | | | | | Rename internal Button `*_icon` functions to `*_button_icon` to match exposed methods
| | * Rename internal Button icon to button_icon to match exposed methodsAaron Franke2024-10-291-27/+27
| | |
| * | Set clang-format `RemoveSemicolon` rule to `true`Adam Scott2024-10-251-2/+2
| |/ | | | | | | - Set clang-format `Standard` rule to `c++20`
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Merge commit godotengine/godot@1015a481ff43edb1126ab39a147fefda290131e5Spartan3222024-10-241-1/+0
|\|
| * Merge pull request #96518 from Giganzo/popup-panel-styleThaddeus Crews2024-10-241-1/+0
| |\ | | | | | | | | | Fix PopupPanel and PopupMenu menu styles
| | * Fix PopupPanel menu styleGiganzo2024-10-201-1/+0
| | |
* | | Merge commit godotengine/godot@af77100e394dcaca609b15bef815ed17475e51edSpartan3222024-10-151-1/+3
|\| |
| * | Fix ControlEditorPopupButton arrow position in RTL languageHaoyu Qiu2024-10-091-1/+3
| |/
* / Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Scene] Add SceneStringName::toggledYuri Rubinsky2024-08-281-1/+1
|
* [Scene] Add `SceneStringNames::item_selected`A Thousand Ships2024-06-191-2/+2
|
* Fix some incorrect uses of `String` over `StringName`A Thousand Ships2024-06-031-3/+3
| | | | These were accepting `SNAME` assignments
* [Scene] Add `SceneStringNames::panel`A Thousand Ships2024-05-301-1/+1
|
* [Scene] Add SceneStringNames::pressedA Thousand Ships2024-05-141-5/+5
|
* Toggle control expand flag directly via top barRedMser2024-05-101-3/+77
|
* Only add warning label for Layout group in Control categoryHaoyu Qiu2024-04-271-0/+8
|
* Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
| | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Add const references detected by clang-tidyWilson E. Alvarez2023-12-161-1/+1
|
* Replace flat buttons with flat-styled buttons with a visible pressed stateYuri Sizov2023-09-191-2/+2
|
* [Editor] Replace `ERR_FAIL_COND` with `ERR_FAIL_NULL` where applicableA Thousand Ships2023-09-151-1/+1
|
* Merge pull request #81516 from YuriSizov/editor-theme-access-the-successYuri Sizov2023-09-151-1/+2
|\ | | | | | | Fix accessing editor theme items throughout the UI
| * Fix accessing editor theme items throughout the UIYuri Sizov2023-09-151-1/+2
| | | | | | | | This also exposes `EditorInterface::get_editor_theme`.
* | Improve the looks of 2D/3D viewport contextual toolbarsYuri Sizov2023-09-131-2/+0
|/
* Add EditorStringNames singletonkobewi2023-09-031-35/+35
|
* Add get_edited_property_value() shorthand methodkobewi2023-05-261-3/+3
|
* Use `PropertyUsageFlags` enum in parse_propertyRaul Santos2023-01-311-1/+1
|
* Add EditorUndoRedoManager singletonkobewi2023-01-161-3/+3
|
* Ensure that the cached layout mode is in syncYuri Sizov2023-01-101-0/+1
|
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Cleanup remaining EditorUndoRedoManager usageskobewi2022-11-241-1/+3
|
* Remove redundant Variant-types initializationsMarkus Sauermann2022-11-141-1/+1
|
* Use forward-declarations in EditorPlugin where possibletrollodel2022-11-111-0/+1
|
* Code simplificationsMarkus Sauermann2022-11-071-13/+0
| | | | | | | | | | | | | | | | | CanvasItemEditor: - p_result == ADD_MOVE is always true in this switch-clause - both parts of the if-else-clause do the same thing and simplified an affine_inverse call ControlEditorToolbar: - private function ControlEditorToolbar::_anchor_to_position is used nowhere. Looks like copy and paste from CanvasItemEditor::_anchor_to_position ScrollContainer: - screen_is_touchscreen is always true, because otherwise the function already returned TextLine: - both parts of the if-else-clause do the same thing and simplified return statement
* Fix some editor theme regressionsYuri Sizov2022-08-291-1/+1
|
* Revert "Remove NOTIFICATION_ENTER_TREE when paired with ↵Rémi Verschelde2022-08-291-0/+5
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | NOTIFICATION_THEME_CHANGED" This reverts commit 4b817a565cab8af648c88cfc7ab6481e86ee3625. Fixes #64988. Fixes #64997. This caused several regressions (#64988, #64997, https://github.com/godotengine/godot/issues/64997#issuecomment-1229970605) which point at a flaw in the current logic: - `Control::NOTIFICATION_ENTER_TREE` triggers a *deferred* notification with `NOTIFCATION_THEME_CHANGED` as introduced in #62845. - Some classes use their `THEME_CHANGED` to cache theme items in member variables (e.g. `style_normal`, etc.), and use those member variables in `ENTER_TREE`, `READY`, `DRAW`, etc. Since the `THEME_CHANGE` notification is now deferred, they end up accessing invalid state and this can lead to not applying theme properly (e.g. for EditorHelp) or crashing (e.g. for EditorLog or CodeEdit). So we need to go back to the drawing board and see if `THEME_CHANGED` can be called earlier so that the previous logic still works? Or can we refactor all engine code to make sure that: - `ENTER_TREE` and similar do not depend on theme properties cached in member variables. - Or `THEME_CHANGE` does trigger a general UI update to make sure that any bad theme handling in `ENTER_TREE` and co. gets fixed when `THEME_CHANGE` does arrive for the first time. But that means having a temporary invalid (and possibly still crashing) state, and doing some computations twice which might be heavy (e.g. `EditorHelp::_update_doc()`).
* Merge pull request #64885 from Mickeon/rename-tooltip-hintRémi Verschelde2022-08-281-10/+10
|\ | | | | Rename `hint_tooltip` to `tooltip_text` & setter getter
| * Rename `hint_tooltip` to `tooltip_text` & setgetMicky2022-08-271-10/+10
| | | | | | | | | | | | | | | | `hint_tooltip` -> `tooltip_text` `set_tooltip` -> `set_tooltip_text` `_get_tooltip` -> `get_tooltip_text` Updates documentation, too.
* | Remove NOTIFICATION_ENTER_TREE when paired with NOTIFICATION_THEME_CHANGEDAaron Record2022-08-271-5/+0
|/
* Add per-scene UndoRedokobewi2022-08-221-0/+1
|
* Improve editor toolbar for Control nodesYuri Sizov2022-08-161-399/+449
|
* Extract EditorResourceConversionPlugin into its own source files and clean ↵Yuri Sizov2022-07-311-0/+2
| | | | up editor includes
* simplify alignment preset, fixing icon for full rectNathan Franke2022-07-201-14/+8
|
* Rename Control PRESET_WIDE to PRESET_FULL_RECTFireForge2022-07-181-7/+7
|
* Move duplicate AutoWrap, Overrun and VisibleChar behavior enums to the ↵bruvzg2022-06-161-2/+2
| | | | TextServer.
* Replace most uses of Map by HashMapreduz2022-05-161-1/+1
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Cleanup metadata usagekobewi2022-05-061-3/+3
|
* Reduce the size of Controls editor toolbarkobewi2022-03-201-37/+16
|
* Fix vertical icons in container sizingMarkus Sauermann2022-02-191-2/+6
|