summaryrefslogtreecommitdiffstats
path: root/editor/plugins/path_3d_editor_plugin.cpp
Commit message (Collapse)AuthorAgeFilesLines
...
| * Rename `hint_tooltip` to `tooltip_text` & setgetMicky2022-08-271-4/+4
| | | | | | | | | | | | | | | | `hint_tooltip` -> `tooltip_text` `set_tooltip` -> `set_tooltip_text` `_get_tooltip` -> `get_tooltip_text` Updates documentation, too.
* | Remove NOTIFICATION_ENTER_TREE when paired with NOTIFICATION_THEME_CHANGEDAaron Record2022-08-271-2/+0
|/
* Add per-scene UndoRedokobewi2022-08-221-6/+7
|
* Extract EditorResourceConversionPlugin into its own source files and clean ↵Yuri Sizov2022-07-311-0/+1
| | | | up editor includes
* Remove Signal connect bindsJuan Linietsky2022-07-291-3/+3
| | | | | Remove the optional argument p_binds from `Object::connect` since it was deprecated by Callable.bind(). Changed all uses of it to Callable.bind()
* fix end handles being reversed in Path3DGizmoHayden Leete2022-06-041-20/+25
|
* swap path_3d_editor_plugin control points orderHayden Leete2022-06-021-10/+10
|
* Rename Basis get_axis to get_column, remove redundant methodsAaron Franke2022-05-031-3/+3
|
* Fix more issues found by cppcheck.bruvzg2022-04-201-2/+2
|
* Remove most EditorNode constructor parameters and fieldstrollodel2022-02-141-7/+6
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-0/+1
|
* Fix theme application in various curve editorsYuri Sizov2022-01-291-9/+26
|
* Fix secondary handles in editor gizmosjfons2022-01-121-12/+12
| | | | | | Primary and secondary handles are no longer differentiated by their ids, so a bool was added to tell them apart in all the handle-related methods. Includes a minor fix in CollisionPolygon3DEditor, unrelated to editor gizmos.
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Use "enum class" for input enumsAaron Franke2021-11-121-3/+3
|
* clang-format: Various fixes to comments alignment from `clang-format` 13Rémi Verschelde2021-10-281-9/+0
| | | | All reviewed manually and occasionally rewritten to avoid bad auto formatting.
* Swap args of Plane(point, normal) constructormennomax2021-10-151-6/+6
| | | | Now (normal, point)
* Implemented SkeletonEditorGizmoSilc Renew2021-10-071-11/+11
| | | | Co-authored-by: Lyuma <xn.lyuma@gmail.com>
* add missing undo on CloseCurve path3dStéphane Fortin2021-09-141-1/+8
|
* Removes const from set functions on the GizmosAndreaCatania2021-08-071-2/+2
|
* Node3D gizmo improvementsjfons2021-07-231-28/+28
| | | | | | | | * Clean-up of node_3d_editor_plugin.{h,cpp}: removed unused code, fixed some bugs. * Moved node_3d_editor_gizmos.{h,cpp} to editor/plugins. * Added support for multiple gizmos per node. This means custom gizmos will no longer override the built-in ones and that multiple gizmos can be used in more complex nodes. * Added support for handle IDs. When adding handles to a gizmo, an ID can be specified for each one, making it easier to work with gizmos that have a variable number of handles. * Added support for subgizmos, selectable elements that can be transformed without needing a node of their own. By overriding _subgizmo_intersect_frustum() and/or _subgizmo_intersect_ray() gizmos can define which subgizmos should be selected on a region or click selection. Subgizmo transformations are applied using get/set/commit virtual methods, similar to how handles work.
* Optimize StringName usagereduz2021-07-181-9/+9
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-1/+1
|
* Rename Transform to Transform3D in coreAaron Franke2021-06-031-4/+4
|
* Rename "Control" key to "Ctrl" and add "_pressed" suffix to all ↵Lightning_A2021-05-071-1/+1
| | | | InputEventWithModifiers properties/methods
* Rename ButtonList enum and members to MouseButtonAaron Franke2021-03-231-2/+2
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Editor: Fix invalid use of Node::get_viewport() after rename of ↵Rémi Verschelde2020-12-281-1/+1
| | | | | | | | | | | EditorNode::get_viewport() Fixes #44761, was a regression from #44524. The PR passed CI because EditorNode::get_viewport() used to shadow Node::get_viewport() (which was a bug in itself, fixed by #44524), so once it was renamed the existing code relying on it fell back to the now available Node::get_viewport(). This might bite some thirdparty modules too.
* Merge pull request #43742 from qarmin/editor_modules_default_valuesRémi Verschelde2020-12-081-0/+2
|\ | | | | Initialize class/struct variables with default values in platform/ and editor/
| * Initialize class/struct variables with default values in platform/ and editor/Rafał Mikrut2020-12-021-0/+2
| |
* | Rename EditorNode3DGizmoPlugin "get_name" to "get_gizmo_name"Aaron Franke2020-12-041-1/+1
|/
* Proposal 1246: Make Path3D handles more visible.Ryan Roden-Corrent2020-11-121-2/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Resolves godotengine/godot-proposals#1246. It is difficult to tell the difference between the handles for adjusting curves and the points themselves when looking at a Path gizmo. This re-uses the icons used for Path2D. Unlike Path2D, this does not use a different icon for smooth vs sharp points, as using a potentially different material for each point would prevent batching the points in add_handles (and adding them out-of-order messes up other logic based on handle indices). This includes a public API change to allow specifying a texture for a handle material. This allows spatial gizmo plugins to customize the way a handle is rendered, if desired, but does not break existing behavior (as providing no texture uses the default). The path handle icons were resized as well. 16x16 is the standard icon size. These icons were 10x10 rather than 16x16, and appeared rather small in the editor. To resize, I: - Opened the original in Inkscape - Resized the document to 16x16 - Opened the transform dialog - Scaled by 160% proportionally - Used Align/Distribute to center on the page - Saved the document - Cleaned with `svgcleaner --multipass`
* Remove ToolButton in favor of ButtonHugo Locurcio2020-06-191-4/+8
| | | | | | | | | | | ToolButton has no redeeming differences with Button; it's just a Button with the Flat property enabled by default. Removing it avoids some confusion when creating GUIs. Existing ToolButtons will be converted to Buttons, but the Flat property won't be enabled automatically. This closes https://github.com/godotengine/godot-proposals/issues/1081.
* Split `Geometry` singleton into `Geometry2D` and `Geometry3D`Andrii Doroshenko (Xrayez)2020-05-271-2/+4
| | | | Extra `_2d` suffixes are removed from 2D methods accoringly.
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-25/+46
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: Enforce separation line between function definitionsRémi Verschelde2020-05-141-0/+2
| | | | | | | | | | | | | | | | | | | | | | | I couldn't find a tool that enforces it, so I went the manual route: ``` find -name "thirdparty" -prune \ -o -name "*.cpp" -o -name "*.h" -o -name "*.m" -o -name "*.mm" \ -o -name "*.glsl" > files perl -0777 -pi -e 's/\n}\n([^#])/\n}\n\n\1/g' $(cat files) misc/scripts/fix_style.sh -c ``` This adds a newline after all `}` on the first column, unless they are followed by `#` (typically `#endif`). This leads to having lots of places with two lines between function/class definitions, but clang-format then fixes it as we enforce max one line of separation. This doesn't fix potential occurrences of function definitions which are indented (e.g. for a helper class defined in a .cpp), but it's better than nothing. Also can't be made to run easily on CI/hooks so we'll have to be careful with new code. Part of #33027.
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-38/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Style: clang-format: Disable AllowShortIfStatementsOnASingleLineRémi Verschelde2020-05-101-1/+2
| | | | | | | Part of #33027, also discussed in #29848. Enforcing the use of brackets even on single line statements would be preferred, but `clang-format` doesn't have this functionality yet.
* Rename all gizmo classes, using the 4.0 node names.jfons2020-04-071-13/+13
|
* Replace NULL with nullptrlupoDharkael2020-04-021-4/+4
|
* doc: Update classref with node renamesRémi Verschelde2020-03-301-1/+1
| | | | A few extra renames for classes which were missed in last week's PRs.
* Rename more 2D and 3D nodes to follow conventionRémi Verschelde2020-03-271-0/+653
Rename editor plugins to match the new node names.