summaryrefslogtreecommitdiffstats
path: root/editor/project_export.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Move project export and export template manager into export folderAaron Franke2022-07-261-1298/+0
|
* Merge pull request #62827 from fire-forge/ok-cancelRémi Verschelde2022-07-131-3/+3
|\ | | | | Add `ok_button_text` to AcceptDialog and `cancel_button_text` to ConfirmationDialog
| * Add ok_button_text to AcceptDialog and cancel_button_text to ConfirmationDialogFireForge2022-07-091-3/+3
| |
* | Seperate filter and description in FileDialog.add_filter()FireForge2022-07-091-3/+3
|/
* Export: Fix comma handling in feature list RTLRémi Verschelde2022-07-071-3/+4
| | | | Fixes #62815.
* Add tooltips to Export dialog icon buttonsHaoyu Qiu2022-06-101-0/+2
|
* Add readable export errors.bruvzg2022-06-081-23/+23
|
* Use "odd" style for TabContainers on base BG colorFireForge2022-05-261-0/+1
| | | | - Use the "odd" style for TabContainers that are on a background with the same color as the default TabContainer background color to add contrast
* Add a new HashSet templatereduz2022-05-201-3/+6
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Replace most uses of Map by HashMapreduz2022-05-161-2/+2
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Add property name style toggle to InspectorHaoyu Qiu2022-03-281-0/+5
|
* Make `TabBar/Container` default their alignments to the left instead of centerMichael Alexsander2022-03-171-1/+0
|
* Initialize bools in the headers in editorAaron Franke2022-03-121-5/+0
|
* Remove more occurrences of "stex"TechnoPorg2022-03-101-1/+1
|
* Make name of editor file dialog filters translatableHaoyu Qiu2022-03-051-1/+2
|
* Make `TabContainer` use `TabBar` internallyMichael Alexsander2022-03-031-1/+1
|
* Convert _notification methods to switch - Chunk CJakob Bouchard2022-02-161-0/+1
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-4/+4
|
* Merge pull request #57796 from akien-mga/revert-sname-theme-settersRémi Verschelde2022-02-081-4/+4
|\
| * Revert "Add missing SNAME macro optimization to all theme methods call"Rémi Verschelde2022-02-081-4/+4
| | | | | | | | | | | | | | | | This reverts commit a988fad9a092053434545c32afae91ccbdfbe792. As discussed in #57725 and clarified in #57788, `SNAME` is not meant to be used everywhere but only in critical code paths. For theme methods specifically, it was by design that only getters use `SNAME` and not setters.
* | Refactor some object type checking code with `cast_to`Rémi Verschelde2022-02-081-2/+0
|/ | | | Less stringly typed logic, and less String allocations and comparisons.
* Add missing SNAME macro optimization to all theme methods calljmb4622022-02-061-4/+4
|
* Merge pull request #53276 from Phischermen/propagate_checkRémi Verschelde2022-01-201-46/+13
|\
| * Addded methods to propagate checks & refactored classes to use new methods.Kevin Fischer2022-01-181-46/+13
| |
* | [macOS export] Improve code signing/notarization options validation.bruvzg2022-01-101-1/+21
|/
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-7/+7
| | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* align to horizontal_alignment, valign to vertical_alignment, relatedNathan Franke2021-12-091-1/+1
|
* Improved some editor checkboxeskobewi2021-11-211-0/+2
|
* Allow dehardcoding documentation branch and URL in docs linksRémi Verschelde2021-11-151-1/+2
| | | | | | | | | | | | | | This makes it possible to change the branch of the documentation that URLs are pointing to without having to modify all class reference files. In the XML class reference, the `$DOCS_URL` placeholder should be used, and will be replaced automatically in the editor and when generating the RST class reference. The documentation branch string is set in `version.py`. Co-authored-by: Hugo Locurcio <hugo.locurcio@hugo.pro>
* Add TextFile support across the editorPaulb232021-09-301-0/+3
|
* Use bullet points in the editor instead of dashes where relevantHugo Locurcio2021-07-281-2/+2
|
* Use const references where possible for List range iteratorsRémi Verschelde2021-07-251-1/+1
|
* Use C++ iterators for Lists in many situationsAaron Franke2021-07-231-4/+4
|
* Make various strings translatablefoxydevloper2021-07-191-3/+3
|
* Optimize StringName usagereduz2021-07-181-8/+8
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Add header theme type variations to labelskobewi2021-07-131-1/+4
|
* Improve the Export All button display in the export dialogHugo Locurcio2021-07-101-9/+15
| | | | | | | | | | - Update the disabled status when changing an export path. - Display a tooltip that states why the button is disabled. - Update the Export All dialog message to have a more friendly tone. - Suffix button texts with "...", as they display another dialog when clicked. This closes #33293.
* Tweak script export text in the export dialog to be more explicitHugo Locurcio2021-06-241-6/+6
|
* Documentation search fixesGregory Basile2021-06-161-5/+5
| | | | | | Updates rich_text_label so that the built-in documentation can be searched Previously, it would only find the first result and would not select other results Renames "_entered" functions to "_submitted"
* Consistently prefix bound virtual methods with _kobewi2021-06-121-3/+3
|
* Core: Move DirAccess and FileAccess to `core/io`Rémi Verschelde2021-06-111-2/+2
| | | | | File handling APIs are typically considered part of I/O, and we did have most `FileAccess` implementations in `core/io` already.
* Improve TreeItem API and allow to move nodestrollodel2021-05-171-2/+2
|
* Merge pull request #43550 from KoBeWi/resourcismRémi Verschelde2021-04-011-0/+1
|\ | | | | Add option to exclude selected resources on export
| * Add option to exclude selected resources on exportTomasz Chabora2021-03-231-0/+1
| |
* | Rename PHashTranslation to OptimizedTranslationMarcel Admiraal2021-03-201-1/+1
| |
* | Ensures that export path is used when exporting PCK/ZIPMaganty Rushyendra2021-01-231-0/+6
| |
* | Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* | Merge pull request #44569 from madmiraal/rename-unselect-deselectRémi Verschelde2020-12-281-1/+1
|\ \ | | | | | | Rename unselect to deselect
| * | Rename unselect to deselectMarcel Admiraal2020-12-211-1/+1
| | |