summaryrefslogtreecommitdiffstats
path: root/editor/property_selector.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
|
* Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
| | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Merge pull request #96400 from ↵Rémi Verschelde2024-09-161-31/+22
|\ | | | | | | | | | | Maran23/inputmap-usage-for-filter-and-corresponding-refactor Use InputMap actions consistently across all LineEdit's that filter an underlying Tree or ItemList.
| * Use InputMap actions consistently across all LineEdit's that filter an ↵Marius Hanl2024-08-311-31/+22
| | | | | | | | | | | | | | | | | | underlying Tree or ItemList. - Instead of checking for Key::UP, Key::DOWN, Key::PAGEUP, Key::PAGEDOWN etc., we rather check for the action like 'ui_up' or 'ui_down'. - Also use AcceptDialog's 'register_text_enter' functionality to consistently close a dialog when ENTER is pressed while the LineEdit has focus (instead of redirecting ENTER keys to e.g. the underlying Tree). - Unify the LineEdit filter behavior for the SceneTreeDialog and corresponding usages - Improve OK Button disablement (something should be selected)
* | Pass current value to `EditorInterface` node/property popupsChris Cranford2024-09-031-0/+17
|/
* Merge pull request #95554 from KoBeWi/subproperty_of_a_subproperty_of_a_propertyRémi Verschelde2024-08-161-2/+131
|\ | | | | | | Allow picking partial properties in PropertySelector
| * Allow picking partial properties in PropertySelectorkobewi2024-08-151-2/+131
| |
* | Remove type icon array from PropertySelectorkobewi2024-08-151-45/+1
|/
* [Scene] Add `SceneStringNames::text/value_changed`A Thousand Ships2024-06-191-1/+1
|
* [Scene] Add `SceneStringNames::confirmed`A Thousand Ships2024-06-191-2/+2
|
* Editor: Hide GDScript internal functions from method selectorsDanil Alexeev2024-06-051-2/+15
|
* Use Core/Scene stringnames consistentlykobewi2024-05-131-1/+1
|
* [Core] Add case-insensitive `String::containsn`A Thousand Ships2024-05-081-4/+4
|
* Reduce and prevent unnecessary random-access to `List`A Thousand Ships2024-05-041-8/+8
| | | | | | | | | Random-access access to `List` when iterating is `O(n^2)` (`O(n)` when accessing a single element) * Removed subscript operator, in favor of a more explicit `get` * Added conversion from `Iterator` to `ConstIterator` * Remade existing operations into other solutions when applicable
* Add PackedVector4Array Variant typeK. S. Ernest (iFire) Lee2024-05-031-1/+2
| | | | | Co-authored-by: A Thousand Ships <96648715+AThousandShips@users.noreply.github.com> Co-authored-by: Rémi Verschelde <rverschelde@gmail.com>
* Editor: Display deprecated/experimental messages in tooltipsDanil Alexeev2024-04-181-19/+14
|
* Fix unexpected auto translation of Tree contentHaoyu Qiu2024-03-181-0/+1
|
* Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
| | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Clamps the height of description text for property selectorsQuirkyLemon2023-10-231-0/+2
|
* Revamp how documentation tooltips workMichael Alexsander2023-10-031-37/+6
|
* Add EditorStringNames singletonkobewi2023-09-031-40/+40
|
* Delay initialization of the visual shader editor UIYuri Sizov2023-05-231-1/+1
| | | | | | | | This makes sure that the theme is ready to be used before the methods is called. Also add missing icons (and update some existing). Co-authored-by: Samuel Wilson <yokomeshi@gmail.com>
* Add Vector4i iconSummersay4152023-05-131-1/+1
|
* Fix type icons in `PropertySelector`Ninni Pipping2023-03-061-1/+5
| | | | And adding a check to prevent future issues.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Remove excessive `editor/property_editor.h` includesYuri Sizov2022-08-011-0/+4
|
* Add ok_button_text to AcceptDialog and cancel_button_text to ConfirmationDialogFireForge2022-07-091-1/+1
|
* Replace most uses of Map by HashMapreduz2022-05-161-8/+8
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Initialize bools in the headers in editorAaron Franke2022-03-121-1/+0
|
* Convert _notification methods to switch - Chunk CJakob Bouchard2022-02-161-4/+8
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-1/+1
|
* Reload built-in scripts when picking methodskobewi2022-02-081-3/+6
|
* String: Add contains().Anilforextra2022-02-041-2/+2
|
* Vectors: Use clear() and has().Anilforextra2022-02-021-1/+1
| | | | | | Use clear() instead of resize(0). Use has() instead of "find(p_val) != -1".
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-10/+10
| | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* Use "enum class" for input enumsAaron Franke2021-11-121-4/+4
|
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-1/+1
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Use Key enum instead of plain integersAaron Franke2021-08-101-0/+2
|
* Make property description in the animation editor actually show itMichael Alexsander2021-08-081-17/+30
|
* Use const references where possible for List range iteratorsRémi Verschelde2021-07-251-1/+1
|
* Use C++ iterators for Lists in many situationsAaron Franke2021-07-231-25/+23
|
* Fix visual script iconsNick Huelin2021-07-201-0/+3
| | | | This pull request fixes an issue where the visual script icons weren't representative of their data.
* Optimize StringName usagereduz2021-07-181-35/+35
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Adding some more missing renames for Transform3D and QuaternionBastiaan Olij2021-06-151-1/+1
|
* update property selector's icon list and rename Quat.svg to Quaternion.svgSilc 'Tokage' Renew2021-06-091-3/+8
|
* Improve TreeItem API and allow to move nodestrollodel2021-05-171-6/+6
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Rename AcceptDialog get_ok() to get_ok_button()Marcel Admiraal2020-12-141-3/+3
| | | | | | Also renames: - AcceptDialog add_cancel() to add_cancel_button() - ConfirmationDiaglog get_cancel() to get_cancel_button()
* Refactor DocData into core and editor (DocTools) partsThakee Nathees2020-12-021-1/+2
|