summaryrefslogtreecommitdiffstats
path: root/modules/gdscript/gdscript_functions.h
Commit message (Collapse)AuthorAgeFilesLines
* GDScript: Refactor builtin functionsGeorge Marques2020-11-261-137/+0
| | | | | | | | | | | They are now called "utility functions" to avoid confusion with methods of builtin types, and be consistent with the naming in Variant. Core utility functions are now available in GDScript. The ones missing in core are added specifically to GDScript as helpers for convenience. Some functions were remove when there are better ways to do, reducing redundancy and cleaning up the global scope.
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-2/+1
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* Exposed randi_range to global funcs + renamed rand_range to randf_rangeYuri Roubinsky2020-11-061-2/+3
|
* Reworked signal connection system, added support for Callable and Signal ↵Juan Linietsky2020-02-201-1/+1
| | | | objects and made them default.
* Remove deprecated decimals builtinRémi Verschelde2020-02-121-1/+0
| | | | Replaced by 'step_decimals' in 3.2 via #21425.
* Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
| | | | | | | | | | | Happy new year to the wonderful Godot community! We're starting a new decade with a well-established, non-profit, free and open source game engine, and tons of further improvements in the pipeline from hundreds of contributors. Godot will keep getting better, and we're looking forward to all the games that the community will keep developing and releasing with it.
* Add ord() function to return Unicode code point of a string of length oneMasoud Montazeri2019-08-281-0/+1
|
* Added lerp_angles built-in functionChaosus2019-07-201-0/+1
| | | | | Co-authored-by: Xrayez <https://github.com/Xrayez> Co-authored-by: DleanJeans <https://github.com/DleanJeans>
* Add integer posmod and rename default arg namesAaron Franke2019-07-181-0/+1
| | | | | "posmod" is the integer version of "fposmod". We do not need a "mod" because of the % operator. I changed the default arg names from "x" and "y" to "a" and "b" because they are not coordinates. I also changed pow's arg names to "base" and "exp". Also, I reorganized the code in the VS built-in funcs switch statement.
* Added move_toward functions for float, Vector2 and Vector3Giacom2019-05-281-0/+1
|
* Make "decimal" functions more consistentAaron Franke2019-04-301-0/+1
| | | | In GDScript, rename "decimals" to "step_decimals". In C#, add "StepDecimals", but keep the old functionality in a method called "DecimalCount".
* [Core] Expose approximate equality methods to GDScriptAaron Franke2019-04-251-0/+2
|
* Added smoothstep built-in functionChaosus2019-04-071-0/+1
|
* Update copyright statements to 2019Rémi Verschelde2019-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* Add new "push_*()" functions to GDScriptMichael Alexsander Silva Dias2018-10-311-1/+2
|
* Make core/ includes absolute, remove subfolders from include pathRémi Verschelde2018-09-121-1/+1
| | | | | | This allows more consistency in the manner we include core headers, where previously there would be a mix of absolute, relative and include path-dependent includes.
* Merge pull request #18966 from chanon/new-debug-printMax Hilbrunner2018-07-041-0/+1
|\ | | | | Add new debug print method that shows line number where the print came from
| * add new print_debug method which shows source and line numberchanon2018-05-281-0/+1
| |
* | add new get_stack function to get GDScript stack trace as arraychanon2018-05-171-0/+1
|/
* Add is_instance_valid() method to GDScript, ending more than a decade of pain.Juan Linietsky2018-05-071-0/+1
|
* Add missing copyright headers and fix formattingRémi Verschelde2018-01-051-0/+1
| | | | | | Using `misc/scripts/fix_headers.py` on all Godot files. Some missing header guards were added, and the header inclusion order was fixed in the Bullet module.
* Update copyright statements to 2018Rémi Verschelde2018-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* Add cartesian to polar conversion functionspablotato2017-11-201-0/+2
|
* GDScript: Refactor "GD" class prefix to "GDScript"Rémi Verschelde2017-11-161-0/+123