summaryrefslogtreecommitdiffstats
path: root/modules/navigation/nav_map.cpp
Commit message (Collapse)AuthorAgeFilesLines
...
* Make navigation mesh edge connections optionalsmix82023-05-111-1/+11
| | | | Makes navigation mesh edge connections optional.
* Prevent unnecessary navigation map synchronizationssmix82023-05-111-0/+12
| | | | Prevents unnecessary navigation map synchronizations triggered by redundant calls to setters of e.g. region, link or map properties.
* Rework Navigation Avoidancesmix82023-05-101-33/+209
| | | | Rework Navigation Avoidance.
* Merge pull request #74558 from smix8/navserver_real_t_4.xRémi Verschelde2023-04-031-19/+19
|\ | | | | | | Fix NavigationServer internals still using float instead of real_t
| * Fix NavigationServer internals still using float instead of real_tsmix82023-03-071-19/+19
| | | | | | | | Fixes that some NavigationServer internals still used float instead of real_t in some parts.
* | Fix NavigationAgent enable avoidance crashsmix82023-04-011-0/+1
| | | | | | | | Fixes NavigationAgent enable avoidance crash.
* | Fix agents with disabled avoidance getting added to avoidance simulationsmix82023-03-141-3/+3
|/ | | | Fixes that agents with disabled avoidance were getting added to avoidance simulation.
* Rename NavigationServer internal RvoAgent to NavAgentsmix82023-02-011-9/+9
| | | | Renames the NavigationServer internal RvoAgent to NavAgent.
* Rename Navigation uses of 'location' to 'position'smix82023-01-261-2/+2
| | | | Contrary to the entire rest of the engine NavigationAgent's and NavigationLinks decided to deal with locations instead of positions.
* Convert en_GB spelling to en_US with codespellRémi Verschelde2023-01-231-2/+2
|
* Use range iterators in LocalVector loopskobewi2023-01-211-34/+23
|
* Add NavigationServer Performance Monitorsmix82023-01-081-0/+33
| | | | Adds Performance Monitor for NavigationServer3D.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Add support for emitting a signal when entering a NavLinkJosh Jones2022-12-171-4/+81
|
* Fix crash in navigation 3d when target is not reachableSean2022-10-021-0/+1
| | | | The code that resets variables to retry navigation to the closest possible poly was not resetting 1 variable, which caused it to exceed the vector bounds
* Fix heap-use-after-free in `NavMap::get_path()`Haoyu Qiu2022-09-281-11/+9
|
* Added node for Navigation linksJosh Jones2022-08-261-10/+154
|
* Replace Navigation std::vector use with LocalVectorsmix82022-07-281-37/+37
| | | | Replace Navigation std::vector use with LocalVector.
* Remove ThreadWorkPool, replace by WorkerThreadPoolJuan Linietsky2022-07-251-10/+3
| | | | | The former needs to be allocated once per usage. The later is shared for all threads, which is more efficient. It can also be better debugged.
* Print NavMap error only once for invalid NavMesh.K. S. Ernest (iFire) Lee2022-06-161-1/+1
|
* Streamline Navigation layer function names.smix82022-06-151-3/+3
| | | | Streamline Navigation layer function names.
* Add NavigationRegion costs for pathfindingsmix82022-06-061-3/+13
| | | | Add NavigationRegion costs for pathfinding.
* Replace most uses of Map by HashMapreduz2022-05-161-2/+2
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Create NavMap thread pool only when it's used, to prevent creating excessive ↵bruvzg2022-04-261-1/+3
| | | | amount of running threads.
* Merge pull request #60359 from adamscott/nav-map-thread-work-poolRémi Verschelde2022-04-261-2/+9
|\
| * Use ThreadWorkPool instead of thread_process_array in NavMapAdam Scott2022-04-191-2/+9
| |
* | Fix crash in `GodotNavigationServer::map_get_path`Pawel Lampe2022-04-221-3/+3
|/
* NavMap::get_path Fix not resetting least_cost_idkleonc2022-04-141-2/+3
|
* Fix get_simple_path behavior in 2D & 3DPawel Lampe2022-04-051-2/+6
|
* NavMap Fix polygons being treated like triangle strips instead of triangle fanskleonc2022-02-131-69/+25
|
* Style: Remove inconsistently used `@author` docstringsRémi Verschelde2022-01-041-4/+0
| | | | | | | | | | Each file in Godot has had multiple contributors who co-authored it over the years, and the information of who was the original person to create that file is not very relevant, especially when used so inconsistently. `git blame` is a much better way to know who initially authored or later modified a given chunk of code, and most IDEs now have good integration to show this information.
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Use range iterators for `Map`Lightning_A2021-09-301-6/+6
|
* Use functions defined in the their classes.Anilforextra2021-09-291-2/+2
|
* Use is_equal_approx in more placesAaron Franke2021-07-211-3/+3
|
* Rename `GdNavigationServer` to `GodotNavigationServer`Rémi Verschelde2021-06-301-0/+764
And rename `gdnavigation` module to simply `navigation`.