summaryrefslogtreecommitdiffstats
path: root/scene/gui/scroll_bar.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@f128f383e892865379cb8b14e7bcc9858efe2973Spartan3222024-11-271-7/+9
|\
| * Fix `ScrollBar` grabber mouse input.Mounir Tohami2024-11-271-7/+9
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* CI: Update `clang-format` pre-commit hook to 19.1.0Rémi Verschelde2024-09-261-1/+1
|
* Use Core/Scene stringnames consistentlykobewi2024-05-131-9/+9
|
* Enabled 'Scrolling' signal when scrolling with middle mouse on ↵Sofox2024-04-221-21/+36
| | | | RichTextLabel/ScrollContainer
* Document, cleanup and fix some theme propertieskobewi2023-09-271-17/+0
|
* Register theme properties with ThemeDBYuri Sizov2023-09-111-18/+15
|
* [RTL] Improve scroll bar responsiveness during updates.bruvzg2023-08-141-0/+8
|
* Merge pull request #67910 from pkowal1982/scroll_barRémi Verschelde2023-03-081-4/+8
|\ | | | | | | Fix scrolling behaviour with zero/low page value
| * Fix scrolling behaviour with low page valuePaweł2022-10-261-4/+8
| |
* | Clean-up, harmonize, and improve StyleBox APIYuri Sizov2023-01-191-3/+3
| | | | | | | | | | | | - Make all margin properties follow the same naming convention (their getter and setter too). - Remove a virtual counterpart of `get_style_margin` from API. - Allow to override `get_minimum_size` from scripting and remove `get_center_size`.
* | One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* | Fix Determining Window for TouchscreenMarkus Sauermann2022-12-071-1/+1
|/ | | | | | | | | DisplayServer::screen_is_touchscreen will likely never utilize its parameter p_screen. This PR replaces this function by DisplayServer::is_touchscreen_available() with the same functionality. This solves the problem, that a SubViewport was used for determining the screen, which resulted in error messages.
* Code simplificationsMarkus Sauermann2022-10-181-1/+1
| | | | | | | | | | | | 1. Viewport::get_visible_rect().position is always zero. So Control::get_window_rect is identical to Control::get_global_rect. Remove Control::get_window_rect since it is not used in the source code. 2. sqrt(a * a) = abs(a) for doubles 3. Simplify affine_inverse combination 4. Simplify calculation in shaders
* Ensure all checks of `is_action` in the editor which are for 'shortcut' use, ↵Eric M2022-09-241-6/+6
| | | | check the action exactly.
* Rename CONNECT_ONESHOT TO CONNECT_ONE_SHOTMicky2022-09-061-2/+2
| | | | For consistency. Every other exposed `one_shot` is spaced out like this.
* Add a lifecycle method for manual theme item caching to ControlYuri Sizov2022-09-011-29/+47
|
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-6/+6
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* Remove Signal connect bindsJuan Linietsky2022-07-291-2/+2
| | | | | Remove the optional argument p_binds from `Object::connect` since it was deprecated by Callable.bind(). Changed all uses of it to Callable.bind()
* Add suffixes to all nodes and resourcesFireForge2022-06-111-1/+1
|
* Style: Cleanup single-line blocks, semicolons, dead codeRémi Verschelde2022-02-161-5/+0
| | | | | Remove currently unused implementation of TextureBasisU, could be re-added later on if needed and ported.
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-147/+150
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Use "enum class" for input enumsAaron Franke2021-11-121-4/+4
|
* Construct values only when necessary.Anilforextra2021-09-231-1/+1
|
* Merge pull request #51805 from skysphr/scrollbar-icons-pressedHugo Locurcio2021-09-131-2/+24
|\ | | | | Added increment_pressed and decrement_pressed icons to scrollbars
| * Added increment_pressed and decrement_pressed icons to scrollbarsskysphr2021-08-171-2/+24
| |
* | Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-2/+1
|/ | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Optimize StringName usagereduz2021-07-181-26/+26
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Fix crashes in *_input functionsRafał Mikrut2021-04-051-0/+2
|
* Rename ButtonList enum and members to MouseButtonAaron Franke2021-03-231-3/+3
|
* Initialize class variables with default values in scene/ [2/2]Rafał Mikrut2021-02-091-1/+1
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Rename Control margin to offsetMarcel Admiraal2020-12-231-4/+4
|
* Cleanup unused engine codeTomasz Chabora2020-12-091-12/+0
|
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-1/+1
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* GUI ScrollBar: possible fix for scrollingSergey Minakov2020-07-251-1/+1
| | | | Use of unmodified value returned by 'screen_is_touchscreen' to be used in determening if scroll bar should be scrolled
* Allow scroll_to_line when scroll_active is 'false'Dominik 'dreamsComeTrue' Jasiński2020-06-031-13/+8
| | | | Fix #36134
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-21/+36
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-64/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Replace NULL with nullptrlupoDharkael2020-04-021-4/+4
|
* Popups are now windows also (broken!)Juan Linietsky2020-03-261-25/+25
|
* Added a Window node, and made it the scene root.Juan Linietsky2020-03-261-1/+1
| | | | Still a lot of work to do.
* Effective DisplayServer separation, rename X11 -> LinuxBSDJuan Linietsky2020-03-261-2/+2
|
* Signals: Port connect calls to use callable_mpRémi Verschelde2020-02-281-11/+9
| | | | | | | | | Remove now unnecessary bindings of signal callbacks in the public API. There might be some false positives that need rebinding if they were meant to be public. No regular expressions were harmed in the making of this commit. (Nah, just kidding.)
* Variant: Added 64-bit packed arrays, renamed Variant::REAL to FLOAT.Juan Linietsky2020-02-251-1/+1
| | | | | | | | | | | | | | | | | | | | | - Renames PackedIntArray to PackedInt32Array. - Renames PackedFloatArray to PackedFloat32Array. - Adds PackedInt64Array and PackedFloat64Array. - Renames Variant::REAL to Variant::FLOAT for consistency. Packed arrays are for storing large amount of data and creating stuff like meshes, buffers. textures, etc. Forcing them to be 64 is a huge waste of memory. That said, many users requested the ability to have 64 bits packed arrays for their games, so this is just an optional added type. For Variant, the float datatype is always 64 bits, and exposed as `float`. We still have `real_t` which is the datatype that can change from 32 to 64 bits depending on a compile flag (not entirely working right now, but that's the idea). It affects math related datatypes and code only. Neither Variant nor PackedArray make use of real_t, which is only intended for math precision, so the term is removed from there to keep only float.
* Reworked signal connection system, added support for Callable and Signal ↵Juan Linietsky2020-02-201-9/+9
| | | | objects and made them default.
* Texture refactorJuan Linietsky2020-02-111-9/+9
| | | | | | | | -Texture renamed to Texture2D -TextureLayered as base now inherits 2Darray, cubemap and cubemap array -Removed all references to flags in textures (they will go in the shader) -Texture3D gone for now (will come back later done properly) -Create base rasterizer for RenderDevice, RasterizerRD