summaryrefslogtreecommitdiffstats
path: root/scene/gui/video_stream_player.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@c6c464cf9ae56e8b68620af65125dd980d0e8122Spartan3222024-11-021-0/+8
|\
| * Add "Game" editor for better runtime debuggingMichael Alexsander2024-10-301-0/+8
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Use Core/Scene stringnames consistentlykobewi2024-05-131-1/+0
|
* Add shorthand for using singleton string nameskobewi2024-05-111-2/+2
|
* Replace internal usage of ImageTexture in VideoStreamPlayer for Texture2DÁlex Román Núñez2024-01-241-1/+0
|
* VideoPlayer: Fix reloading translation remapped streamRémi Verschelde2023-11-121-0/+10
| | | | Fixes #43917.
* Use StringName consistently to refer to the Master audio bus nameHugo Locurcio2023-08-071-1/+1
|
* Extract and reorganize texture resource classesHendrik Brucker2023-07-141-0/+1
|
* Merge pull request #77858 from kinami-imai/expose_videostreamplayer_video_lengthYuri Sizov2023-07-121-0/+8
|\ | | | | | | Expose VideoStreamPlayer video length
| * Expose VideoStreamPlayer video length今井きなみ2023-06-051-0/+8
| |
* | Merge pull request #77857 from ↵Yuri Sizov2023-07-121-0/+16
|\ \ | | | | | | | | | | | | | | | kinami-imai/add_loop_property_to_videostreamplayer Add `loop` property to VideoStreamPlayer
| * | Add loop property to VideoStreamPlayer今井きなみ2023-06-051-0/+16
| |/
* | Use NULL instead of COND checks when appropriateNinni Pipping2023-06-101-2/+2
| | | | | | | | Restricted to scene
* | Fix VideoStreamPlayer seamless loop今井きなみ2023-06-051-0/+3
|/
* Updates VideoDecoder plugin API to GDExtension.anish bhobe2023-01-301-1/+6
| | | | | | | | | | | | | Adds VideoStream and relevant resource loaders to migrate external GDNative plugins to GDExtension. Adds a VideoStreamLoader as a specialization of ResourceFormatLoader as ClassDB::is_parent_class is inaccessible from GDExtension currently. Using Object* instead of Ref<T> in order to avoid the refcount bug (godotengine/godot-cpp#652) Also another bug is in ResourceLoader in use on the extension side that requires fixing.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Change time parameters and variables to double typeDave Palais2022-09-261-2/+2
| | | | Addresses #65313
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-2/+2
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* Rename `str2var` to `str_to_var` and similarMicky2022-08-261-2/+2
| | | | | | | | | | | | | | | | | | Affects the Math class, a good chunk of the audio code, and a lot of other miscellaneous classes, too. - `var2str` -> `var_to_str` - `str2var` -> `str_to_var` - `bytes2var` -> `bytes_to_var` - `bytes2var_with_objects` -> `bytes_to_var_with_objects` - `var2bytes` -> `var_to_bytes` - `var2bytes_with_objects` -> `var_to_bytes_with_objects` - `linear2db` -> `linear_to_db` - `db2linear` -> `db_to_linear` - `deg2rad` -> `deg_to_rad` - `rad2deg` -> `rad_to_deg` - `dict2inst` -> `dict_to_inst` - `inst2dict` -> `inst_to_dict`
* Add some codes, returnes directly if the value is not changed.风青山2022-08-231-0/+8
| | | | Avoid executing the following value-changed logics if the value does not really change.
* Implement BPM supportreduz2022-07-231-1/+1
| | | | | | | | | | | Based on #62896, only implements the BPM support part. * Implements BPM support in the AudioStreamOGG/MP3 importers. * Can select BPM/Bar Size and total beats in a song file, as well as edit looping points. * Looping is now BPM aware * Added a special importer UI for configuring this. * Added a special preview showing the audio waveform as well as the playback position in the resource picker. * Renamed `AudioStream::instance` to `instantiate` for correctness.
* Properly handle game pause in VideoPlayerkobewi2022-06-261-0/+34
|
* Add suffixes to all nodes and resourcesFireForge2022-06-111-1/+1
|
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-1/+1
|
* Fix some issues found by cppcheck.bruvzg2022-04-061-2/+2
|
* Style: Cleanup single-line blocks, semicolons, dead codeRémi Verschelde2022-02-161-24/+18
| | | | | Remove currently unused implementation of TextureBasisU, could be re-added later on if needed and ported.
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-5/+2
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Rename `VideoPlayer` to `VideoStreamPlayer` for consistencyRémi Verschelde2021-12-061-0/+470
It's a player for `VideoStream` resources, just like `AudioStreamPlayer` is a player for `AudioStream` resources. Closes https://github.com/godotengine/godot-proposals/issues/3624.