index
:
redot-engine.git
4.3
master
Redot Engine – Multi-platform 2D and 3D game engine
summary
refs
log
tree
commit
diff
stats
log msg
author
committer
range
path:
root
/
scene
/
gui
/
viewport_container.cpp
Commit message (
Expand
)
Author
Age
Files
Lines
*
Rename ViewportContainer to SubViewportContainer
Michael Alexsander
2020-04-01
1
-215
/
+0
*
Added a Window node, and made it the scene root.
Juan Linietsky
2020-03-26
1
-9
/
+9
*
basic 2D engine is more or less working with Vulkan, including editor.
Juan Linietsky
2020-02-11
1
-2
/
+2
*
Update copyright statements to 2020
Rémi Verschelde
2020-01-01
1
-2
/
+2
*
process unhandled input in ViewportContainer
Fabian Stiewitz
2019-08-31
1
-0
/
+1
*
Update copyright statements to 2019
Rémi Verschelde
2019-01-01
1
-2
/
+2
*
ViewportContainer was not passing unhandled input. Pass it, fixes #17326
Juan Linietsky
2018-11-15
1
-0
/
+26
*
-Send mouse motion events again to CollisionObjects (Area/Body) if they move,...
Juan Linietsky
2018-11-15
1
-0
/
+2
*
ViewportContainer passes input down to children viewports
Fabio Alessandrelli
2018-01-15
1
-0
/
+28
*
Add missing copyright headers and fix formatting
Rémi Verschelde
2018-01-05
1
-0
/
+1
*
Update copyright statements to 2018
Rémi Verschelde
2018-01-01
1
-2
/
+2
*
Ability to shrink 3D viewport by half
Juan Linietsky
2017-10-31
1
-1
/
+34
*
Use HTTPS URL for Godot's website in the headers
Rémi Verschelde
2017-08-27
1
-1
/
+1
*
Convert Object::cast_to() to the static version
Hein-Pieter van Braam
2017-08-24
1
-4
/
+4
*
Add "Godot Engine contributors" copyright line
Rémi Verschelde
2017-04-08
1
-0
/
+1
*
A Whole New World (clang-format edition)
Rémi Verschelde
2017-03-05
1
-25
/
+16
*
Add a bunch of missing Godot headers in own files
Rémi Verschelde
2017-03-05
1
-1
/
+30
*
Rename the _MD macro to D_METHOD
Hein-Pieter van Braam
2017-02-13
1
-2
/
+2
*
Remove use of _SCS from ADD_METHOD
Hein-Pieter van Braam
2017-02-13
1
-1
/
+1
*
New API for visibility in both CanvasItem and Spatial
Juan Linietsky
2017-01-13
1
-1
/
+1
*
ObjectTypeDB was renamed to ClassDB. Types are meant to be more generic to Va...
Juan Linietsky
2017-01-02
1
-2
/
+2
*
-Added ViewportContainer, this is the only way to make viewports show up in G...
Juan Linietsky
2016-10-05
1
-0
/
+103