summaryrefslogtreecommitdiffstats
path: root/scene/main/resource_preloader.cpp
Commit message (Expand)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
* Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
* Remove unnecessary assignmentsWilson E. Alvarez2023-12-131-3/+2
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
* Add tests for empty/unnamed arguments to ClassDB, Variant, GDScriptYuri Sizov2022-08-081-1/+1
* Add a new HashSet templatereduz2022-05-201-1/+1
* Use range iterators for RBSet in most casesAaron Record2022-05-191-3/+3
* Replace most uses of Map by HashMapreduz2022-05-161-4/+5
* Remove `RES` and `REF` typedefs in favor of spelled out `Ref<>`Hugo Locurcio2022-05-031-8/+8
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
* Rename `PROPERTY_USAGE_NOEDITOR` to `PROPERTY_USAGE_NO_EDITOR`Hugo Locurcio2021-11-031-1/+1
* Use range iterators for `Map`Lightning_A2021-09-301-4/+4
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
* Style: Enforce separation line between function definitionsRémi Verschelde2020-05-141-0/+2
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-16/+0
* PoolVector is gone, replaced by VectorJuan Linietsky2020-02-181-4/+4
* Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
* Update copyright statements to 2019Rémi Verschelde2019-01-011-2/+2
* Bind many more properties to scriptsBojidar Marinov2018-01-121-1/+1
* Add missing copyright headers and fix formattingRémi Verschelde2018-01-051-0/+1
* Update copyright statements to 2018Rémi Verschelde2018-01-011-2/+2
* Use HTTPS URL for Godot's website in the headersRémi Verschelde2017-08-271-1/+1
* Removes type information from method bindsIgnacio Etcheverry2017-08-101-2/+2
* Add object type hint for docsPoommetee Ketson2017-07-231-2/+2
* Add "Godot Engine contributors" copyright lineRémi Verschelde2017-04-081-0/+1
* A Whole New World (clang-format edition)Rémi Verschelde2017-03-051-59/+42
* Rename the _MD macro to D_METHODHein-Pieter van Braam2017-02-131-9/+9
* Remove use of _SCS from ADD_METHODHein-Pieter van Braam2017-02-131-1/+1
* Memory pool vectors (DVector) have been enormously simplified in code, and re...Juan Linietsky2017-01-071-4/+4
* ObjectTypeDB was renamed to ClassDB. Types are meant to be more generic to Va...Juan Linietsky2017-01-021-9/+9
* Welcome in 2017, dear changelog reader!Rémi Verschelde2017-01-011-1/+1
* Update copyright to 2016 in headersGeorge Marques2016-01-011-1/+1
* Updated copyright year in all headersJuan Linietsky2015-04-181-1/+1
* GODOT IS OPEN SOURCEJuan Linietsky2014-02-091-0/+183