summaryrefslogtreecommitdiffstats
path: root/servers/physics_2d/godot_space_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
|
* Rebrand preambles to RedotSpartan3222024-10-131-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | (cherry picked from commit e8542b06acca3c1bdeee4b528411771f0819f084) Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Servers] Replace `ERR_FAIL_COND` with `ERR_FAIL_NULL` where applicableA Thousand Ships2023-09-251-4/+4
|
* Merge pull request #66076 from ↵Rémi Verschelde2023-02-011-1/+1
|\ | | | | | | | | | | Sauermann/fix-double-physics-input-events-for-layers Fix physics events being interpreted twice for nodes in canvas layer
| * Fix physics events being interpreted twice when in canvas layerMarkus Sauermann2023-01-311-1/+1
| |
* | Create default World physics spaces on demand onlysmix82023-01-311-9/+9
| | | | | | | | Changes that the default physics spaces of World resources are only created on first use.
* | Merge pull request #68429 from KoBeWi/PropertySettingsRémi Verschelde2023-01-061-20/+7
|\ \ | | | | | | Add PropertyInfo overload for GLOBAL_DEF
| * | Add PropertyInfo overload for GLOBAL_DEFkobewi2022-12-111-20/+7
| |/
* / One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
|/ | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Remove duplicate project settings definitionskobewi2022-11-081-1/+1
|
* Merge pull request #66548 from akien-mga/msvc-warnings-c4701-c4703Rémi Verschelde2022-09-281-2/+3
|\ | | | | | | Fix MSVC warnings C4701 and C4703: Potentially uninitialized variable used
| * Fix MSVC warnings C4701 and C4703: Potentially uninitialized variable usedRémi Verschelde2022-09-281-2/+3
| |
* | Fix MSVC warning C4702: unreachable codeRémi Verschelde2022-09-281-2/+0
|/ | | | Part of #66537.
* Merge pull request #64367 from Mickeon/rename-var-to-strRémi Verschelde2022-08-261-1/+1
|\ | | | | Rename `str2var` to `str_to_var` and similar
| * Rename `str2var` to `str_to_var` and similarMicky2022-08-261-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Affects the Math class, a good chunk of the audio code, and a lot of other miscellaneous classes, too. - `var2str` -> `var_to_str` - `str2var` -> `str_to_var` - `bytes2var` -> `bytes_to_var` - `bytes2var_with_objects` -> `bytes_to_var_with_objects` - `var2bytes` -> `var_to_bytes` - `var2bytes_with_objects` -> `var_to_bytes_with_objects` - `linear2db` -> `linear_to_db` - `db2linear` -> `db_to_linear` - `deg2rad` -> `deg_to_rad` - `rad2deg` -> `rad_to_deg` - `dict2inst` -> `dict_to_inst` - `inst2dict` -> `inst_to_dict`
* | Restore RigidBody2/3D, SoftBody names in physicsfabriceci2022-08-261-2/+2
|/
* Add collision weight to PhysicsBody for penetrations must be avoidedSilc Renew2022-08-181-1/+13
| | | | Co-authored-by: Juan Linietsky <reduzio@gmail.com>
* Add a new HashSet templatereduz2022-05-201-1/+1
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Add motion parameter to toggle whether recovery is reported as a collisionRicardo Buring2022-05-181-1/+1
| | | | This makes the intent explicit in each use case.
* Replace most uses of Map by HashMapreduz2022-05-161-1/+1
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Rename Basis get_axis to get_column, remove redundant methodsAaron Franke2022-05-031-4/+4
|
* Rename Transform2D "elements" to "columns"Aaron Franke2022-04-291-2/+2
|
* Fix more issues found by cppcheck.bruvzg2022-04-201-2/+2
|
* Fix some issues found by cppcheck.bruvzg2022-04-061-3/+3
|
* Raycasts hitting from inside: return collision point in global coordinatesRicardo Buring2022-03-201-1/+1
|
* Merge pull request #57630 from lawnjelly/bvh4_templated_checksRémi Verschelde2022-03-041-4/+1
|\ | | | | [4.x] BVH - Sync BVH with 3.x
| * BVH - Sync BVH with 3.xlawnjelly2022-02-041-4/+1
| | | | | | | | | | Templated mask checks and generic NUM_TREES Fix leaking leaves
* | In final phase of test_body_motion, move and cull AABB for body once, ↵Ricardo Buring2022-02-181-4/+3
|/ | | | instead of for every shape
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Merge pull request #55702 from nekomatata/physics-solver-settingsRémi Verschelde2021-12-101-0/+18
|\
| * Add physics solver settings to project settingsPouleyKetchoupp2021-12-071-0/+18
| | | | | | | | | | | | | | | | | | | | | | | | Helps with discovery and setup of physics solver settings, in a specific project settings section for both 2D and 3D. Other changes for cleanup: -Removed unused space parameters in 3D SPACE_PARAM_BODY_ANGULAR_VELOCITY_DAMP_RATIO SPACE_PARAM_CONSTRAINT_DEFAULT_BIAS -Added custom solver bias for Shape3D (same as Shape2D) -Improved documentation for solver settings
* | Handle test body motion with 0 marginPouleyKetchoupp2021-12-091-9/+15
|/ | | | | | | | | Margin needs to have a high enough value for test body motion to work properly (separate using the margin, move without then gather rest info with the margin again). Fixes issues with test motion returning no collision in some cases with margin equal to 0.
* Update space parameters in 2D and 3DPouleyKetchoupp2021-12-031-2/+12
| | | | | | | | | | | Clarified space parameters for contacts and added missing ones. List of changes: -Add contact bias to space parameters -Add solver iterations to space parameters, instead of a specific physics server function -Renamed BODY_MAX_ALLOWED_PENETRATION to CONTACT_MAX_ALLOWED_PENETRATION to make it consistent with other contact parameters
* Fix rest_info returning no result with high margin and low motionPouleyKetchoupp2021-11-171-9/+5
| | | | | Apply the same logic as in test_body_motion to make sure the minimum allowed depth doesn't filter out all contacts in this case.
* Add raycast options to hit when starting inside / hit back facesPouleyKetchoupp2021-11-101-0/+16
| | | | | Makes the results consistent for all shape types with options to set the desired behavior.
* Use parameter classes instead of arguments for all physics queriesPouleyKetchoupp2021-11-041-61/+48
| | | | | | | | Same as what is already done for shape queries, applied to point and ray queries. Easier to document and more flexible to add more parameters. Also expose intersect_point method to script in 3D. Remove intersect_point_on_canvas in 2D, replaced with a parameter.
* Rename Godot Physics classes from *SW to Godot*PouleyKetchoupp2021-10-181-0/+1213
Also moved MT physics server wrappers to the main servers folder, since they don't have to be implementation specific.