summaryrefslogtreecommitdiffstats
path: root/tests/core/templates
Commit message (Collapse)AuthorAgeFilesLines
* Fix Godot headers for AHashMap to RedotSpartan3222024-10-301-2/+2
|
* Merge pull request #818 from Spartan322/fixup/copyright-headersGeorge L. Albany2024-10-2710-20/+20
|\ | | | | Fix copyright headers referring to Godot
| * Fix copyright headers referring to GodotSpartan3222024-10-2710-20/+20
| |
* | Merge commit godotengine/godot@61accf060515416da07d913580419fd8c8490f7bSpartan3222024-10-261-0/+297
|\ \ | |/ |/|
| * Implement array based hash mapnazarii2024-10-241-0/+295
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-1110-0/+20
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* | Rebrand Godot to RedotRandolph W. Aarseth II2024-10-111-6/+6
|/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Add Linux Editor tests workflow matrix Add Windows Editor w/ Mono workflow matrix Add Generate Glue Code job to Windows workflow Add Build GodotSharp job to Windows workflow Add godot compatibility version references Add Godot author info Add Godot version compatibility info Add Godot donor info Add Godot authors and donors to editor_about.cpp Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Core] Add `LocalVector::has` for convenienceA Thousand Ships2024-05-061-1/+10
|
* Merge pull request #90268 from RandomShaper/wtp_serversRémi Verschelde2024-04-151-10/+34
|\ | | | | Use WorkerThreadPool for Server threads (enhanced)
| * WorkerThreadPool: Support daemon-like tasks (via yield semantics)Pedro J. Estébanez2024-04-101-10/+34
| |
* | Fix a doc and a test issue not caught by CIRémi Verschelde2024-04-101-2/+0
|/
* Add unit tests for OAHashMapnazarii2024-04-101-0/+227
|
* Fix PagedArray.merge_unordered() dropping pagesmyaaaaaaaaa2023-02-161-0/+51
|
* One Copyright Update to rule them allRémi Verschelde2023-01-059-261/+261
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Remove NO_THREADS fallback code, Godot 4 requires thread supportRémi Verschelde2022-10-031-4/+0
| | | | | This also removes `OS::can_use_threads` from the public API since it's always true.
* Tests: Silence some intentional errorsRémi Verschelde2022-08-042-3/+3
| | | | Also fix printing messages in ClassDB test.
* Add unit tests for RID class.Sean Kim2022-08-041-0/+101
|
* Code quality: Fix header guards consistencyRémi Verschelde2022-07-251-1/+1
| | | | | Adds `header_guards.sh` bash script, used in CI to validate future changes. Can be run locally to fix invalid header guards.
* Add a new HashSet templatereduz2022-05-201-0/+228
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Add a new HashMap implementationreduz2022-05-121-34/+32
| | | | | | | | | | | | | | | | | Adds a new, cleaned up, HashMap implementation. * Uses Robin Hood Hashing (https://en.wikipedia.org/wiki/Hash_table#Robin_Hood_hashing). * Keeps elements in a double linked list for simpler, ordered, iteration. * Allows keeping iterators for later use in removal (Unlike Map<>, it does not do much for performance vs keeping the key, but helps replace old code). * Uses a more modern C++ iterator API, deprecates the old one. * Supports custom allocator (in case there is a wish to use a paged one). This class aims to unify all the associative template usage and replace it by this one: * Map<> (whereas key order does not matter, which is 99% of cases) * HashMap<> * OrderedHashMap<> * OAHashMap<>
* Remove unused legacy testsRémi Verschelde2022-04-072-342/+0
| | | | | | | | They haven't been updated for years and still use the old MainLoop basic framework instead of the new doctest one. They're of dubious quality and best redone from scratch using the new framework.
* `Array`: Relax `slice` bound checks to properly handle negative indicesRémi Verschelde2022-01-101-5/+20
| | | | | | | | | | | | | | The same is done for `Vector` (and thus `Packed*Array`). `begin` and `end` can now take any value and will be clamped to `[-size(), size()]`. Negative values are a shorthand for indexing the array from the last element upward. `end` is given a default `INT_MAX` value (which will be clamped to `size()`) so that the `end` parameter can be omitted to go from `begin` to the max size of the array. This makes `slice` works similarly to numpy's and JavaScript's.
* Add list initialization support for Vector & LocalVectorHaoyu Qiu2022-01-052-0/+22
|
* Update copyright statements to 2022Rémi Verschelde2022-01-039-18/+18
| | | | Happy new year to the wonderful Godot community!
* Merge pull request #35901 from nathanfranke/pool-byte-array-subarray-exclusiveRémi Verschelde2021-12-071-22/+22
|\
| * PackedByteArray, Array slice end exclusive, rename subarray to sliceNathan Franke2021-11-261-22/+22
| |
* | Don't return reference on copy assignment operatorsRémi Verschelde2021-11-301-1/+4
|/ | | | | | | | | | | | | We prefer to prevent using chained assignment (`T a = b = c = T();`) as this can lead to confusing code and subtle bugs. According to https://en.wikipedia.org/wiki/Assignment_operator_(C%2B%2B), C++ allows any arbitrary return type, so this is standard compliant. This could be re-assessed if/when we have an actual need for a behavior more akin to that of the C++ STL, for now this PR simply changes a handful of cases which were inconsistent with the rest of the codebase (`void` return type was already the most common case prior to this commit).
* Rename `remove()` to `remove_at()` when removing by indexLightning_A2021-11-232-29/+29
|
* Move and organize tests into subfoldersAaron Franke2021-11-079-0/+2443