summaryrefslogtreecommitdiffstats
path: root/tests/test_physics_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Move and organize tests into subfoldersAaron Franke2021-11-071-403/+0
|
* Construct values only when necessary.Anilforextra2021-09-251-1/+1
|
* Rename WorldMarginShape to WorldBoundaryShapePouleyKetchoupp2021-09-141-7/+7
|
* Rename LineShape2D to WorldMarginShape2DHugo Locurcio2021-08-141-1/+1
| | | | | The new name makes it more obvious that it acts as an infinite plane, and is consistent with its 3D counterpart (WorldMarginShape3D).
* Use doubles for time everywhere in Timer/SceneTreeAaron Franke2021-07-261-1/+1
|
* Increase the default 2D gravity to 980.0Hugo Locurcio2021-05-051-1/+1
| | | | | | This makes 2D RigidBody physics feel less floaty out of the box. This closes https://github.com/godotengine/godot-proposals/issues/98.
* Unexpose _direct_state_changed in PhysicsBodyrafallus2021-04-221-4/+1
| | | | | | | Removed _direct_state_changed bindings Affects 2D and 3D nodes Callbacks now use Callable Tests were changed accordingly
* Rename ButtonList enum and members to MouseButtonAaron Franke2021-03-231-2/+2
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Rename MainLoop methods to match Node methodsMarcel Admiraal2020-12-221-3/+3
|
* Remove empty lines around braces with the formatting scriptAaron Franke2020-11-161-1/+0
|
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-2/+2
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* Move `tests` to the top-level directoryAndrii Doroshenko (Xrayez)2020-07-261-0/+407