summaryrefslogtreecommitdiffstats
path: root/editor/animation_track_editor_plugins.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
|
* Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
| | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Remove empty bind_methods()kobewi2024-08-151-6/+0
|
* [Scene] Add `SceneStringNames::font(_size/_color)`A Thousand Ships2024-06-181-48/+48
|
* Reorganize code related to editor themingYuri Sizov2024-01-161-1/+1
| | | | | | | | | | | | | This change introduces a new EditorThemeManager class to abstract theme generatio and its subroutines. Logic related to EditorTheme, EditorColorMap, and editor icons has been extracted into their respective files with includes cleaned up. All related files have been moved to a separate folder to better scope them in the project. This includes relevant generated files as well.
* Remove unnecessary assignmentsWilson E. Alvarez2023-12-131-4/+2
| | | | Co-authored-by: A Thousand Ships <96648715+AThousandShips@users.noreply.github.com>
* Add EditorStringNames singletonkobewi2023-09-031-15/+16
|
* Code simplificationsMarkus Sauermann2023-06-211-3/+1
| | | | | | | | | | | | | | | | | | | | CPPcheck found most of them. no need to assign the variable twice: - AnimationTrackEditTypeAudio - SSEffects variable is assigned in all if-else clauses: - EditorHelp - AndroidInputHandler - MenuBar - ShaderCompiler same if clause: - ItemList clearing an empty bitfield has no effect: - Viewport
* Fix `draw_multiline_colors` usageDanil Alexeev2023-05-151-30/+24
|
* Fix display for no-length audio stream keysSilc Renew2023-02-151-14/+10
|
* Fix AnimationEditor ignoring region of Sprite2DSalia Nifo2023-02-061-2/+2
|
* Add EditorUndoRedoManager singletonkobewi2023-01-161-3/+2
|
* Merge pull request #65609 from dalexeev/animated-spriteRémi Verschelde2023-01-051-2/+2
|\ | | | | | | `AnimatedSprite{2D,3D}` improvements
| * `AnimatedSprite{2D,3D}` improvementsDanil Alexeev2023-01-051-2/+2
| | | | | | | | | | * Add support for individual frame duration to `SpriteFrames`. * Various minor improvements.
* | One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
|/ | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Add inspector plugin for key time edit & Change find key argumentSilc Renew2022-12-221-6/+6
|
* AnimationTrackEditTypeAudio: Both start and end offset dragging is now ↵Eduard Zalyaev2022-12-121-24/+64
| | | | | | possible with proper preview of the changes Fixes #68788.
* Cleanup remaining EditorUndoRedoManager usageskobewi2022-11-241-12/+15
|
* Fix MSVC warnings, rename shadowed variables, fix uninitialized values, ↵bruvzg2022-10-071-18/+18
| | | | change warnings=all to use /W4.
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-6/+6
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* Add per-scene UndoRedokobewi2022-08-221-0/+1
|
* Style: Partially apply clang-tidy's `cppcoreguidelines-pro-type-member-init`Rémi Verschelde2022-05-021-1/+0
| | | | | | | | | | | Didn't commit all the changes where it wants to initialize a struct with `{}`. Should be reviewed in a separate PR. Option `IgnoreArrays` enabled for now to be conservative, can be disabled to see if it proposes more useful changes. Also fixed manually a handful of other missing initializations / moved some from constructors.
* Clip animation track keyframe rectsHaoyu Qiu2022-03-311-6/+6
|
* Initialize bools in the headers in editorAaron Franke2022-03-121-1/+0
|
* Use get_cursor_shape for identifying the cursor shape in ↵Markus Sauermann2022-03-111-7/+10
| | | | | | | AnimationTrackEditTypeAudio get_cursor_shape() is used in cases where a Control displays different cursors in different areas. There is no need to set the default cursor shape on every mouse move event.
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-2/+2
|
* Use List Initializations for Vectors.Anilforextra2022-01-121-14/+13
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* align to horizontal_alignment, valign to vertical_alignment, relatedNathan Franke2021-12-091-2/+2
|
* Use "enum class" for input enumsAaron Franke2021-11-121-2/+2
|
* Fixed animation insertion in SkeletonEditorSilc 'Tokage' Renew2021-10-231-2/+2
|
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-2/+2
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Optimize StringName usagereduz2021-07-181-65/+65
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Rename "Control" key to "Ctrl" and add "_pressed" suffix to all ↵Lightning_A2021-05-071-2/+2
| | | | InputEventWithModifiers properties/methods
* fix AnimationTrackEditor's undo with correction invalid method nameTokage2021-05-051-1/+1
|
* Fix crashes in *_input functionsRafał Mikrut2021-04-051-0/+2
|
* Merge pull request #47230 from trollodel/anim_track_colorRémi Verschelde2021-03-311-25/+45
|\ | | | | Preview the color animation in the animation editor
| * Preview the color animation in the animation editortrollodel2021-03-271-25/+45
| |
* | Rename ButtonList enum and members to MouseButtonAaron Franke2021-03-231-2/+2
|/
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* [Complex Text Layouts] Refactor Font class, default themes and controls to ↵bruvzg2020-11-261-23/+45
| | | | | | | | use Text Server interface. Implement interface mirroring. Add TextLine and TextParagraph classes. Handle UTF-16 input on macOS and Windows.
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-22/+44
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: Enforce separation line between function definitionsRémi Verschelde2020-05-141-0/+14
| | | | | | | | | | | | | | | | | | | | | | | I couldn't find a tool that enforces it, so I went the manual route: ``` find -name "thirdparty" -prune \ -o -name "*.cpp" -o -name "*.h" -o -name "*.m" -o -name "*.mm" \ -o -name "*.glsl" > files perl -0777 -pi -e 's/\n}\n([^#])/\n}\n\n\1/g' $(cat files) misc/scripts/fix_style.sh -c ``` This adds a newline after all `}` on the first column, unless they are followed by `#` (typically `#endif`). This leads to having lots of places with two lines between function/class definitions, but clang-format then fixes it as we enforce max one line of separation. This doesn't fix potential occurrences of function definitions which are indented (e.g. for a helper class defined in a .cpp), but it's better than nothing. Also can't be made to run easily on CI/hooks so we'll have to be careful with new code. Part of #33027.
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-76/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* [Core] Rename linear_interpolate to lerpAaron Franke2020-04-291-2/+2
|
* Replace NULL with nullptrlupoDharkael2020-04-021-1/+1
|
* Renaming of servers for coherency.Juan Linietsky2020-03-271-4/+4
| | | | | | | | | | VisualServer -> RenderingServer PhysicsServer -> PhysicsServer3D Physics2DServer -> PhysicsServer2D NavigationServer -> NavigationServer3D Navigation2DServer -> NavigationServer2D Also renamed corresponding files.
* Renamed 2D and 3D nodes to make their types explicitJuan Linietsky2020-03-271-8/+8
| | | | Fixes #30736.
* Popups are now windows also (broken!)Juan Linietsky2020-03-261-45/+45
|
* Signals: Port connect calls to use callable_mpRémi Verschelde2020-02-281-4/+2
| | | | | | | | | Remove now unnecessary bindings of signal callbacks in the public API. There might be some false positives that need rebinding if they were meant to be public. No regular expressions were harmed in the making of this commit. (Nah, just kidding.)