summaryrefslogtreecommitdiffstats
path: root/editor/property_editor.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Remove `CustomPropertyEditor` completelyYuri Sizov2022-08-011-1866/+0
|
* Improve easing inspector usabilityHugo Locurcio2022-08-011-2/+2
| | | | | | | | | | | | | - Add `positive_only` property hint to disallow using negative presets. These values are clamped in several places in the editor already, so this avoids displaying presets that don't work. - Move the Zero preset at the end of the positive list to match the custom property editor. It's also used less often than Linear, Ease In and Ease Out. - Rename presets to be consistent between the easing property editor and custom property editor. - Remove unused `inout` hint which was redundant since it was already the default.
* Extract EditorResourceConversionPlugin into its own source files and clean ↵Yuri Sizov2022-07-311-33/+1
| | | | up editor includes
* Remove Signal connect bindsJuan Linietsky2022-07-291-5/+3
| | | | | Remove the optional argument p_binds from `Object::connect` since it was deprecated by Callable.bind(). Changed all uses of it to Callable.bind()
* Split up editor export code into multiple filesAaron Franke2022-07-261-1/+0
|
* Color Pickers Respect SettingsGuh-Feng2022-07-211-7/+1
| | | | Updated editor_node with function that sets up color pickers throughout Godot to respect editor's settings.
* Rename Control PRESET_WIDE to PRESET_FULL_RECTFireForge2022-07-181-3/+3
|
* Seperate filter and description in FileDialog.add_filter()FireForge2022-07-091-3/+3
|
* Merge pull request #62075 from Vitika9/gsoc-colorpickerRémi Verschelde2022-07-081-5/+1
|\
| * ColorPicker RefactorVitika92022-07-061-5/+1
| |
* | Add a const call mode to Object, Variant and Script.K. S. Ernest (iFire) Lee2022-06-271-2/+2
|/ | | | | | | For this to work safely (user not call queue_free or something in the expression), a const call mode was added to Object and Variant (and optionally Script). This mode ensures only const functions can be called, making it safe to use from the editor. Co-Authored-By: reduz <reduzio@gmail.com>
* Support explicit values in flag properties, add C# flags supportRaul Santos2022-06-031-14/+19
| | | | | | | | | - Add support for explicit values in properties using `PROPERTY_HINT_FLAGS` that works the same way it does for enums. - Fix enums and flags in VisualScriptEditor (it wasn't considering the explicit value). - Use `PROPERTY_HINT_FLAGS` for C# enums with the FlagsAttribute instead of `PROPERTY_HINT_ENUM`.
* Add a new HashSet templatereduz2022-05-201-2/+2
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Use range iterators for RBSet in most casesAaron Record2022-05-191-4/+4
|
* Replace most uses of Map by HashMapreduz2022-05-161-4/+4
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Merge pull request #60627 from aaronfranke/rename-elementsRémi Verschelde2022-05-031-6/+6
|\ | | | | Rename Transform2D and Basis `elements` to `columns` and `rows` respectively
| * Rename Basis "elements" to "rows"Aaron Franke2022-04-291-4/+4
| |
| * Rename Transform2D "elements" to "columns"Aaron Franke2022-04-291-2/+2
| |
* | Remove `RES` and `REF` typedefs in favor of spelled out `Ref<>`Hugo Locurcio2022-05-031-13/+13
|/ | | | | | These typedefs don't save much typing compared to the full `Ref<Resource>` and `Ref<RefCounted>`, yet they sometimes introduce confusion among new contributors.
* Initialize bools in the headers in editorAaron Franke2022-03-121-3/+0
|
* Discern between virtual and abstract class bindingsreduz2022-03-101-1/+1
| | | | | | | | | | | | | | * Previous "virtual" classes (which can't be instantiated) are not corretly named "abstract". * Added a new "virtual" category for classes, they can't be instantiated from the editor, but can be inherited from script and extensions. * Converted a large amount of classes from "abstract" to "virtual" where it makes sense. Most classes that make sense have been converted. Missing: * Physics servers * VideoStream * Script* classes. which will go in a separate PR due to the complexity involved.
* Replace some bits of code left to work with the new `TabContainer`Michael Alexsander2022-03-041-1/+1
|
* Convert _notification methods to switch - Chunk CJakob Bouchard2022-02-161-2/+4
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-0/+2
|
* Merge pull request #43015 from Xrayez/refactor-auto-instapropRémi Verschelde2022-02-081-0/+6
|\ | | | | Refactor auto-instantiation of `Object` properties in editor
| * Refactor auto-instantiation of `Object` properties in editorAndrii Doroshenko (Xrayez)2021-12-281-0/+6
| | | | | | | | | | | | | | | | Auto-instantiation is used by the create dialog, but should also be used by the editor inspector. This refactors object properties auto-instantiation into a dedicated method to be reused throughout editor (and possibly scripting).
* | String: Add contains().Anilforextra2022-02-041-1/+1
| |
* | Store panels and docks singletons in their own classestrollodel2022-01-201-4/+4
| |
* | Improve locale detection.bruvzg2022-01-181-3/+22
| | | | | | | | | | Use separate language, script and country lists. Add locale selection dialog and property hint.
* | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | | | | | Happy new year to the wonderful Godot community!
* | Fix size of the default property popup after opening a Color propertyYuri Roubinsky2021-12-261-1/+1
|/
* Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-6/+6
| | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* align to horizontal_alignment, valign to vertical_alignment, relatedNathan Franke2021-12-091-2/+2
|
* Added `reset_size` method to `Control` and `Window` classesYuri Roubinsky2021-11-221-1/+1
|
* Use "enum class" for input enumsAaron Franke2021-11-121-2/+2
|
* Update usabilaty of the CustomPropertyEditorDavid Cambré2021-11-041-20/+24
| | | | Structure button layout so there is no more overlap.
* clang-format: Disable alignment of operands, too unreliableRémi Verschelde2021-10-281-5/+5
| | | | | | | | | Sets `AlignOperands` to `DontAlign`. `clang-format` developers seem to mostly care about space-based indentation and every other version of clang-format breaks the bad mismatch of tabs and spaces that it seems to use for operand alignment. So it's better without, so that it respects our two-tabs `ContinuationIndentWidth`.
* Replace BIND_VMETHOD by new GDVIRTUAL syntaxreduz2021-08-221-21/+12
| | | | | | | | | | | * New syntax is type safe. * New syntax allows for type safe virtuals in native extensions. * New syntax permits extremely fast calling. Note: Everything was replaced where possible except for `_gui_input` `_input` and `_unhandled_input`. These will require API rework on a separate PR as they work different than the rest of the functions. Added a new method flag METHOD_FLAG_OBJECT_CORE, used internally. Allows to not dump the core virtuals like `_notification` to the json API, since each language will implement those as it is best fits.
* Use const references where possible for List range iteratorsRémi Verschelde2021-07-251-6/+6
|
* Use C++ iterators for Lists in many situationsAaron Franke2021-07-231-12/+8
|
* Optimize StringName usagereduz2021-07-181-47/+47
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Fix casing of the "to" stop word in editor stringsHugo Locurcio2021-07-131-1/+1
| | | | | This also fixes a C# documentation example that had one of its strings incorrectly converted.
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-9/+9
|
* Documentation search fixesGregory Basile2021-06-161-1/+1
| | | | | | Updates rich_text_label so that the built-in documentation can be searched Previously, it would only find the first result and would not select other results Renames "_entered" functions to "_submitted"
* Fix property editor to make changes if popup closed (remake)Yuri Roubinsky2021-06-051-31/+39
|
* Rename Quat to QuaternionMarcel Admiraal2021-06-041-6/+6
|
* Rename Variant TRANSFORM to TRANSFORM3DAaron Franke2021-06-031-4/+4
| | | Also _transform to _transform3d
* Rename Transform to Transform3D in coreAaron Franke2021-06-031-2/+2
|
* Improve the editor themeHugo Locurcio2021-04-271-1/+0
| | | | | | | | | | The editor theme now makes use of rounded corners and less borders to follow modern visual trends. The default theme's colors were also tweaked to make the blue hue more subtle (similar to the Arc theme, which was removed as a consequence). The Alien theme was replaced by a Breeze Dark theme, which should blend in well with the KDE theme.
* Add Various ColorPicker shapesKongfa Waroros2021-04-061-0/+3
|