summaryrefslogtreecommitdiffstats
path: root/modules/gridmap/grid_map_editor_plugin.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Modules: Don't build editor-specific classes in templatesRémi Verschelde2022-03-281-1481/+0
| | | | | They're moved to an `editor` subfolder so that we can easily handle them separately.
* Remove duplicate editor settings definitionskobewi2022-03-061-2/+2
|
* Remove unimplemented set_clip() methodkobewi2022-03-021-30/+0
|
* Convert _notification methods to switch - Chunk CJakob Bouchard2022-02-161-9/+11
|
* Remove the EditorNode parameter from EditorPlugins create methodstrollodel2022-02-141-1/+1
| | | | Remove EditorNode usage from the Navigation editor plugin.
* Remove most EditorNode constructor parameters and fieldstrollodel2022-02-141-8/+5
|
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-0/+1
|
* Revert "Add missing SNAME macro optimization to all theme methods call"Rémi Verschelde2022-02-081-1/+1
| | | | | | | | This reverts commit a988fad9a092053434545c32afae91ccbdfbe792. As discussed in #57725 and clarified in #57788, `SNAME` is not meant to be used everywhere but only in critical code paths. For theme methods specifically, it was by design that only getters use `SNAME` and not setters.
* Add missing SNAME macro optimization to all theme methods calljmb4622022-02-061-1/+1
|
* Rename String::is_subsequence_ofi to String::is_subsequence_ofnWilson E. Alvarez2022-01-261-1/+1
|
* Merge pull request #56619 from timothyqiu/left-right-paletteRémi Verschelde2022-01-181-4/+4
|\
| * Allow showing both left and right side panelsHaoyu Qiu2022-01-081-4/+4
| |
* | Fix theming update in several editor classesYuri Roubinsky2022-01-161-4/+9
|/
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-2/+2
| | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* align to horizontal_alignment, valign to vertical_alignment, relatedNathan Franke2021-12-091-3/+3
|
* Rename built-in `SGN()` macro to `SIGN()`Hugo Locurcio2021-11-161-1/+1
| | | | | This matches the name of the GDScript function (except it's uppercase here).
* Use "enum class" for input enumsAaron Franke2021-11-121-31/+31
|
* Implemented SkeletonEditorGizmoSilc Renew2021-10-071-19/+29
| | | | Co-authored-by: Lyuma <xn.lyuma@gmail.com>
* implement individual mesh transform for meshlibrary itemsVincent2021-09-091-0/+6
|
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-1/+1
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Make action names translatableHaoyu Qiu2021-07-311-1/+1
|
* Use const references where possible for List range iteratorsRémi Verschelde2021-07-251-4/+4
|
* Use C++ iterators for Lists in many situationsAaron Franke2021-07-231-12/+7
|
* Optimize StringName usagereduz2021-07-181-4/+4
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Improvements to Label's layout optionsHendrik Brucker2021-07-041-1/+1
| | | | | | - Added options to trim the text in case it overruns - Added more autowrap modes - Improved line breaking, which ignores trailing spaces
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-5/+5
|
* Merge pull request #48070 from KoBeWi/greedmapRémi Verschelde2021-06-171-0/+10
|\ | | | | Fix GridMap still drawing when Alt+Tabbing
| * Fix GridMap still drawing when Alt+Tabbingkobewi2021-04-221-0/+10
| |
* | Remove GridMap's "Lock View" option and a related method.Riteo Siuga2021-06-161-22/+0
| | | | | | | | | | | | | | Apparently this feature utilized a completely commented out 7+ years old method, effectively doing nothing. Since it was designed with a completely different editor design in mind it is pretty much incompatible and as such it's best to remove it for now.
* | Rename Transform to Transform3D in coreAaron Franke2021-06-031-9/+9
| |
* | Rename "Control" key to "Ctrl" and add "_pressed" suffix to all ↵Lightning_A2021-05-071-8/+8
|/ | | | InputEventWithModifiers properties/methods
* Rename ButtonList enum and members to MouseButtonAaron Franke2021-03-231-10/+10
|
* Use real_t in GridMap and VariantParserAaron Franke2021-03-191-3/+4
|
* Fix LineEdit minimum widthreduz2021-02-121-1/+1
| | | | | -Changed theme setting name to make more sense of what it does -Reduced amount of minimum characters, so minimum size is smaller.
* Initialize class/struct variables with default values in modules/Rafał Mikrut2021-02-081-12/+1
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Merge pull request #44569 from madmiraal/rename-unselect-deselectRémi Verschelde2020-12-281-1/+1
|\ | | | | Rename unselect to deselect
| * Rename unselect to deselectMarcel Admiraal2020-12-211-1/+1
| |
* | Rename Control margin to offsetMarcel Admiraal2020-12-231-1/+1
|/
* Put misc. 3D tool visible instances on their own layerPedro J. Estébanez2020-11-261-0/+4
| | | | This makes that visible stuff invisible to ReflectionProbes, whose preview in the editor shouldn't involve them.
* Update GridMap to use Vector3i instead of three intsAaron Franke2020-07-021-27/+30
|
* Remove ToolButton in favor of ButtonHugo Locurcio2020-06-191-2/+4
| | | | | | | | | | | ToolButton has no redeeming differences with Button; it's just a Button with the Flat property enabled by default. Removing it avoids some confusion when creating GUIs. Existing ToolButtons will be converted to Buttons, but the Flat property won't be enabled automatically. This closes https://github.com/godotengine/godot-proposals/issues/1081.
* Split `Geometry` singleton into `Geometry2D` and `Geometry3D`Andrii Doroshenko (Xrayez)2020-05-271-1/+0
| | | | Extra `_2d` suffixes are removed from 2D methods accoringly.
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-41/+78
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-104/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Enforce use of bool literals instead of integersRémi Verschelde2020-05-141-2/+2
| | | | | Using clang-tidy's `modernize-use-bool-literals`. https://clang.llvm.org/extra/clang-tidy/checks/modernize-use-bool-literals.html
* Revert "Renamed plane's d to distance"Rémi Verschelde2020-05-101-2/+2
| | | | | | | This reverts commit ec7b481170dcd6a7b4cf0e6c1221e204ff7945f3. This was wrong, `d` is not a distance but the `d` constant in the parametric equation `ax + by + cz = d` describing the plane.
* Renamed plane's d to distanceMarcus Elg2020-05-101-2/+2
|
* Merge pull request #37717 from qarmin/world_fixRémi Verschelde2020-05-041-6/+6
|\ | | | | Change non-existent World to World3D