summaryrefslogtreecommitdiffstats
path: root/modules/navigation/navigation_mesh_editor_plugin.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Modules: Don't build editor-specific classes in templatesRémi Verschelde2022-03-281-156/+0
| | | | | They're moved to an `editor` subfolder so that we can easily handle them separately.
* Convert _notification methods to switch - Chunk CJakob Bouchard2022-02-161-4/+6
|
* Remove the EditorNode parameter from EditorPlugins create methodstrollodel2022-02-141-3/+2
| | | | Remove EditorNode usage from the Navigation editor plugin.
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-0/+1
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Node3D gizmo improvementsjfons2021-07-231-2/+2
| | | | | | | | * Clean-up of node_3d_editor_plugin.{h,cpp}: removed unused code, fixed some bugs. * Moved node_3d_editor_gizmos.{h,cpp} to editor/plugins. * Added support for multiple gizmos per node. This means custom gizmos will no longer override the built-in ones and that multiple gizmos can be used in more complex nodes. * Added support for handle IDs. When adding handles to a gizmo, an ID can be specified for each one, making it easier to work with gizmos that have a variable number of handles. * Added support for subgizmos, selectable elements that can be transformed without needing a node of their own. By overriding _subgizmo_intersect_frustum() and/or _subgizmo_intersect_ray() gizmos can define which subgizmos should be selected on a region or click selection. Subgizmo transformations are applied using get/set/commit virtual methods, similar to how handles work.
* Optimize StringName usagereduz2021-07-181-2/+2
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Rename `GdNavigationServer` to `GodotNavigationServer`Rémi Verschelde2021-06-301-0/+154
And rename `gdnavigation` module to simply `navigation`.