summaryrefslogtreecommitdiffstats
path: root/platform/osx/export/export_plugin.h
Commit message (Collapse)AuthorAgeFilesLines
* Rename OSX to macOS and iPhoneOS to iOS.bruvzg2022-07-211-137/+0
|
* Add a new HashSet templatereduz2022-05-201-1/+1
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Replace most uses of Map by HashMapreduz2022-05-161-2/+2
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Make FileAccess and DirAccess classes reference counted.bruvzg2022-04-111-2/+2
|
* Merge pull request #58455 from bruvzg/export_scriptRémi Verschelde2022-03-181-0/+1
|\
| * [Export] Add "export console script" option for Linux, macOS, and Windows ↵bruvzg2022-03-141-0/+1
| | | | | | | | exports.
* | Implement GDExtension export plugin.bruvzg2022-03-161-1/+1
|/
* Improve compilation speed (forward declarations/includes cleanup)Hendrik Brucker2022-02-121-1/+0
|
* Cleanup and move char functions to the `char_utils.h` header.bruvzg2022-02-041-1/+1
|
* [Export] Instead of removing unsupported options, hide it.bruvzg2022-01-221-0/+1
|
* [macOS export] Implements ad-hoc signing on Linux/Windows, adds extra ↵bruvzg2022-01-181-2/+3
| | | | privacy settings, entitlements warnings and error checking.
* Merge pull request #56047 from piiertho/feature/osx-sign-directoryRémi Verschelde2022-01-051-0/+7
|\
| * OSX: Add signing of directory structure in Library when exporting for OSX.Pierre-Thomas Meisels2021-12-281-0/+7
| | | | | | | | OSX: Add exporting of folder structure in PlugIns when exporting for OSX.
* | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
|/ | | | Happy new year to the wonderful Godot community!
* Make platform feature tag names lowercaseHugo Locurcio2021-08-311-1/+1
| | | | | | | | | | | | | | Feature tag names are still case-sensitive, but this makes built-in feature tags more consistent. - `Windows` -> `windows` - `OSX` -> `osx` - `LinuxBSD` -> `linuxbsd` - `Android` -> `android` - `iOS` -> `ios` - `HTML5` -> `html5` - `JavaScript` -> `javascript` - `UWP` -> `uwp`
* Split osx platform export template into multiple filesSergey Minakov2021-08-121-0/+128