summaryrefslogtreecommitdiffstats
path: root/scene/2d/animated_sprite_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@87318a2fb7fffeb72adca934e31915be077c3d1fSpartan3222024-11-061-2/+4
|\
| * Compile certain `CanvasItem._edit_*()` functions with `DEBUG_ENABLED`Michael Alexsander2024-11-021-2/+4
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Cleanup of raw `nullptr` checks with `Ref`A Thousand Ships2024-08-311-2/+2
| | | | Using `is_valid/null` over checks with `nullptr` or `ERR_FAIL_NULL` etc.
* Fix Issue #94145 Incorrect text in the Node Configuration Warning dialogValeriy Molchanov2024-07-091-1/+1
| | | | | | | | | | | | | | | | | | Fix some translations Revert "Fix some translations" This reverts commit 61e586ef84fb962eefdc14593241c1d8b0fb7b6b. Revert "Fix Issue #94145 Incorrect text in the Node Configuration Warning dialog" This reverts commit d0832dc5e7f0657744780cdfc97ed40772ea717c. msgid warnings.push_back(RTR("A SpriteFrames resource must be created or set in the \"Sprite Frames\" revert editor/translations/editor
* Add alternative pixel roundingMark DiBarry2024-06-291-1/+1
|
* Fix AnimationSprite2D/3D::play using wrong end_frameRobocraft9992024-06-261-1/+4
| | | | On playing a different animation to the current backwards will start the new animation on the last animations last frame not the new ones
* Use Core/Scene stringnames consistentlykobewi2024-05-131-5/+4
|
* Add shorthand for using singleton string nameskobewi2024-05-111-7/+7
|
* Reduce and prevent unnecessary random-access to `List`A Thousand Ships2024-05-041-1/+1
| | | | | | | | | Random-access access to `List` when iterating is `O(n^2)` (`O(n)` when accessing a single element) * Removed subscript operator, in favor of a more explicit `get` * Added conversion from `Iterator` to `ConstIterator` * Remade existing operations into other solutions when applicable
* Optimise Object's `get_argument_options`Micky2024-02-291-1/+4
|
* Revert "Update Node::get_configuration_warnings signature"Rémi Verschelde2024-02-171-2/+2
| | | | This reverts commit d3852deaa450d77edb30df2bb1c77bd7bc45befc.
* Stabilize snapping 2D transforms to pixelAdam Scott2024-02-121-1/+2
| | | | Co-authored-by: Danni <34800072+KeyboardDanni@users.noreply.github.com>
* Update Node::get_configuration_warnings signatureRedMser2024-02-081-2/+2
|
* Merge pull request #86733 from Mickeon/autocompletion-more-animated-spriteRémi Verschelde2024-01-031-5/+7
|\ | | | | | | Add autocompletion options for AnimatedSprite's other play methods
| * Add autocompletion options for AnimatedSprite's other play methodsMicky2024-01-031-5/+7
| |
* | Fix missing autocompletion for inheriting classesMicky2024-01-031-1/+1
|/
* Add property change guards to Sprite2D and AnimatedSprite2DMika Viskari2023-12-161-0/+16
|
* [Scene,Main] Replace `ERR_FAIL_COND` with `ERR_FAIL_NULL` where applicableA Thousand Ships2023-09-121-1/+1
|
* Fix `AnimatedSprite2D` autoplay warningNinni Pipping2023-03-231-2/+2
| | | | | Changing of autoplay when changing `SpriteFrames` is not done by the user and warning is unhelpful
* Fix AnimatedSprite play() don't redraw immediatelySilc Renew2023-01-291-1/+2
|
* Make AnimatedSprite's playback API consistent with AnimationPlayerSilc Renew2023-01-261-91/+216
|
* Merge pull request #65609 from dalexeev/animated-spriteRémi Verschelde2023-01-051-40/+33
|\ | | | | | | `AnimatedSprite{2D,3D}` improvements
| * `AnimatedSprite{2D,3D}` improvementsDanil Alexeev2023-01-051-40/+33
| | | | | | | | | | * Add support for individual frame duration to `SpriteFrames`. * Various minor improvements.
* | One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
|/ | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Change return type of `get_configuration_warnings` to `PackedStringArray`Marc Gilleron2022-09-191-2/+2
|
* Fix outdated warning in AnimatedSprite2DMicky2022-09-181-1/+1
|
* Merge pull request #65148 from Mickeon/animated-sprite-negative-speed-scaleRémi Verschelde2022-09-161-27/+27
|\ | | | | | | Allow negative `speed_scale` in AnimatedSprite2D & 3D
| * Allow negative `speed_scale` in AnimatedSprite2D & 3DMicky2022-09-131-27/+27
| | | | | | | | | | | | | | If the `speed_scale` is set to a negative value, the animation plays in reverse. The second parameter of `play()` still reverses as before. if `speed_scale` and the second parameter of `play()` is true, the animation plays forward. Also updates the documentation to better describe the pausing and playing behaviour.
* | Don't store frame of playing AnimatedSpritekobewi2022-09-121-0/+8
|/
* Harmonise AnimatedSprite3D and its 2D counterpartMicky2022-09-091-26/+32
| | | | | | | | Add the following properties to AnimatedSprite3D: - `backwards` parameter in `play()`; - `speed_scale`. Both classes' internals are more similar, down to the line spacings. They've also been updated to be clearer and less inconsistent (e.g. `!frames.is_valid()` -> `frames.is_null()`, use SceneStringNames instead of CoreStringNames, rename the internal _queue_update to _queue_redraw)
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-9/+9
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* Fix AnimatedSprite2D & 3D animation list in inspectorjmb4622022-08-261-4/+7
|
* Make `_validate_property` a multilevel methodYuri Sizov2022-08-221-13/+13
|
* Fix no `hint_string` for `frame` property in `AnimatedSprite`skleonc2022-07-031-1/+4
|
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-1/+1
|
* Fix AnimatedSprite doesn't emit animation_finished when changing playback ↵Haoyu Qiu2022-05-161-0/+1
| | | | direction
* Add autocompletion for AnimatedSprite.play()Haoyu Qiu2022-05-051-0/+11
|
* String: Remove TTR and DTR defines in non-tools buildRémi Verschelde2022-03-281-1/+1
| | | | | This ensures we don't use TTR in runtime code, as it's specifically meant to source translations for the editor.
* Fix AnimatedSprite infinite loopHaoyu Qiu2022-02-281-5/+5
|
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-1/+0
|
* Vectors: Use clear() and has().Anilforextra2022-02-021-1/+1
| | | | | | Use clear() instead of resize(0). Use has() instead of "find(p_val) != -1".
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Merge pull request #51235 from AnilBK/awkward-funcsRémi Verschelde2021-12-101-12/+7
|\
| * Fixed awkwardly named AnimatedSprite Setters.Anilforextra2021-08-041-12/+7
| |
* | Replace String comparisons with "", String() to is_empty()Nathan Franke2021-12-091-1/+1
| | | | | | | | | | | | Also: - Adds two stress tests to test_string.h - Changes to .empty() on std::strings
* | Fix _validate_property on AnimatedSprite 2D and 3DJonathan Gollnick2021-12-081-1/+1
| |
* | Fix rendering centered odd-size texture in AnimatedSprite2D/AnimatedSprite3Dkleonc2021-10-031-3/+2
| |
* | Fix some unnecessary includesAaron Franke2021-08-131-1/+0
| |