summaryrefslogtreecommitdiffstats
path: root/scene/2d/line_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@87318a2fb7fffeb72adca934e31915be077c3d1fSpartan3222024-11-061-1/+1
|\
| * Compile certain `CanvasItem._edit_*()` functions with `DEBUG_ENABLED`Michael Alexsander2024-11-021-1/+1
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Add closed property to Line2DMewPurPur2023-09-111-30/+33
|
* Unify and streamline connecting to Resource changeskobewi2023-07-171-5/+4
|
* Display `BitField[Enum]` in docs to distinguish from `Enum`Danil Alexeev2023-06-151-5/+0
|
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-19/+19
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* Clarify the Line2D, Curve2D/3D documentation and fix parameter namesYuri Sizov2022-08-151-4/+4
|
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-1/+1
|
* Merge pull request #57436 from AnilBK/change-scopesRémi Verschelde2022-03-131-3/+3
|\ | | | | Scope Changes for some variables.
| * Code quality cleanup for some variable scopes.Anilforextra2022-02-101-3/+3
| |
* | Add a property hint for the Line2D Round Precision propertyHugo Locurcio2022-02-171-5/+2
| | | | | | | | | | This prevents choosing extremely high values which cause performance issues for no visual benefit.
* | Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-2/+2
|/
* Vectors: Use clear() and has().Anilforextra2022-02-021-1/+1
| | | | | | Use clear() instead of resize(0). Use has() instead of "find(p_val) != -1".
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Rename `remove()` to `remove_at()` when removing by indexLightning_A2021-11-231-1/+1
|
* Line2D::set_point_position Fail if passed index is out of boundskleonc2021-02-211-0/+1
|
* Initialize class variables with default values in scene/ [1/2]Rafał Mikrut2021-02-071-9/+0
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Fixup `ColorRamp` to `Gradient` renamesAndrii Doroshenko (Xrayez)2020-10-251-1/+1
|
* Split `Geometry` singleton into `Geometry2D` and `Geometry3D`Andrii Doroshenko (Xrayez)2020-05-271-1/+2
| | | | Extra `_2d` suffixes are removed from 2D methods accoringly.
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-6/+12
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-4/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Make Line2D be white by defaultTomasz Chabora2020-04-261-1/+1
|
* Renaming of servers for coherency.Juan Linietsky2020-03-271-1/+1
| | | | | | | | | | VisualServer -> RenderingServer PhysicsServer -> PhysicsServer3D Physics2DServer -> PhysicsServer2D NavigationServer -> NavigationServer3D Navigation2DServer -> NavigationServer2D Also renamed corresponding files.
* Signals: Manually port most of remaining connect_compat usesRémi Verschelde2020-02-281-8/+5
| | | | | | | | It's tedious work... Some can't be ported as they depend on private or protected methods of different classes, which is not supported by callable_mp (even if it's a class inherited by the current one).
* Variant: Added 64-bit packed arrays, renamed Variant::REAL to FLOAT.Juan Linietsky2020-02-251-2/+2
| | | | | | | | | | | | | | | | | | | | | - Renames PackedIntArray to PackedInt32Array. - Renames PackedFloatArray to PackedFloat32Array. - Adds PackedInt64Array and PackedFloat64Array. - Renames Variant::REAL to Variant::FLOAT for consistency. Packed arrays are for storing large amount of data and creating stuff like meshes, buffers. textures, etc. Forcing them to be 64 is a huge waste of memory. That said, many users requested the ability to have 64 bits packed arrays for their games, so this is just an optional added type. For Variant, the float datatype is always 64 bits, and exposed as `float`. We still have `real_t` which is the datatype that can change from 32 to 64 bits depending on a compile flag (not entirely working right now, but that's the idea). It affects math related datatypes and code only. Neither Variant nor PackedArray make use of real_t, which is only intended for math precision, so the term is removed from there to keep only float.
* Reworked signal connection system, added support for Callable and Signal ↵Juan Linietsky2020-02-201-4/+4
| | | | objects and made them default.
* PoolVector is gone, replaced by VectorJuan Linietsky2020-02-181-6/+6
| | | | | Typed `PoolTypeArray` types are now renamed `PackedTypeArray` and are sugar for `Vector<Type>`.
* Bugfixes and ability to better specify filter and repeat modes everywhere.Juan Linietsky2020-02-111-2/+1
| | | | Removes antialiased flag for draw_* methods.
* A lot of progress with canvas rendering, still far from working.Juan Linietsky2020-02-111-2/+2
|
* Texture refactorJuan Linietsky2020-02-111-3/+3
| | | | | | | | -Texture renamed to Texture2D -TextureLayered as base now inherits 2Darray, cubemap and cubemap array -Removed all references to flags in textures (they will go in the shader) -Texture3D gone for now (will come back later done properly) -Create base rasterizer for RenderDevice, RasterizerRD
* Don't compile editor-only function when tools=noGilles Roudière2020-01-091-0/+2
|
* Merge pull request #34726 from nekomatata/polygon2d-antialiasing-fixRémi Verschelde2020-01-031-1/+1
|\ | | | | Fixed antialiasing option for Polygon2D with concave/hollow shapes
| * Fixed antialiasing option for Polygon2DPouleyKetchoupp2020-01-011-1/+1
| | | | | | | | | | | | Some cases were not handled properly for Polygon2D after making changes in common code to fix Line2D antialiasing. Added an option for drawing polygons to differentiate the two use cases. Fixes #34568
* | Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
|/ | | | | | | | | | | Happy new year to the wonderful Godot community! We're starting a new decade with a well-established, non-profit, free and open source game engine, and tons of further improvements in the pipeline from hundreds of contributors. Godot will keep getting better, and we're looking forward to all the games that the community will keep developing and releasing with it.
* Fixed antialiased option for Polygon2D / Line2DPouleyKetchoupp2019-11-281-2/+16
| | | | | | | | | | Polygon2D: The property wasn't used anymore after switching from canvas_item_add_polygon() to canvas_item_add_triangle_array() for drawing. Line2D: Added the same property as for Polygon2D & fixed smooth line drawing to use indices correctly. Fixes #26823
* Merge pull request #28565 from CedNaru/CurvedWidthLine2DRémi Verschelde2019-07-011-35/+65
|\ | | | | Added a Width Curve to Line2D + UVs fix
| * Added a Width Curve to Line2D + UVs fixTristan Grespinet2019-06-191-35/+65
| |
* | Fix uninitialized variables in Line2D, JSONParseResult and TileMapRémi Verschelde2019-06-301-0/+1
| |
* | Some code changed with Clang-Tidyqarmin2019-06-261-2/+1
| |
* | Fix error macro calls not ending with semicolonRémi Verschelde2019-06-111-1/+1
| | | | | | | | | | | | | | It's not necessary, but the vast majority of calls of error macros do have an ending semicolon, so it's best to be consistent. Most WARN_DEPRECATED calls did *not* have a semicolon, but there's no reason for them to be treated differently.
* | Fix 2D Line crashqarmin2019-06-061-0/+1
|/
* Add optional position argument for add_point in Line2DKanabenki2019-04-081-3/+7
|
* Added method to clear all points in Line2DChaosus2019-03-191-0/+10
|
* Update copyright statements to 2019Rémi Verschelde2019-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* -Moved EditorDefaultValue to ClassDB, made it coreJuan Linietsky2018-11-081-6/+6
| | | | -Removed one and zero hints for properties, replaced by default value
* Make core/ includes absolute, remove subfolders from include pathRémi Verschelde2018-09-121-1/+1
| | | | | | This allows more consistency in the manner we include core headers, where previously there would be a mix of absolute, relative and include path-dependent includes.