summaryrefslogtreecommitdiffstats
path: root/scene/3d/remote_transform_3d.cpp
Commit message (Expand)AuthorAgeFilesLines
* Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
* Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
* Fix super call in various `get_configuration_warnings` methodsA Thousand Ships2024-09-051-1/+1
* Propagate reset_physics_interpolation through RemoteTransform2D/3DValden2024-05-281-0/+10
* Revert "Update Node::get_configuration_warnings signature"Rémi Verschelde2024-02-171-2/+2
* Update Node::get_configuration_warnings signatureRedMser2024-02-081-2/+2
* Remove unnecessary `this->` expressionsA Thousand Ships2024-01-291-1/+1
* Fix cannot update remote after disabling `use_global_coordinates` in `RemoteT...风青山2023-10-151-1/+24
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
* Move EulerOrder enum to math_defs.h and global scopeAaron Franke2022-11-021-2/+2
* Change return type of `get_configuration_warnings` to `PackedStringArray`Marc Gilleron2022-09-191-2/+2
* String: Remove TTR and DTR defines in non-tools buildRémi Verschelde2022-03-281-1/+1
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-2/+1
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
* Refactored Node3D rotation modesreduz2021-10-251-2/+2
* Rename `is_a_parent_of()` to `is_ancestor_of()`Lightning_A2021-06-211-1/+1
* Rename Transform to Transform3D in coreAaron Franke2021-06-031-4/+4
* Use Array for node configuration warningsNathan Franke2021-04-111-8/+5
* Initialize class variables with default values in scene/ [1/2]Rafał Mikrut2021-02-071-5/+0
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
* Rename empty() to is_empty()Marcel Admiraal2020-12-281-1/+1
* Update all get_configuration_warning to retrieve warnings from the parentArrowInAKnee2020-05-161-2/+7
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-9/+18
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-11/+0
* Renamed 2D and 3D nodes to make their types explicitJuan Linietsky2020-03-271-0/+223