| Commit message (Expand) | Author | Age | Files | Lines |
* | Rename Godot Physics classes from *SW to Godot* | PouleyKetchoupp | 2021-10-18 | 1 | -353/+0 |
* | Initialize variables in servers/physics | qarmin | 2021-09-15 | 1 | -5/+5 |
* | Proper support for custom mass properties in 2D/3D physics bodies | PouleyKetchoupp | 2021-09-06 | 1 | -31/+37 |
* | Add AnimatableBody inherited from StaticBody for moving platforms | PouleyKetchoupp | 2021-08-31 | 1 | -2/+5 |
* | Merge pull request #49471 from nekomatata/body-state-sync-callback | Juan Linietsky | 2021-08-31 | 1 | -86/+12 |
|\ |
|
| * | Clean physics direct body state usage in 2D and 3D physics | PouleyKetchoupp | 2021-08-25 | 1 | -86/+12 |
* | | Fix point gravity calculation | PouleyKetchoupp | 2021-08-24 | 1 | -1/+1 |
|/ |
|
* | Fix applied rotation from moving platforms in move_and_slide | PouleyKetchoupp | 2021-08-09 | 1 | -0/+6 |
* | Unexpose _direct_state_changed in PhysicsBody | rafallus | 2021-04-22 | 1 | -3/+2 |
* | Godot Physics solver optimization | PouleyKetchoupp | 2021-04-12 | 1 | -8/+0 |
* | Update copyright statements to 2021 | Rémi Verschelde | 2021-01-01 | 1 | -2/+2 |
* | Rename empty() to is_empty() | Marcel Admiraal | 2020-12-28 | 1 | -1/+1 |
* | make 2d constraint solving more deterministic by solving in push order | Jordan Schidlowsky | 2020-12-04 | 1 | -5/+7 |
* | Reorganized core/ directory, it was too fatty already | reduz | 2020-11-07 | 1 | -1/+1 |
* | Add override keywords. | Marcel Admiraal | 2020-07-10 | 1 | -31/+31 |
* | Refactor physics force and impulse code | Aaron Franke | 2020-06-02 | 1 | -9/+9 |
* | Style: Enforce braces around if blocks and loops | Rémi Verschelde | 2020-05-14 | 1 | -5/+10 |
* | Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocks | Rémi Verschelde | 2020-05-14 | 1 | -13/+0 |
* | Style: clang-format: Disable AllowShortIfStatementsOnASingleLine | Rémi Verschelde | 2020-05-10 | 1 | -1/+2 |
* | Replace NULL with nullptr | lupoDharkael | 2020-04-02 | 1 | -1/+1 |
* | More server renames for consistency after #37361 | Rémi Verschelde | 2020-03-28 | 1 | -5/+5 |
* | Renaming of servers for coherency. | Juan Linietsky | 2020-03-27 | 1 | -18/+18 |
* | ObjectID converted to a structure, fixes many bugs where used incorrectly as ... | Juan Linietsky | 2020-02-12 | 1 | -1/+1 |
* | Update copyright statements to 2020 | Rémi Verschelde | 2020-01-01 | 1 | -2/+2 |
* | Fix custom inertia in physics2d, closes#30838 | RaphaelHunter | 2019-08-22 | 1 | -0/+1 |
* | Update copyright statements to 2019 | Rémi Verschelde | 2019-01-01 | 1 | -2/+2 |
* | Make core/ includes absolute, remove subfolders from include path | Rémi Verschelde | 2018-09-12 | 1 | -1/+1 |
* | Merge pull request #20381 from AndreaCatania/phymat_2 | Juan Linietsky | 2018-08-07 | 1 | -8/+0 |
|\ |
|
| * | Removed physics material combination mode. Added rough and absorbent paramete... | Andrea Catania | 2018-08-07 | 1 | -8/+0 |
* | | Reduce unnecessary COW on Vector by make writing explicit | Hein-Pieter van Braam | 2018-07-26 | 1 | -3/+3 |
* | | Modified RigidBody, PhysicsDirectBodyState, PhysicsServer, and their respecti... | Tiger Caldwell | 2018-07-24 | 1 | -1/+24 |
|/ |
|
* | Implemented physics material | AndreaCatania | 2018-05-11 | 1 | -0/+8 |
* | Add missing copyright headers and fix formatting | Rémi Verschelde | 2018-01-05 | 1 | -0/+1 |
* | Update copyright statements to 2018 | Rémi Verschelde | 2018-01-01 | 1 | -2/+2 |
* | Rename pos to position in user facing methods and variables | letheed | 2017-09-20 | 1 | -3/+3 |
* | Use HTTPS URL for Godot's website in the headers | Rémi Verschelde | 2017-08-27 | 1 | -1/+1 |
* | Improve cleanup of physics constraints | Pedro J. Estébanez | 2017-08-01 | 1 | -0/+1 |
* | -Trigger shapes removed in 2D, they became obsolete long ago when areas could... | Juan Linietsky | 2017-06-23 | 1 | -15/+0 |
* | Add "Godot Engine contributors" copyright line | Rémi Verschelde | 2017-04-08 | 1 | -0/+1 |
* | A Whole New World (clang-format edition) | Rémi Verschelde | 2017-03-05 | 1 | -117/+124 |
* | Use real_t as floating point type in physics code. | Ferenc Arn | 2017-02-13 | 1 | -12/+12 |
* | Type renames: | Juan Linietsky | 2017-01-11 | 1 | -3/+3 |
* | ObjectTypeDB was renamed to ClassDB. Types are meant to be more generic to Va... | Juan Linietsky | 2017-01-02 | 1 | -1/+1 |
* | Welcome in 2017, dear changelog reader! | Rémi Verschelde | 2017-01-01 | 1 | -1/+1 |
* | RigidBody2D (add_force, set_inertia): new methods. | Josh Grams | 2016-04-26 | 1 | -0/+6 |
* | RigidBody2D: rename apply_impulse(pos) to offset. | Josh Grams | 2016-04-24 | 1 | -3/+3 |
* | Merge pull request #2698 from Faless/add_area_fix | Juan Linietsky | 2016-01-23 | 1 | -3/+19 |
|\ |
|
| * | Fix Body (and Body2D) add_area / remove_area when area have multiple shapes | Fabio Alessandrelli | 2015-12-02 | 1 | -3/+19 |
* | | physics state properly returns contact metadata, closes #1979 | Juan Linietsky | 2016-01-03 | 1 | -1/+1 |
* | | skip the first integration in physics bodies, fixes #2213 | Juan Linietsky | 2016-01-02 | 1 | -0/+1 |