summaryrefslogtreecommitdiffstats
path: root/servers/physics_2d/shape_2d_sw.cpp
Commit message (Expand)AuthorAgeFilesLines
* Rename Godot Physics classes from *SW to Godot*PouleyKetchoupp2021-10-181-995/+0
* Use range iterators for `Map`Lightning_A2021-09-301-5/+5
* Merge pull request #52668 from qarmin/cppcheck_servers_physicsCamille Mohr-Daurat2021-09-161-10/+0
|\
| * Initialize variables in servers/physicsqarmin2021-09-151-10/+0
* | Rename WorldMarginShape to WorldBoundaryShapePouleyKetchoupp2021-09-141-6/+6
|/
* Optimize area detection and intersect_shape queries with concave shapesPouleyKetchoupp2021-08-271-2/+4
* Rename RayShape to SeparationRayShapePouleyKetchoupp2021-08-241-6/+6
* Rename slips_on_slope to slide_on_slopePouleyKetchoupp2021-08-241-2/+2
* Fix RayShape collision detectionPouleyKetchoupp2021-08-241-8/+1
* Restore RayShape as a regular shape typePouleyKetchoupp2021-08-241-0/+40
* Rename LineShape2D to WorldMarginShape2DHugo Locurcio2021-08-141-6/+6
* Make radius & height in CapsuleShape2D independentTomasz Chabora2021-08-111-9/+9
* Remove infinite inertia and ray shapes from CharacterBodyPouleyKetchoupp2021-08-101-40/+0
* Merge pull request #47678 from madmiraal/fix-47436.1Rémi Verschelde2021-04-061-0/+4
|\
| * Check for empty ConcavePolygonShape2D before checking for intersectionMarcel Admiraal2021-04-061-0/+4
* | Merge pull request #47675 from madmiraal/fix-47436Rémi Verschelde2021-04-061-0/+1
|\ \
| * | Check ConvexPolygonShape2D point count before calcuating moment of inertiaMarcel Admiraal2021-04-061-0/+1
| |/
* / Ensure ConvexPolygonShape support count variable is initialisedMarcel Admiraal2021-04-061-1/+2
|/
* Use real_t in physics codeAaron Franke2021-01-281-4/+12
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
* Rename Vector2.tangent() to Vector2.orthogonal()Marcel Admiraal2020-12-061-4/+4
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-1/+1
* Split `Geometry` singleton into `Geometry2D` and `Geometry3D`Andrii Doroshenko (Xrayez)2020-05-271-4/+4
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-23/+42
* Style: Enforce separation line between function definitionsRémi Verschelde2020-05-141-0/+1
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-104/+0
* Replace NULL with nullptrlupoDharkael2020-04-021-2/+2
* Variant: Added 64-bit packed arrays, renamed Variant::REAL to FLOAT.Juan Linietsky2020-02-251-2/+2
* PoolVector is gone, replaced by VectorJuan Linietsky2020-02-181-15/+13
* Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
* Added release function to PoolVector::Access.Ibrahn Sahir2019-07-061-1/+1
* Fix some shape2d get_moment_of_inertia erroryakun.zhang2019-05-201-8/+5
* Small fixes, mostly dupicated codeqarmin2019-04-081-1/+1
* Merge pull request #26103 from nekomatata/area2d-rectangle-collision-fixRémi Verschelde2019-02-211-2/+5
|\
| * Area2d rectangle collision check doesn't ignore the first pixel row and colum...PouleyKetchoupp2019-02-211-2/+5
* | Add -Wshadow=local to warnings and fix reported issues.marxin2019-02-201-12/+12
|/
* Core: Ensure classes match their header filenameRémi Verschelde2019-02-121-1/+1
* Update copyright statements to 2019Rémi Verschelde2019-01-011-2/+2
* Make core/ includes absolute, remove subfolders from include pathRémi Verschelde2018-09-121-2/+2
* Reduce unnecessary COW on Vector by make writing explicitHein-Pieter van Braam2018-07-261-8/+8
* Resolves crash on shape2D culling for empty Concave shapesCrazy-P2018-04-121-0/+4
* Merge pull request #16530 from AndreaCatania/raysRémi Verschelde2018-02-191-2/+7
|\
| * Improved ray shape (2D and 3D) by addiing the possibility to act as regular s...Andrea Catania2018-02-191-2/+7
* | Clean up some bad words from code commentsArtem Varaksa2018-02-171-1/+1
|/
* Add missing copyright headers and fix formattingRémi Verschelde2018-01-051-0/+1
* Update copyright statements to 2018Rémi Verschelde2018-01-011-2/+2
* Dead code tells no talesRémi Verschelde2017-08-271-0/+1
* Use HTTPS URL for Godot's website in the headersRémi Verschelde2017-08-271-1/+1
* Refactor 'treshold' to 'threshold'Poommetee Ketson2017-07-081-4/+4
* renamed all Rect2.pos to Rect2.positionalexholly2017-06-041-8/+8