summaryrefslogtreecommitdiffstats
path: root/scene/2d/visibility_notifier_2d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Rename VisibilityNotifierXD to VisibleOnScreenNotifierXDreduz2021-06-161-213/+0
| | | | | | * Renames for 2D and 3D * Class name was confusing, given both 2D and 3D have a "visible" property that is unrelated to actual on-screen visibility. * New name makes it clear that this is about visibility on screen.
* Refactor VisibilityNotifierreduz2021-06-161-224/+76
| | | | | | * Works from RenderinServer * Accurately tells when on or off-scren, its no longer approximate. * VisibilityEnabler also simplified to use the process mode instead.
* More explanatory names for RigidBody modesPouleyKetchoupp2021-06-041-1/+1
| | | | | | | | | MODE_DYNAMIC instead of MODE_RIGID MODE_DYNAMIC_LOCKED instead of MODE_CHARACTER No more special case for sleeping behavior for MODE_DYNAMIC_LOCKED (MODE_CHARACTER was forcing the body not to sleep, which is redundant with can_sleep and wasn't done in Bullet).
* Use Array for node configuration warningsNathan Franke2021-04-111-7/+4
| | | | Previously, the warnings were passed as a string and delimitation of which were hard coded at each implementation.
* Removed _change_notifyreduz2021-02-101-2/+0
| | | | | | -For inspector refresh, the inspector now detects if a property change by polling a few times per second and then does update the control if so. This process is very cheap. -For property list refresh, a new signal (property_list_changed) was added to Object. _change_notify() is replaced by notify_property_list_changed() -Changed all objects using the old method to the signal, or just deleted the calls to _change_notify(<property>) since they are unnecesary now.
* Initialize class variables with default values in scene/ [1/2]Rafał Mikrut2021-02-071-2/+0
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Rename empty() to is_empty()Marcel Admiraal2020-12-281-1/+1
|
* Reorganized core/ directory, it was too fatty alreadyreduz2020-11-071-1/+1
| | | | | | -Removed FuncRef, since Callable makes it obsolete -Removed int_types.h as its obsolete in c++11+ -Changed color names code
* Update all get_configuration_warning to retrieve warnings from the parentArrowInAKnee2020-05-161-2/+7
|
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-15/+29
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: Enforce separation line between function definitionsRémi Verschelde2020-05-141-0/+1
| | | | | | | | | | | | | | | | | | | | | | | I couldn't find a tool that enforces it, so I went the manual route: ``` find -name "thirdparty" -prune \ -o -name "*.cpp" -o -name "*.h" -o -name "*.m" -o -name "*.mm" \ -o -name "*.glsl" > files perl -0777 -pi -e 's/\n}\n([^#])/\n}\n\n\1/g' $(cat files) misc/scripts/fix_style.sh -c ``` This adds a newline after all `}` on the first column, unless they are followed by `#` (typically `#endif`). This leads to having lots of places with two lines between function/class definitions, but clang-format then fixes it as we enforce max one line of separation. This doesn't fix potential occurrences of function definitions which are indented (e.g. for a helper class defined in a .cpp), but it's better than nothing. Also can't be made to run easily on CI/hooks so we'll have to be careful with new code. Part of #33027.
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-34/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Merge pull request #31938 from KoBeWi/a_welcome_lagRémi Verschelde2020-05-111-4/+13
|\ | | | | Fix VisibilityEnabler2D behavior on start
| * Fix VisibilityEnabler2D behavior on startTomasz Chabora2020-05-081-4/+13
| |
* | Rename more 2D and 3D nodes to follow conventionRémi Verschelde2020-03-271-3/+3
| | | | | | | | Rename editor plugins to match the new node names.
* | Renamed 2D and 3D nodes to make their types explicitJuan Linietsky2020-03-271-3/+3
| | | | | | | | Fixes #30736.
* | Added a Window node, and made it the scene root.Juan Linietsky2020-03-261-1/+1
| | | | | | | | Still a lot of work to do.
* | Fix visibility enabler flag togglingTomasz Chabora2020-03-171-12/+9
|/
* Signals: Manually port most of remaining connect_compat usesRémi Verschelde2020-02-281-2/+2
| | | | | | | | It's tedious work... Some can't be ported as they depend on private or protected methods of different classes, which is not supported by callable_mp (even if it's a class inherited by the current one).
* Reworked signal connection system, added support for Callable and Signal ↵Juan Linietsky2020-02-201-2/+2
| | | | objects and made them default.
* Don't compile editor-only function when tools=noGilles Roudière2020-01-091-9/+10
|
* Fix wrong disconnect in callback in VisibilityNotifier 3DАлександр Растриженков2020-01-021-2/+0
|
* Update copyright statements to 2020Rémi Verschelde2020-01-011-2/+2
| | | | | | | | | | | Happy new year to the wonderful Godot community! We're starting a new decade with a well-established, non-profit, free and open source game engine, and tons of further improvements in the pipeline from hundreds of contributors. Godot will keep getting better, and we're looking forward to all the games that the community will keep developing and releasing with it.
* Improve the node configuration warning displayHugo Locurcio2019-07-091-1/+1
| | | | | | | - Refer to properties explicitly when possible - When multiple warnings are returned, always separate them by one blank line to make them easier to distinguish - Improve grammar and formatting
* Update copyright statements to 2019Rémi Verschelde2019-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* Remove the "is able to sleep" condition for adding visibility notifier ↵Juan Linietsky2018-11-191-1/+1
| | | | | | nodes, fixes #19659 I think the previous behavior was more useful, but I understand it's not obvious or discoverable.
* Make core/ includes absolute, remove subfolders from include pathRémi Verschelde2018-09-121-1/+1
| | | | | | This allows more consistency in the manner we include core headers, where previously there would be a mix of absolute, relative and include path-dependent includes.
* Remove the selection rect for nodes that do not require itGilles Roudiere2018-04-031-0/+4
|
* Renamed tree_exited to tree_exiting. tree_exited is now used for actual out ↵Juan Linietsky2018-01-121-2/+2
| | | | | | of tree notification. Updated doc accordingly.
* Add missing copyright headers and fix formattingRémi Verschelde2018-01-051-0/+1
| | | | | | Using `misc/scripts/fix_headers.py` on all Godot files. Some missing header guards were added, and the header inclusion order was fixed in the Bullet module.
* Update copyright statements to 2018Rémi Verschelde2018-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* Rework the canvas_item API for further improves to the canvas item editorGilles Roudiere2017-11-191-1/+1
|
* Bind unbound enums, rearrange some by valuePoommetee Ketson2017-10-221-2/+2
|
* Renamed fixed_process to physics_processAndreaCatania2017-09-301-9/+9
|
* Use HTTPS URL for Godot's website in the headersRémi Verschelde2017-08-271-1/+1
|
* Convert Object::cast_to() to the static versionHein-Pieter van Braam2017-08-241-8/+8
| | | | | | | | | | | | Currently we rely on some undefined behavior when Object->cast_to() gets called with a Null pointer. This used to work fine with GCC < 6 but newer versions of GCC remove all codepaths in which the this pointer is Null. However, the non-static cast_to() was supposed to be null safe. This patch makes cast_to() Null safe and removes the now redundant Null checks where they existed. It is explained in this article: https://www.viva64.com/en/b/0226/
* Merge pull request #10351 from neikeq/enums-are-for-the-weakJuan Linietsky2017-08-211-7/+7
|\ | | | | ClassDB: Provide the enum name of integer constants
| * ClassDB: Provide the enum name of integer constantsIgnacio Etcheverry2017-08-201-8/+7
| |
* | Removes editor_hint from SceneTreeIgnacio Etcheverry2017-08-191-7/+7
|/
* few bugs fixed thanks to explicit bool constructor and clang.Juan Linietsky2017-08-051-0/+1
| | | | explicit bool constructor has thus now been removed, as it served it's mission!
* Add "Godot Engine contributors" copyright lineRémi Verschelde2017-04-081-0/+1
|
* A Whole New World (clang-format edition)Rémi Verschelde2017-03-051-125/+93
| | | | | | | | | | | | | | | | | | | | | | | | I can show you the code Pretty, with proper whitespace Tell me, coder, now when did You last write readable code? I can open your eyes Make you see your bad indent Force you to respect the style The core devs agreed upon A whole new world A new fantastic code format A de facto standard With some sugar Enforced with clang-format A whole new world A dazzling style we all dreamed of And when we read it through It's crystal clear That now we're in a whole new world of code
* Rename the _MD macro to D_METHODHein-Pieter van Braam2017-02-131-6/+6
| | | | | | This new name also makes its purpose a little clearer This is a step towards fixing #56
* Remove use of _SCS from ADD_METHODHein-Pieter van Braam2017-02-131-7/+7
| | | | This saves typing and is a step towards fixing #56
* Must now register with set_transform_notify() to get ↵Juan Linietsky2017-01-121-0/+1
| | | | NOTIFICATION_TRANSFORM_CHANGED
* Renamed most signals so they refer to:Juan Linietsky2017-01-121-10/+10
| | | | | -An action being requested to the user in present tense: (ie, draw, gui_input, etc) -A notification that an action happened, in past tense (ie, area_entered, modal_closed, etc).
* -Conversion of most properties to a simpler syntax, easier to use by scriptJuan Linietsky2017-01-041-6/+6
| | | | | | -Modified help to display properties GDScript can still not make use of them, though.
* ObjectTypeDB was renamed to ClassDB. Types are meant to be more generic to ↵Juan Linietsky2017-01-021-6/+6
| | | | | | | | Variant. All usages of "type" to refer to classes were renamed to "class" ClassDB has been exposed to GDScript. OBJ_TYPE() macro is now GDCLASS()
* Welcome in 2017, dear changelog reader!Rémi Verschelde2017-01-011-1/+1
| | | | | | | | That year should bring the long-awaited OpenGL ES 3.0 compatible renderer with state-of-the-art rendering techniques tuned to work as low as middle end handheld devices - without compromising with the possibilities given for higher end desktop games of course. Great times ahead for the Godot community and the gamers that will play our games!