summaryrefslogtreecommitdiffstats
path: root/scene/3d/camera_3d.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@f128f383e892865379cb8b14e7bcc9858efe2973Spartan3222024-11-271-2/+5
|\
| * Merge pull request #98489 from Flarkk/fix_project_positionThaddeus Crews2024-11-271-2/+5
| |\ | | | | | | | | | Fix Camera3D::project_position() when depth=zfar
| | * Fix Camera3D::project_position() when depth=zfarFlorent Guiocheau2024-10-241-2/+5
| | |
* | | Merge commit godotengine/godot@c6c464cf9ae56e8b68620af65125dd980d0e8122Spartan3222024-11-021-0/+1
|\| |
| * | Add "Game" editor for better runtime debuggingMichael Alexsander2024-10-301-0/+1
| | |
* | | Merge commit godotengine/godot@8004c7524fb9f43425c4d6f614410a76678e0f7cSpartan3222024-10-301-4/+4
|\| |
| * | Set clang-format `RemoveSemicolon` rule to `true`Adam Scott2024-10-251-4/+4
| |/ | | | | | | - Set clang-format `Standard` rule to `c++20`
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* Fixed Timestep Interpolation (3D)Ricardo Buring2024-07-071-3/+135
| | | | | | | Adds 3D fixed timestep interpolation to the rendering server. This does not yet include support for multimeshes or particles. Co-authored-by: lawnjelly <lawnjelly@gmail.com>
* Expose is_part_of_edited_scene()kobewi2024-04-261-3/+3
|
* Split monolithic physics class filessmix82024-02-271-1/+0
| | | | Splits monolithic physics class files.
* Implement hooks into rendererBastiaan Olij2024-02-181-0/+17
|
* Rename camera near and far private members to avoid conflict with Windows.h ↵ACB2024-01-151-32/+32
| | | | defines
* Prevent Camera3D.current from being set to true automatically in the editor.addmix2023-12-011-1/+1
|
* Tweak Camera3D `size` property hint to make dragging more usefulHugo Locurcio2023-10-011-1/+1
| | | | Values greater than the maximum can still be entered.
* Unify and streamline connecting to Resource changeskobewi2023-07-171-3/+2
|
* Fix Camera3D project_* methods not accounting for frustum offsetBauke Conijn2023-06-201-35/+33
| | | | | This does not fix Camera3D::project_ray_normal(). Adds Camera3D::get_camera_projection() and exposes it to GDScript
* Use NULL instead of COND checks when appropriateNinni Pipping2023-06-101-2/+2
| | | | Restricted to scene
* Changed Camera3D Ortho Size LimitiiMidknightii2023-01-241-2/+2
|
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Add safety-checks before some servers `free()`Adam Scott2022-12-291-0/+2
|
* Make Camera3D gizmo the same aspect ratio as its viewportHaoyu Qiu2022-11-151-0/+11
|
* Implement Physical Light Units as an optional setting.clayjohn2022-08-311-11/+49
| | | | | | This allows light sources to be specified in physical light units in addition to the regular energy multiplier. In order to avoid loss of precision at high values, brightness values are premultiplied by an exposure normalization value. In support of Physical Light Units this PR also renames CameraEffects to CameraAttributes.
* Replace Array return types with TypedArraykobewi2022-08-221-1/+6
|
* Make `_validate_property` a multilevel methodYuri Sizov2022-08-221-2/+0
|
* Allow more precise adjustments of orthogonal/frustum size in Camera3DHugo Locurcio2022-08-031-1/+1
|
* Implement Vector4, Vector4i, Projectionreduz2022-07-231-8/+8
| | | | | | | | | | | | | Implement built-in classes Vector4, Vector4i and Projection. * Two versions of Vector4 (float and integer). * A Projection class, which is a 4x4 matrix specialized in projection types. These types have been requested for a long time, but given they were very corner case they were not added before. Because in Godot 4, reimplementing parts of the rendering engine is now possible, access to these types (heavily used by the rendering code) becomes a necessity. **Q**: Why Projection and not Matrix4? **A**: Godot does not use Matrix2, Matrix3, Matrix4x3, etc. naming convention because, within the engine, these types always have a *purpose*. As such, Godot names them: Transform2D, Transform3D or Basis. In this case, this 4x4 matrix is _always_ used as a _Projection_, hence the naming.
* Use suffixes for units in nodes and resourcesAaron Franke2022-05-191-6/+6
|
* Make `{call,set,notify}_group()` immediate by defaultHugo Locurcio2022-05-051-2/+0
| | | | | | | This results in less surprising behavior out of the box. Internal usages were modified to keep the existing behavior identical there.
* Rename Basis get_axis to get_column, remove redundant methodsAaron Franke2022-05-031-3/+3
|
* Rename theme properties to include underscoresFireForge2022-04-231-2/+2
| | | | | | | | | | | | | | - check_vadjust -> check_v_adjust - close_h_ofs -> close_h_offset - close_v_ofs -> close_v_offset - commentfocus -> comment_focus - hseparation -> h_separation - ofs -> offset - selectedframe -> selected_frame - state_machine_selectedframe -> state_machine_selected_frame - table_hseparation -> table_h_separation - table_vseparation -> table_v_separation - vseparation -> v_separation
* Allow `size` values as low as `0.001` in Camera3D's orthogonal/frustum modeHugo Locurcio2022-04-081-2/+2
| | | | | | | This allows for lower field of view (or higher zoom) in orthogonal and frustum camera modes. The property hint also allows setting the size with greater precision.
* Style: Cleanup single-line blocks, semicolons, dead codeRémi Verschelde2022-02-161-6/+0
| | | | | Remove currently unused implementation of TextureBasisU, could be re-added later on if needed and ported.
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-2/+4
|
* CameraMatrix: Pre-allocate Vector in get_projection_planes().Anilforextra2022-01-131-5/+7
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Rename `PROPERTY_USAGE_NOEDITOR` to `PROPERTY_USAGE_NO_EDITOR`Hugo Locurcio2021-11-031-3/+3
| | | | | This is consistent with other constants that include `NO`, such as `PROPERTY_HINT_COLOR_NO_ALPHA`.
* Refactored Node3D rotation modesreduz2021-10-251-0/+2
| | | | | | | | | * Made the Basis euler orders indexed via enum. * Node3D has a new rotation_order property to choose Euler rotation order. * Node3D has also a rotation_mode property to choose between Euler, Quaternion and Basis Exposing these modes as well as the order makes Godot a lot friendlier for animators, which can choose the best way to interpolate rotations. The new *Basis* mode makes the (exposed) transform property obsolete, so it was removed (can still be accessed by code of course).
* add failure condition for get_pyramid_shape_rid() when camera3d is not in ↵Mark Riedesel2021-10-111-0/+1
| | | | tree. fixes #53564
* Fix missing argument names in bindingsRémi Verschelde2021-10-091-9/+9
| | | | | | While at it, tweak some boolean setters to use `p_enabled` for the bool. Also renames `draw_minimap()` to `set_draw_minimap()`.
* Remove ClippedCamera3Dreduz2021-10-041-215/+29
| | | | | | * Usage was always confusing for users * The ability to generate a pyramid shape was moved to Camera3D * SpringArm3D now casts using the camera pyramid shape if no shape is supplied.
* Display a editor gizmo icon for Listener3DHugo Locurcio2021-09-161-4/+0
| | | | | | | | The icon was present in `editor/icons/`, but it was never implemented in the editor gizmos code. This also removes some unused gizmo drawing code (overridden methods that are no longer called anywhere).
* Fix some unnecessary includesAaron Franke2021-08-131-3/+1
|
* Uniformize layer names, script methods and documentationPouleyKetchoupp2021-08-121-19/+25
| | | | | | | - Back to 1-based layer names to make it clearer in editor UI - Layer bit accessors are renamed to layer value and 1-based too - Uniform errors and documentation in render and physics - Fix a few remaining collision_layer used in place of collision_mask
* Use real_t in 3D nodesAaron Franke2021-08-031-21/+21
|
* Node3D gizmo improvementsjfons2021-07-231-4/+4
| | | | | | | | * Clean-up of node_3d_editor_plugin.{h,cpp}: removed unused code, fixed some bugs. * Moved node_3d_editor_gizmos.{h,cpp} to editor/plugins. * Added support for multiple gizmos per node. This means custom gizmos will no longer override the built-in ones and that multiple gizmos can be used in more complex nodes. * Added support for handle IDs. When adding handles to a gizmo, an ID can be specified for each one, making it easier to work with gizmos that have a variable number of handles. * Added support for subgizmos, selectable elements that can be transformed without needing a node of their own. By overriding _subgizmo_intersect_frustum() and/or _subgizmo_intersect_ray() gizmos can define which subgizmos should be selected on a region or click selection. Subgizmo transformations are applied using get/set/commit virtual methods, similar to how handles work.
* add viewport.get_camera_2d()Josh Chandler2021-07-031-10/+10
| | | | | | * there is now a more clear distinction between camera_2d and camera_3d functions in the engine code * simplified camera2d's exported interface - now everything happens directly with the 'current' variable and make_current and clear_current are no longer exposed- there were some situations where calling one instead of set_current would result in incomplete results * rebased to current godot master
* Fix editor suffixes and degrees conversionreduz2021-06-301-3/+3
| | | | | | | | | | | | | * Functions to convert to/from degrees are all gone. Conversion is done by the editor. * Use PROPERTY_HINT_ANGLE instead of PROPERTY_HINT_RANGE to edit radian angles in degrees. * Added possibility to add suffixes to range properties, use "min,max[,step][,suffix:<something>]" example "0,100,1,suffix:m" * In general, can add suffixes for EditorSpinSlider Not covered by this PR, will have to be addressed by future ones: * Ability to switch radians/degrees in the inspector for angle properties (if actually wanted). * Animations previously made will most likely break, need to add a way to make old ones compatible. * Only added a "px" suffix to 2D position and a "m" one to 3D position, someone needs to go through the rest of the engine and add all remaining suffixes. * Likely also need to track down usage of EditorSpinSlider outside properties to add suffixes to it too.
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-1/+1
|