summaryrefslogtreecommitdiffstats
path: root/scene/3d/collision_object_3d.h
Commit message (Collapse)AuthorAgeFilesLines
* Split monolithic physics class filessmix82024-02-271-184/+0
| | | | Splits monolithic physics class files.
* Revert "Update Node::get_configuration_warnings signature"Rémi Verschelde2024-02-171-1/+1
| | | | This reverts commit d3852deaa450d77edb30df2bb1c77bd7bc45befc.
* Update Node::get_configuration_warnings signatureRedMser2024-02-081-1/+1
|
* Clear monitoring in `Area*` when its space changes to invalid风青山2023-12-151-0/+2
| | | | | | So that it can work properly when the space changes to valid again. Change `space` in advance to prevent disabled areas from being queried again.
* Error when removing a phycics node during a physics callbackJuan Linietsky2023-01-071-0/+7
| | | | | | | | * This behavior is not allowed, the error text suggests using call_deferred(). * Added a check in Node::remove_child to prevent future crashes of this type. * Fixed a performance regression introduced by #36244. Fixes #63718, probably other crashes too.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* Change return type of `get_configuration_warnings` to `PackedStringArray`Marc Gilleron2022-09-191-1/+1
|
* Expose input interaction virtual functions in CollisionObjectrafallus2022-08-291-0/+2
|
* Replace Array return types with TypedArraykobewi2022-08-221-1/+1
|
* Add collision weight to PhysicsBody for penetrations must be avoidedSilc Renew2022-08-181-0/+4
| | | | Co-authored-by: Juan Linietsky <reduzio@gmail.com>
* Code quality: Fix header guards consistencyRémi Verschelde2022-07-251-1/+1
| | | | | Adds `header_guards.sh` bash script, used in CI to validate future changes. Can be run locally to fix invalid header guards.
* Add a new HashSet templatereduz2022-05-201-1/+1
| | | | | * Intended to replace RBSet in most cases. * Optimized for iteration speed
* Replace most uses of Map by HashMapreduz2022-05-161-2/+2
| | | | | | | | | | | | * Map is unnecessary and inefficient in almost every case. * Replaced by the new HashMap. * Renamed Map to RBMap and Set to RBSet for cases that still make sense (order matters) but use is discouraged. There were very few cases where replacing by HashMap was undesired because keeping the key order was intended. I tried to keep those (as RBMap) as much as possible, but might have missed some. Review appreciated!
* Store ObjectID instead of raw pointer for Shape OwnersHaoyu Qiu2022-01-251-1/+1
|
* Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
| | | | Happy new year to the wonderful Godot community!
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-1/+3
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Fix some unnecessary includesAaron Franke2021-08-131-2/+0
|
* Uniformize layer names, script methods and documentationPouleyKetchoupp2021-08-121-4/+4
| | | | | | | - Back to 1-based layer names to make it clearer in editor UI - Layer bit accessors are renamed to layer value and 1-based too - Uniform errors and documentation in render and physics - Fix a few remaining collision_layer used in place of collision_mask
* Support for 3D sync to physicsPouleyKetchoupp2021-07-151-0/+5
| | | | Same implementation as in 2D.
* Add support for controlling physics nodes' behavior when disabledPouleyKetchoupp2021-06-301-0/+23
| | | | | | | | | | | New property disable_mode to set different behaviors: Remove: remove from physics simulation MakeStatic: change body mode to static (doesn't affect area and soft body) KeepActive: do nothing Extra change: Handle disable/enable node state with specific notifications, in order to differentiate global pause from disabled nodes.
* Rename Transform to Transform3D in coreAaron Franke2021-06-031-4/+4
|
* Use the correct method in shape_owner_remove_shapetrollodel2021-05-091-1/+1
|
* Create CollisionObject3D debug shapes using RStrollodel2021-05-051-5/+10
|
* Move collision layer and mask into CollisionObject.Marcel Admiraal2021-04-201-0/+15
|
* Fix crashes with CollisionObject debug shapesPouleyKetchoupp2021-04-121-0/+2
| | | | | | | | | | MeshInstance added as child nodes for CollisionObject debug shapes can be invalidated while deleting the collision object (child nodes are deleted first), which caused accesses to invalid memory in shape_owner_remove_shape that lead to random crashes. Also optimized accesses to shapes to avoid copy-on-write on each iteration.
* Use Array for node configuration warningsNathan Franke2021-04-111-1/+1
| | | | Previously, the warnings were passed as a string and delimitation of which were hard coded at each implementation.
* Allow CollisionObject3D to show collision shape meshestrollodel2021-02-241-0/+7
| | | | | Add an editor gizmo to CollisionObject3D. CollisionShape3D no longer shows collision shapes directly.
* Initialize class variables with default values in scene/ [1/2]Rafał Mikrut2021-02-071-12/+7
|
* Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* Add override keywords.Marcel Admiraal2020-07-101-1/+1
|
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-2/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* Replace NULL with nullptrlupoDharkael2020-04-021-1/+1
|
* Renamed 2D and 3D nodes to make their types explicitJuan Linietsky2020-03-271-0/+119
Fixes #30736.