summaryrefslogtreecommitdiffstats
path: root/editor/plugins/shader_graph_editor_plugin.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Drop old ShaderGraph code, obsoleted by VisualShaderRémi Verschelde2018-08-241-2932/+0
|
* Change ".." punctuation for "..." in editor strings (#16507)Hugo Locurcio2018-04-221-4/+4
|
* Improve popup menus usabilityPedro J. Estébanez2018-04-071-2/+0
| | | | | | | | | | | | It seems that popups were intended to "grab" the mouse click that triggered them, but their intent was being lost. This commit does the necessary changes to let it happen and updates items that were trying to get advantage of it, because the semantics of `Control::grab_click_focus()` have changed a bit. Namely, it must be called **before** showing the modal. This allows to popup a menu and activate an item in it in a single click-point-release cycle, instead of having to click once to open the menu and once more to pick an item. This ability is extended even to context menus activated with the RMB (or any other mouse button, for that matter). The editor benefits from this in the context menu of the tree dock, which has been patched to opt-in for this feature. This improves UX a bit by saving unnecessary clicks. From now on, `PopupMenu` always grabs the click and also invalidates the first button release unless the mouse has moved (that's what `set_invalidate_click_until_motion()` was doing and now it's removed), so there is no longer the need of doing both things at every point a pop-up menu is shown.
* Update copyright statements to 2018Rémi Verschelde2018-01-011-2/+2
| | | | Happy new year to the wonderful Godot community!
* Remove set_area_as_parent_rect and replace it by ↵Gilles Roudiere2017-09-221-1/+1
| | | | set_anchors_and_margins_preset(PRESET_WIDE)
* Rename pos to position in user facing methods and variablesletheed2017-09-201-8/+8
| | | | | | | | | | | Rename user facing methods and variables as well as the corresponding C++ methods according to the folloming changes: * pos -> position * rot -> rotation * loc -> location C++ variables are left as is.
* Dead code tells no talesRémi Verschelde2017-08-271-16/+1
|
* Use HTTPS URL for Godot's website in the headersRémi Verschelde2017-08-271-1/+1
|
* Cleanup tons of obsolete commented out codeRémi Verschelde2017-08-261-1/+3
| | | | | Mostly in EditorNode, dropping some obsolete editor plugins and also a cleanup of ProjectSettings/EditorSettings.
* Convert Object::cast_to() to the static versionHein-Pieter van Braam2017-08-241-17/+17
| | | | | | | | | | | | Currently we rely on some undefined behavior when Object->cast_to() gets called with a Null pointer. This used to work fine with GCC < 6 but newer versions of GCC remove all codepaths in which the this pointer is Null. However, the non-static cast_to() was supposed to be null safe. This patch makes cast_to() Null safe and removes the now redundant Null checks where they existed. It is explained in this article: https://www.viva64.com/en/b/0226/
* [#9292] Renamed Image.put_pixel() to set_pixel().ducdetronquito2017-07-071-1/+1
|
* Removal of InputEvent as built-in Variant type..Juan Linietsky2017-05-201-9/+9
| | | | this might cause bugs I haven't found yet..
* Rename [gs]et_pos to [gs]et_position for ControlsSergey Pusnei2017-04-101-8/+8
| | | | | | | | Control set_pos -> set_position Control set_global_pos -> set_global_position [gs]et_mouse_pos -> [gs]et_mouse_position [gs]et_global_mouse_pos -> [gs]et_global_mouse_position fixes #8005
* Add "Godot Engine contributors" copyright lineRémi Verschelde2017-04-081-0/+1
|
* Fix typos in source code using codespellRémi Verschelde2017-03-241-1/+1
| | | | From https://github.com/lucasdemarchi/codespell
* A Whole New World (clang-format edition)Rémi Verschelde2017-03-051-4/+2
| | | | | | | | | | | | | | | | | | | | | | | | I can show you the code Pretty, with proper whitespace Tell me, coder, now when did You last write readable code? I can open your eyes Make you see your bad indent Force you to respect the style The core devs agreed upon A whole new world A new fantastic code format A de facto standard With some sugar Enforced with clang-format A whole new world A dazzling style we all dreamed of And when we read it through It's crystal clear That now we're in a whole new world of code
* Refactoring: rename tools/editor/ to editor/Rémi Verschelde2017-03-051-0/+2948
The other subfolders of tools/ had already been moved to either editor/, misc/ or thirdparty/, so the hiding the editor code that deep was no longer meaningful.