summaryrefslogtreecommitdiffstats
path: root/scene/2d/touch_screen_button.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Merge commit godotengine/godot@cb411fa960f0b7fdbd97dcdb4c90f9346360ee0eSpartan3222024-11-121-1/+1
|\
| * Core: Integrate `Ref::instantiate` where possibleThaddeus Crews2024-11-101-1/+1
| |
* | Merge commit godotengine/godot@87318a2fb7fffeb72adca934e31915be077c3d1fSpartan3222024-11-061-2/+2
|\|
| * Compile certain `CanvasItem._edit_*()` functions with `DEBUG_ENABLED`Michael Alexsander2024-11-021-2/+2
| |
* | Merge commit godotengine/godot@c6c464cf9ae56e8b68620af65125dd980d0e8122Spartan3222024-11-021-0/+1
|\|
| * Add "Game" editor for better runtime debuggingMichael Alexsander2024-10-301-0/+1
| |
* | Fix copyright headers referring to GodotSpartan3222024-10-271-2/+2
| |
* | Rebrand preambles to RedotDubhghlas McLaughlin2024-10-111-0/+2
|/ | | | | | | | | | | | | | | | | | | | | | Credits: Co-authored-by: Skogi <skogi.b@gmail.com> Co-authored-by: Spartan322 <Megacake1234@gmail.com> Co-authored-by: swashberry <swashdev@pm.me> Co-authored-by: Christoffer Sundbom <christoffer_karlsson@live.se> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: McDubh <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: Dubhghlas McLaughlin <103212704+mcdubhghlas@users.noreply.github.com> Co-authored-by: radenthefolf <radenthefolf@gmail.com> Co-authored-by: John Knight <80524176+Tekisasu-JohnK@users.noreply.github.com> Co-authored-by: Adam Vondersaar <adam.vondersaar@uphold.com> Co-authored-by: decryptedchaos <nixgod@gmail.com> Co-authored-by: zaftnotameni <122100803+zaftnotameni@users.noreply.github.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: wesam <108880473+wesamdev@users.noreply.github.com> Co-authored-by: Mister Puma <MisterPuma80@gmail.com> Co-authored-by: Aaron Benjamin <lifeartstudios@gmail.com> Co-authored-by: SingleError <isaaconeoneone@gmail.com> Co-authored-by: Bioblaze Payne <BioblazePayne@gmail.com>
* [Scene] Add SceneStringNames::pressedA Thousand Ships2024-05-141-2/+2
|
* Use Core/Scene stringnames consistentlykobewi2024-05-131-6/+5
|
* Add shorthand for using singleton string nameskobewi2024-05-111-4/+4
|
* Unify and streamline connecting to Resource changeskobewi2023-07-171-2/+2
|
* Add compatibility properties to `TouchScreenButton`Ninni Pipping2023-07-021-0/+13
| | | | | | Added support for `3.x` properties: * `normal` -> `texture_normal` * `pressed` -> `texture_pressed`
* Make `TouchScreenButton` connections reference countedNinni Pipping2023-05-171-2/+2
| | | | Prevents errors when assigning the same texture to both slots
* Fix TouchScreenButton not redrawn when texture changesHaoyu Qiu2023-04-231-3/+22
|
* Remove device-id restriction from `TouchScreenButton` input eventsMarkus Sauermann2023-02-171-4/+0
| | | | | | Remove the restriction that only devices with id 0 are used for `TouchScreenButton`-Input events. This allows emulated events to be used for TouchScreenButton.
* One Copyright Update to rule them allRémi Verschelde2023-01-051-29/+29
| | | | | | | | | | | | | | | | | | | | As many open source projects have started doing it, we're removing the current year from the copyright notice, so that we don't need to bump it every year. It seems like only the first year of publication is technically relevant for copyright notices, and even that seems to be something that many companies stopped listing altogether (in a version controlled codebase, the commits are a much better source of date of publication than a hardcoded copyright statement). We also now list Godot Engine contributors first as we're collectively the current maintainers of the project, and we clarify that the "exclusive" copyright of the co-founders covers the timespan before opensourcing (their further contributions are included as part of Godot Engine contributors). Also fixed "cf." Frenchism - it's meant as "refer to / see".
* TouchScreenButton: Fix screen capability checkRémi Verschelde2022-12-081-2/+2
| | | | Fixes #69572.
* Fix Determining Window for TouchscreenMarkus Sauermann2022-12-071-2/+2
| | | | | | | | | DisplayServer::screen_is_touchscreen will likely never utilize its parameter p_screen. This PR replaces this function by DisplayServer::is_touchscreen_available() with the same functionality. This solves the problem, that a SubViewport was used for determining the screen, which resulted in error messages.
* Refactor BitMap and add testsHendrik Brucker2022-09-011-1/+1
| | | | Co-authored-by: Resul Çelik <resul_celik@hotmail.com>
* Rename `CanvasItem.update()` to `queue_redraw()`Micky2022-08-291-11/+11
| | | | | | | | | | Affects a lot of classes. Very thoroughly checked signal connections and deferred calls to this method, add_do_method/add_undo_method calls, and so on. Also renames the internal `_update_callback()` to `_redraw_callback()` for consistency. Just a few comments have also been changed to say "redraw". In CPUParticles2D, there was a private variable with the same name. It has been renamed to `do_redraw`.
* rename translate(d) to translate(d)_local in Transform 2D/3DFabian Keller2022-07-161-2/+2
|
* Fix TouchScreenButton error spamkobewi2022-04-041-3/+1
|
* Use `switch` consistently in `_notification` (`scene` folder)Rémi Verschelde2022-02-151-2/+4
|
* Merge pull request #55665 from KoBeWi/you_touched_my_TouchScreeenButtonRémi Verschelde2022-01-131-24/+24
|\
| * Rename TouchScreenButton's textureskobewi2021-12-061-24/+24
| |
* | Update copyright statements to 2022Rémi Verschelde2022-01-031-2/+2
|/ | | | Happy new year to the wonderful Godot community!
* Entirely removes BIND_VMETHOD in favor of GDVIRTUALreduz2021-08-231-5/+3
| | | | | | | | * `_gui_input`, `_input`, `_unhandled_input` and `_unhandled_key_input` are now regular C++ virutal functions. * Everything else converted to GDVIRTUAL * BIND_VMETHOD is gone, always use the new syntax from now on. Creating `_gui_input` method and using the binder to register events will no longer work, simply override the virtual function now.
* Fix some unnecessary includesAaron Franke2021-08-131-4/+1
|
* Optimize StringName usagereduz2021-07-181-2/+2
| | | | | | | | | | | * Added a new macro SNAME() that constructs and caches a local stringname. * Subsequent usages use the cached version. * Since these use a global static variable, a second refcounter of static usages need to be kept for cleanup time. * Replaced all theme usages by this new macro. * Replace all signal emission usages by this new macro. * Replace all call_deferred usages by this new macro. This is part of ongoing work to optimize GUI and the editor.
* Rename `instance()`->`instantiate()` when it's a verbLightning_A2021-06-191-2/+2
|
* Fix crashes in *_input functionsRafał Mikrut2021-04-051-0/+2
|
* Merge pull request #44737 from KoBeWi/touch_shape_screen_centered_buttonRémi Verschelde2021-02-191-5/+11
|\ | | | | Fix shape_centered property in TouchScreenButton
| * Fix shape_centered property in TouchScreenButtonkobewi2020-12-271-5/+11
| |
* | Initialize class variables with default values in scene/ [1/2]Rafał Mikrut2021-02-071-5/+0
| |
* | Update copyright statements to 2021Rémi Verschelde2021-01-011-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Happy new year to the wonderful Godot community! 2020 has been a tough year for most of us personally, but a good year for Godot development nonetheless with a huge amount of work done towards Godot 4.0 and great improvements backported to the long-lived 3.2 branch. We've had close to 400 contributors to engine code this year, authoring near 7,000 commit! (And that's only for the `master` branch and for the engine code, there's a lot more when counting docs, demos and other first-party repos.) Here's to a great year 2021 for all Godot users 🎆
* | Use rectangle size instead of extents for Shape dimensionsMarcel Admiraal2020-12-081-1/+1
|/
* Style: Enforce braces around if blocks and loopsRémi Verschelde2020-05-141-22/+43
| | | | | Using clang-tidy's `readability-braces-around-statements`. https://clang.llvm.org/extra/clang-tidy/checks/readability-braces-around-statements.html
* Style: clang-format: Disable KeepEmptyLinesAtTheStartOfBlocksRémi Verschelde2020-05-141-40/+0
| | | | | | | | | | | | | | Which means that reduz' beloved style which we all became used to will now be changed automatically to remove the first empty line. This makes us lean closer to 1TBS (the one true brace style) instead of hybridating it with some Allman-inspired spacing. There's still the case of braces around single-statement blocks that needs to be addressed (but clang-format can't help with that, but clang-tidy may if we agree about it). Part of #33027.
* GUI: Touch screen button click area now is synced with its drawMateo Kuruk Miccino2020-05-071-2/+3
| | | | (cherry picked from commit 1cba7fb1804c35917c075e323b6d303f5a900df6)
* Rename InputFilter back to InputRémi Verschelde2020-04-281-3/+3
| | | | | | | | | | | | | | | | It changed name as part of the DisplayServer and input refactoring in #37317, with the rationale that input no longer goes through the main loop, so the previous Input singleton now only does filtering. But the gains in consistency are quite limited in the renaming, and it breaks compatibility for all scripts and tutorials that access the Input singleton via the scripting language. A temporary option was suggested to keep the scripting singleton named `Input` even if its type is `InputFilter`, but that adds inconsistency and breaks C#. Fixes godotengine/godot-proposals#639. Fixes #37319. Fixes #37690.
* Refactored input, goes all via windows now.Juan Linietsky2020-03-261-6/+6
| | | | Also renamed Input to InputFilter because all it does is filter events.
* Added a Window node, and made it the scene root.Juan Linietsky2020-03-261-1/+1
| | | | Still a lot of work to do.
* Effective DisplayServer separation, rename X11 -> LinuxBSDJuan Linietsky2020-03-261-2/+3
|
* Refactored Input, create DisplayServer and DisplayServerX11Juan Linietsky2020-03-261-2/+2
|
* Signals: Manually port most of remaining connect_compat usesRémi Verschelde2020-02-281-2/+2
| | | | | | | | It's tedious work... Some can't be ported as they depend on private or protected methods of different classes, which is not supported by callable_mp (even if it's a class inherited by the current one).
* Added StringName as a variant type.Juan Linietsky2020-02-211-1/+1
| | | | Also changed all relevant properties defined manually to StringName.
* Reworked signal connection system, added support for Callable and Signal ↵Juan Linietsky2020-02-201-2/+2
| | | | objects and made them default.
* Texture refactorJuan Linietsky2020-02-111-6/+6
| | | | | | | | -Texture renamed to Texture2D -TextureLayered as base now inherits 2Darray, cubemap and cubemap array -Removed all references to flags in textures (they will go in the shader) -Texture3D gone for now (will come back later done properly) -Create base rasterizer for RenderDevice, RasterizerRD
* Don't compile editor-only function when tools=noGilles Roudière2020-01-091-5/+7
|